Modify

#20196 closed defect (duplicate)

fastdrow

Reported by: anonymous Owned by: akks
Priority: normal Milestone:
Component: Plugin FastDraw Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

прорисовал часть линии, а потом решил включить плагин fastDrow

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-11-21 14:56:29 +0100 (Sat, 21 Nov 2020)
Revision:17329
Build-Date:2020-11-22 02:30:52
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17329 uk) Linux Ubuntu 18.04.5 LTS
Memory Usage: 1011 MB / 3924 MB (235 MB allocated, but free)
Java version: 11.0.9.1+1-Ubuntu-0ubuntu1.18.04, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Desktop environment: KDE
Java package: openjdk-11-jre:amd64-11.0.9.1+1-0ubuntu1~18.04
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-20ubuntu0.1
Environment variable LANG: uk_UA.UTF-8
libcommons-logging-java: libcommons-logging-java:-
fonts-noto: fonts-noto:all-20171026-2
Dataset consistency test: No problems found

Plugins:
+ CustomizePublicTransportStop (35640)
+ FastDraw (35640)
+ FixAddresses (35640)
+ ImportImagePlugin (35567)
+ Mapillary (1.5.28-1-g937e98c)
+ PicLayer (2a9aa7a)
+ apache-commons (35524)
+ apache-http (35589)
+ buildings_tools (35640)
+ continuosDownload (91)
+ editgpx (35562)
+ ejml (35458)
+ geotools (35458)
+ imagery_offset_db (35640)
+ javafx-unixoid (35655)
+ jaxb (35543)
+ jna (35458)
+ jogl (1.2.3)
+ jts (35458)
+ log4j (35458)
+ mapwithai (1.7.1.1)
+ measurement (35640)
+ opendata (35640)
+ photo_geotagging (35640)
+ photoadjust (35640)
+ public_transport (35640)
+ reltoolbox (35640)
+ todo (30306)
+ utilsplugin2 (35640)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportOneClick&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://raw.githubusercontent.com/osm-ua/josm-style/master/area_fill.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransportV2&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PTStops&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/MapWithAI&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Admin_Boundaries&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
- https://github.com/igitov/forest-josm-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Historic_Stones&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/iD&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Landcover&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NewHighwayColors&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Schools&zip=1

Last errors/warnings:
- 00107,728 W: Неможливо знайти підтримувану проєкцію для шару kadastr 16. Використовуватиметься EPSG:3857.
- 00367,378 W: java.net.SocketTimeoutException: Read timed out. Причина: java.net.SocketTimeoutException: Read timed out
- 00369,011 W: java.net.SocketTimeoutException: Read timed out. Причина: java.net.SocketTimeoutException: Read timed out
- 03861,667 E: Handled by bug report queue: java.lang.IndexOutOfBoundsException: Index: -1, Size: 1
- 03867,811 E: Handled by bug report queue: java.lang.IndexOutOfBoundsException: Index: -1, Size: 1
- 03867,897 W: Попередження - <html>JOSM не міг знайти інформацію про наступні втулки:<ul><li>apache-commons</li><li>reltoolbox</li><li>geotools</li><li>opendata</li><li>public_transport</li><li>FixAddresses</li><li>measurement</li><li>continuosDownload</li><li>jaxb</li><li>editgpx</li><li>utilsplugin2</li><li>jogl</li><li>jna</li><li>PicLayer</li><li>log4j</li><li>CustomizePublicTransportStop</li><li>imagery_offset_db</li><li>photoadjust</li><li>jts</li><li>Mapillary</li><li>ejml</li><li>FastDraw</li><li>todo</li><li>javafx-unixoid</li><li>mapwithai</li><li>photo_geotagging</li><li>ImportImagePlugin</li><li>buildings_tools</li><li>apache-http</li></ul>Втулки не будуть завантажені.</html>
- 03877,819 E: Handled by bug report queue: java.lang.IndexOutOfBoundsException: Index: -1, Size: 1
- 03882,494 E: Handled by bug report queue: java.lang.IndexOutOfBoundsException: Index: -1, Size: 1
- 03882,808 E: Handled by bug report queue: java.lang.IndexOutOfBoundsException: Index: -1, Size: 1
- 03900,768 E: Handled by bug report queue: java.lang.IndexOutOfBoundsException: Index: -1, Size: 1


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.IndexOutOfBoundsException: Index: -1, Size: 1
	at java.base/java.util.LinkedList.checkElementIndex(LinkedList.java:559)
	at java.base/java.util.LinkedList.get(LinkedList.java:480)
	at org.openstreetmap.josm.plugins.fastdraw.DrawnPolyLine.getLastPoint(DrawnPolyLine.java:124)
	at org.openstreetmap.josm.plugins.fastdraw.FastDrawingMode.paint(FastDrawingMode.java:230)
	at org.openstreetmap.josm.gui.MapView.drawTemporaryLayers(MapView.java:648)
	at org.openstreetmap.josm.gui.MapView.drawMapContent(MapView.java:585)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:488)
	at java.desktop/javax.swing.JComponent.paintChildren(JComponent.java:907)
	at java.desktop/javax.swing.JComponent.paint(JComponent.java:1083)
	at java.desktop/javax.swing.JComponent.paintToOffscreen(JComponent.java:5255)
	at java.desktop/javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:246)
	at java.desktop/javax.swing.RepaintManager.paint(RepaintManager.java:1323)
	at java.desktop/javax.swing.JComponent._paintImmediately(JComponent.java:5203)
	at java.desktop/javax.swing.JComponent.paintImmediately(JComponent.java:5013)
	at java.desktop/javax.swing.RepaintManager$4.run(RepaintManager.java:865)
	at java.desktop/javax.swing.RepaintManager$4.run(RepaintManager.java:848)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:848)
	at java.desktop/javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:823)
	at java.desktop/javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:772)
	at java.desktop/javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1890)
	at java.desktop/java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:313)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:770)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:740)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

Attachments (0)

Change History (1)

comment:1 Changed 21 months ago by GerdP

Component: CorePlugin FastDraw
Owner: changed from team to akks
Resolution: duplicate
Status: newclosed

Closed as duplicate of #19590.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain akks.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.