Modify

Opened 3 months ago

Closed 3 months ago

#20194 closed defect (duplicate)

Can't open any folders, therefore can't open osm file

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Open josm
  2. Open "open" (top left icon with blue open folder)
  3. Try to open any folder on my device (like "desktop" or "documents")

What is the expected result?

The folder opening so I can choose the osm file from it to open

What happens instead?

Cursor becomes "wait"-symbol, folder doesn't open

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-11-21 14:56:29 +0100 (Sat, 21 Nov 2020)
Revision:17329
Build-Date:2020-11-22 02:30:52
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17329 en) Linux Ubuntu 18.04.4 LTS
Memory Usage: 147 MB / 962 MB (70 MB allocated, but free)
Java version: 11.0.9.1+1-Ubuntu-0ubuntu1.18.04, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1366x768 (scaling 1.0x1.0)
Maximum Screen Size: 1366x768
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Desktop environment: ubuntu:GNOME
Environment variable LANG: en_US.UTF-8
VM arguments: [-Duser.home=${HOME}]

Last errors/warnings:
- 00029.175 E: Handled by bug report queue: java.nio.file.InvalidPathException: Malformed input or input contains unmappable characters: /home/<user.name>/Desktop/Lesen_H��ren


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: Basic L&F File Loading Thread (49)
java.nio.file.InvalidPathException: Malformed input or input contains unmappable characters: /home/ans/Desktop/Lesen_H��ren
	at java.base/sun.nio.fs.UnixPath.encode(UnixPath.java:145)
	at java.base/sun.nio.fs.UnixPath.<init>(UnixPath.java:69)
	at java.base/sun.nio.fs.UnixFileSystem.getPath(UnixFileSystem.java:279)
	at java.base/java.nio.file.Path.of(Path.java:147)
	at java.base/java.nio.file.Paths.get(Paths.java:69)
	at java.desktop/sun.awt.shell.ShellFolder.getShellFolder(ShellFolder.java:247)
	at java.desktop/javax.swing.filechooser.FileSystemView.getFiles(FileSystemView.java:523)
	at java.desktop/javax.swing.plaf.basic.BasicDirectoryModel$FilesLoader.run0(BasicDirectoryModel.java:290)
	at java.desktop/javax.swing.plaf.basic.BasicDirectoryModel$FilesLoader.run(BasicDirectoryModel.java:279)
	at java.base/java.lang.Thread.run(Thread.java:834)

Attachments (0)

Change History (1)

comment:1 Changed 3 months ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14596.
See ticket:14596#comment:18.
You need to set a proper LANG= which includes non-ASCII symbols.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.