Modify

Opened 2 months ago

Closed 4 weeks ago

#20152 closed defect (fixed)

CCE at GeoJSONReader.parseRoot

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone: 20.12
Component: Core geojson Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. when I open a point layer this issue occurred

2.

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-11-21 14:56:29 +0100 (Sat, 21 Nov 2020)
Build-Date:2020-11-22 02:30:52
Revision:17329
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17329 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 2004 (19041)
Memory Usage: 596 MB / 1820 MB (206 MB allocated, but free)
Java version: 1.8.0_271-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1600x900 (scaling 1.0x1.0)
Maximum Screen Size: 1600x900
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Last errors/warnings:
- 00366.234 E: Handled by bug report queue: java.lang.ClassCastException: javax.json.JsonValueImpl cannot be cast to javax.json.JsonArray
- 00385.985 E: Handled by bug report queue: java.lang.ClassCastException: javax.json.JsonValueImpl cannot be cast to javax.json.JsonArray
- 00391.305 E: Handled by bug report queue: java.lang.ClassCastException: javax.json.JsonValueImpl cannot be cast to javax.json.JsonArray
- 01004.622 E: Handled by bug report queue: java.lang.ClassCastException: javax.json.JsonValueImpl cannot be cast to javax.json.JsonArray


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-0 (58) of main
java.lang.ClassCastException: javax.json.JsonValueImpl cannot be cast to javax.json.JsonArray
	at org.glassfish.json.JsonObjectBuilderImpl$JsonObjectImpl.getJsonArray(JsonObjectBuilderImpl.java:237)
	at org.openstreetmap.josm.io.GeoJSONReader.parseRoot(GeoJSONReader.java:87)
	at org.openstreetmap.josm.io.GeoJSONReader.parse(GeoJSONReader.java:76)
	at org.openstreetmap.josm.io.GeoJSONReader.doParseDataSet(GeoJSONReader.java:408)
	at org.openstreetmap.josm.io.GeoJSONReader.parseDataSet(GeoJSONReader.java:473)
	at org.openstreetmap.josm.gui.io.importexport.GeoJSONImporter.importData(GeoJSONImporter.java:51)
	at org.openstreetmap.josm.gui.io.importexport.FileImporter.importDataHandleExceptions(FileImporter.java:98)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:370)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:320)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:94)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:142)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (7)

comment:1 Changed 2 months ago by GerdP

Can you attach the geojson file, please?

comment:2 Changed 2 months ago by simon04

Priority: criticalnormal

Very likely caused by an illegal GeoJSON file such as:

{"type": "FeatureCollection", "features": {}}

comment:3 Changed 2 months ago by simon04

Keywords: geojson added

comment:4 Changed 2 months ago by simon04

In 17356/josm:

see #20152 - GeoJSONReader: better exception for illegal FeatureCollection

comment:5 Changed 2 months ago by Don-vip

Owner: changed from team to anonymous
Status: newneedinfo

comment:6 Changed 2 months ago by Don-vip

Component: CoreCore geojson
Keywords: geojson removed
Milestone: 20.12
Summary: opening point dataCCE at GeoJSONReader.parseRoot

comment:7 Changed 4 weeks ago by simon04

Resolution: fixed
Status: needinfoclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.