Modify

Opened 10 days ago

Closed 10 days ago

Last modified 8 days ago

#20119 closed enhancement (fixed)

Warning for kerbs with tags smoothness

Reported by: LorenzoStucchi Owned by: team
Priority: normal Milestone: 20.11
Component: Core validator Version:
Keywords: kerb smoothness combinations Cc:

Description

On the validator, a warning is erased when kerbs are mapped with the tag smoothness.

The issue is raised in the combinations validator at line 192 https://josm.openstreetmap.de/browser/josm/trunk/resources/data/validator/combinations.mapcss?order=date#L192

Multiple projects started to mapping the accessibility for people using wheelchairs and the smoothness that presents the quality of the kerb is an important element to be mapped.

Attachments (0)

Change History (12)

comment:1 Changed 10 days ago by skyper

Keywords: kerb smoothness combinations added

Do you have examples? I do not find smoothness as combination for barrier=kerb on taginfo.

comment:2 Changed 10 days ago by skyper

Owner: changed from team to LorenzoStucchi
Status: newneedinfo

comment:3 Changed 10 days ago by LorenzoStucchi

It is not in barrier=kerb but kerb=* here in taginfo. There are 1600 of this combination.

For other examples there are two main projects in Italy that are mapping kerbs with smoothness:

One example of kerb. In that area, there are multiple nodes tagged from the project ViaLibera.

comment:4 Changed 10 days ago by skyper

Owner: changed from LorenzoStucchi to team
Status: needinfonew

comment:5 Changed 10 days ago by skyper

Thanks, so it should not be warned about nodes with kerb=* together with smoothness and we might check the values of kerb:height in numeric.mapcss

comment:6 Changed 10 days ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 17324/josm:

fix #20119 - Don't warn about smoothness on barrier=kerb or kerb=*

comment:7 in reply to:  5 Changed 10 days ago by Klumbumbus

Replying to skyper:

check the values of kerb:height in numeric.mapcss

We use height in our internal preset instead. https://wiki.openstreetmap.org/wiki/Tag:barrier=kerb recommends height too, but https://wiki.openstreetmap.org/wiki/Key:kerb kerb:height.

comment:8 Changed 10 days ago by Klumbumbus

Milestone: 20.10

comment:9 Changed 10 days ago by skyper

height is ok for barrier=kerb on ways but for kerb=* on nodes kerb:height is documented on the wiki page as it is not tied to barrier=kerb but can be used with other tags like highway=crossing without barrier=kerb.

Last edited 10 days ago by skyper (previous) (diff)

comment:10 in reply to:  9 Changed 10 days ago by skyper

Replying to skyper:

height is ok for barrier=kerb on ways but for kerb=* on nodes kerb:height is documented on the wiki page as it is not tied to barrier=kerb but can be used with other tags like highway=crossing without barrier=kerb.

Sorry, was confusing, try it again:
If kerb is not used together with barrier=kerb it is better to use kerb:height instead of height

comment:11 Changed 10 days ago by LorenzoStucchi

Sorry, I'm not confident with the reply option, so I try here to clarify here some aspects.

The tag kerb is used in the nodes, these nodes are parts of the way mapped ashighway=crossing. For example, this kerb is mapped with the tag kerb:height on it. The nodes with the tag kerb should use the tag kerb:heigth for the height of it.

It is hard to have the exact value of height, since it could be provided only in the field, so without JOSM.

comment:12 Changed 8 days ago by Don-vip

Milestone: 20.1020.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.