Modify

Opened 2 months ago

Closed 2 months ago

Last modified 8 weeks ago

#20027 closed defect (duplicate)

Opening preferences in Metal LAF on macOS produces exception

Reported by: Stereo Owned by: team
Priority: major Milestone: 20.11
Component: Core Version:
Keywords: template_report macOS regression Cc:

Description

What steps will reproduce the problem?

  1. Change style to Metal
  2. Open preferences

What is the expected result?

Preferences open

What happens instead?

Exception

Please provide any additional information below. Attach a screenshot if possible.

Revision:17292
Is-Local-Build:true
Build-Date:2020-11-03 00:24:22

Identification: JOSM/1.5 (17292 SVN en_GB) Mac OS X 10.15.7
OS Build number: Mac OS X 10.15.7 (19H2)
Memory Usage: 356 MB / 8192 MB (115 MB allocated, but free)
Java version: 15.0.1+8, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Look and Feel: com.apple.laf.AquaLookAndFeel
Screen: Display 69733632 1680x1050 (scaling 2.0x2.0)
Maximum Screen Size: 1680x1050
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
VM arguments: [--module-path=/private/var/folders/1y/hwgwq23x3jbb7cyj0j998yrh0000gp/T/AppTranslocation/B9256D49-2E58-41FC-9FC6-BD48ADBBA5E7/d/JOSM.app/Contents/app/mods]

Plugins:
+ AddrInterpolation (35583)
+ CommandLine (35583)
+ Create_grid_of_ways (35583)
+ ImportImagePlugin (35248)
+ ImproveWay (29)
+ Mapillary (1.5.27)
+ OpeningHoursEditor (35579)
+ PicLayer (2a9aa7a)
+ RelationDissolve (0.2.0)
+ alignways (35583)
+ apache-commons (35524)
+ apache-http (35092)
+ areaselector (368)
+ austriaaddresshelper (1597341117)
+ auto_tools (73)
+ buildings_tools (35579)
+ changeset-viewer (22)
+ conflation (0.6.6)
+ continuosDownload (91)
+ contourmerge (v0.1.6)
+ ejml (35313)
+ geotools (35169)
+ gridify (1588746833)
+ http2 (35427)
+ imagery-xml-bounds (35546)
+ jaxb (35092)
+ jna (35092)
+ jogl (1.2.3)
+ jts (35122)
+ log4j (35092)
+ opendata (35513)
+ openqa (0.2.0)
+ poly (35248)
+ public_transport (35405)
+ reltoolbox (35602)
+ reverter (35579)
+ shrinkwrap (v1.0.3)
+ splinex (35454)
+ terracer (35579)
+ todo (30306)
+ undelete (35521)
+ utilsplugin2 (35624)
+ wikipedia (1.1.4)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BicycleJunction&preset&zip=1
+ http://osmtools.de/josm/steps.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historic_Stone&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportOneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Bus_lanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/public_bookcase&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Stolpersteine&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportGtfs&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Heritage&zip=1
+ https://gitlab.com/k127/josm-presets/raw/master/diplomatic.xml

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/BesideTheRoad_Speed&zip=1
- https://github.com/simon04/coloured-addresses.mapcss/raw/master/dist/coloured-addresses.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PTStops&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/HiDPISupport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/iD&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Potlach2_access&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/IconTester&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Potlatch2&zip=1

Validator rules:
+ http://www.openrailwaymap.org/validator/openrailwaymap.validator.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Rules/GermanySpecific&zip=1
+ http://www.openrailwaymap.org/validator/de-openrailwaymap.validator.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Rules/MissingWeekdays&zip=1
+ https://raw.githubusercontent.com/nlehuby/transport_mapcss/master/transport.validator.mapcss

Last errors/warnings:
- 00020.661 W: Not a single layer for the name 'Bing Sat': []
- 00026.480 E: <josm.userdata>/plugins/opendata/resources/org/openstreetmap/josm/plugins/opendata/modules/fr/datagouvfr/datasets/agriculture/RegistreParcellaire.mapcss (No such file or directory)
- 00556.989 W: Could not load Mapillary brand image!
- 00568.767 E: java.io.IOException: Unable to find suitable java runtime at <java.home>/bin/java
- 00582.779 E: Handled by bug report queue: java.util.concurrent.RejectedExecutionException: Task java.util.concurrent.FutureTask@55fe1cb[Not completed, task = java.util.concurrent.Executors$RunnableAdapter@472a7b4c[Wrapped task = org.openstreetmap.josm.gui.preferences.imagery.CacheSettingsPanel$$Lambda$1031/0x000000080097c570@920172b]] rejected from org.openstreetmap.josm.gui.progress.swing.ProgressMonitorExecutor@6ccbb9fd[Terminated, pool size = 0, active threads = 0, queued tasks = 0, completed tasks = 1]
- 00643.078 E: Handled by bug report queue: java.util.concurrent.RejectedExecutionException: Task java.util.concurrent.FutureTask@58f1f1a7[Not completed, task = java.util.concurrent.Executors$RunnableAdapter@6581cabd[Wrapped task = org.openstreetmap.josm.gui.preferences.imagery.CacheSettingsPanel$$Lambda$1031/0x000000080097c570@39272d6f]] rejected from org.openstreetmap.josm.gui.progress.swing.ProgressMonitorExecutor@6ccbb9fd[Terminated, pool size = 0, active threads = 0, queued tasks = 0, completed tasks = 1]


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (22) of main
java.util.concurrent.RejectedExecutionException: Task java.util.concurrent.FutureTask@58f1f1a7[Not completed, task = java.util.concurrent.Executors$RunnableAdapter@6581cabd[Wrapped task = org.openstreetmap.josm.gui.preferences.imagery.CacheSettingsPanel$$Lambda$1031/0x000000080097c570@39272d6f]] rejected from org.openstreetmap.josm.gui.progress.swing.ProgressMonitorExecutor@6ccbb9fd[Terminated, pool size = 0, active threads = 0, queued tasks = 0, completed tasks = 1]
	at java.base/java.util.concurrent.ThreadPoolExecutor$AbortPolicy.rejectedExecution(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.reject(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.execute(Unknown Source)
	at org.openstreetmap.josm.gui.progress.swing.ProgressMonitorExecutor.execute(ProgressMonitorExecutor.java:40)
	at java.base/java.util.concurrent.AbstractExecutorService.submit(Unknown Source)
	at org.openstreetmap.josm.gui.preferences.imagery.CacheSettingsPanel.<init>(CacheSettingsPanel.java:76)
	at org.openstreetmap.josm.gui.preferences.imagery.ImageryPreference.<init>(ImageryPreference.java:60)
	at org.openstreetmap.josm.gui.preferences.imagery.ImageryPreference.<init>(ImageryPreference.java:52)
	at org.openstreetmap.josm.gui.preferences.imagery.ImageryPreference$Factory.createPreferenceSetting(ImageryPreference.java:68)
	at org.openstreetmap.josm.gui.preferences.PreferenceTabbedPane.buildGui(PreferenceTabbedPane.java:487)
	at org.openstreetmap.josm.gui.preferences.PreferenceDialog.build(PreferenceDialog.java:86)
	at org.openstreetmap.josm.gui.preferences.PreferenceDialog.<init>(PreferenceDialog.java:56)
	at org.openstreetmap.josm.actions.PreferencesAction.run(PreferencesAction.java:107)
	at org.openstreetmap.josm.actions.PreferencesAction.actionPerformed(PreferencesAction.java:102)
	at org.openstreetmap.josm.gui.MainApplication$DefaultNativeOsCallback.handlePreferences(MainApplication.java:1430)
	at org.openstreetmap.josm.tools.PlatformHookOsx.invoke(PlatformHookOsx.java:195)
	at com.sun.proxy.$Proxy2.handlePreferences(Unknown Source)
	at java.desktop/com.apple.eawt._AppEventHandler$_PreferencesDispatcher.performUsing(Unknown Source)
	at java.desktop/com.apple.eawt._AppEventHandler$_PreferencesDispatcher.performUsing(Unknown Source)
	at java.desktop/com.apple.eawt._AppEventHandler$_AppEventDispatcher$1.run(Unknown Source)
	at java.desktop/java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.EventQueue$4.run(Unknown Source)
	at java.desktop/java.awt.EventQueue$4.run(Unknown Source)
	at java.base/java.security.AccessController.doPrivileged(Unknown Source)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.desktop/java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 2 months ago by Stereo

Resolution: duplicate
Status: newclosed

Closed as duplicate of #20028.

comment:2 Changed 8 weeks ago by Don-vip

Milestone: 20.1020.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.