Modify

Opened 4 weeks ago

Closed 2 weeks ago

Last modified 8 days ago

#20018 closed defect (fixed)

Start page produces high cpu loads

Reported by: skyper Owned by: Don-vip
Priority: normal Milestone: 20.11
Component: Core Version: latest
Keywords: template_report start page cpu performance Cc:

Description

What steps will reproduce the problem?

  1. Start JOSM and watch your system resources
  2. Do not create a new layer or load a file but just wait some minutes with the Start-up-Page
  3. Create a new layer

What is the expected result?

While doing nothing with only the Start-up-Page the cpu load should drop

What happens instead?

Only after 3. the cpu load drops

Please provide any additional information below. Attach a screenshot if possible.

Thought there was a ticket already about it, but did not find it.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-31 01:21:14 +0100 (Sat, 31 Oct 2020)
Revision:17288
Build-Date:2020-10-31 02:30:50
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17288 en) Linux Debian GNU/Linux 10 (buster)
Memory Usage: 220 MB / 768 MB (38 MB allocated, but free)
Java version: 11.0.9+11-post-Debian-1deb10u1, Debian, OpenJDK 64-Bit Server VM
Desktop environment: GNOME
Java package: openjdk-11-jre:amd64-11.0.9+11-1~deb10u1
Java ATK Wrapper package: libatk-wrapper-java:all-0.38.0-1~bpo10+1
Environment variable LANG: en_US.utf8
libcommons-compress-java: libcommons-compress-java:all-1.18-2+deb10u1
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:all-20181227-1
liboauth-signpost-java: liboauth-signpost-java:all-1.2.1.2-2
VM arguments: [--add-modules=java.scripting,java.sql, -Djosm.restart=true, -Djosm.dir.name=JOSM-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Attachments (0)

Change History (13)

comment:1 Changed 4 weeks ago by GerdP

On Windows I see 1% cpu when doing nothing, maybe 5% when moving the mouse quickly. Quite normal.

comment:2 in reply to:  1 Changed 4 weeks ago by Klumbumbus

Replying to GerdP:

On Windows I see 1% cpu when doing nothing, maybe 5% when moving the mouse quickly. Quite normal.

Similar for me on windows.

comment:3 Changed 4 weeks ago by Don-vip

Keywords: linux atk added
Owner: changed from team to skyper
Status: newneedinfo

Can you please try to uninstall my immediate #1 suspect?

comment:4 in reply to:  3 Changed 4 weeks ago by skyper

Replying to Don-vip:

Can you please try to uninstall my immediate #1 suspect?

Purging libatk-wrapper-java does not make any differences.

Maybe it is a problem together with XWayland, as its numbers drop even more dramatically once the new layer is created.

java is still around 10% without any action and drops to under 1% when the new layer is created on my system. It even works if you delete the new layer again, the numbers rise again.

This is nothing new, as I noticed the issue quite some time, now.

Last edited 4 weeks ago by skyper (previous) (diff)

comment:5 Changed 4 weeks ago by skyper

Owner: changed from skyper to team
Status: needinfonew

comment:6 Changed 4 weeks ago by mdk

On my Linux machine I see 5 to 10% showing the start page and 0.3% after creating a layer.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-31 01:21:14 +0100 (Sat, 31 Oct 2020)
Revision:17288
Build-Date:2020-10-31 02:30:50
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17288 en) Linux Ubuntu 20.10
Memory Usage: 230 MB / 1980 MB (98 MB allocated, but free)
Java version: 14.0.2+12-Ubuntu-1, Private Build, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 3840x2160 (scaling 1.0x1.0)
Maximum Screen Size: 3840x2160
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Desktop environment: ubuntu:GNOME
Java ATK Wrapper package: libatk-wrapper-java:all-0.38.0-1
Environment variable LANG: de_CH.UTF-8
libcommons-compress-java: libcommons-compress-java:all-1.20-1
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:-
VM arguments: [--add-modules=java.scripting,java.sql, -Djosm.restart=true, -Djosm.dir.name=JOSM-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

comment:7 Changed 4 weeks ago by Don-vip

Keywords: atk removed

comment:8 Changed 2 weeks ago by Don-vip

Keywords: performance added; linux removed
Milestone: 20.10
Owner: changed from team to Don-vip
Status: newassigned

It's the 50ms timer used for easter egg animation. I didn't notice repaint was so costly.

comment:9 Changed 2 weeks ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 17322/josm:

fix #20018 - disable repaint timer when no animation extension is enabled

comment:10 in reply to:  8 ; Changed 13 days ago by skyper

Thanks a lot. I can start JOSM in background and read the news when I switch to it.

Replying to Don-vip:

It's the 50ms timer used for easter egg animation. I didn't notice repaint was so costly.

That explains why XWayland had even higher numbers.

One more reason to have an option to disable the easter egg animation. Was quite some discussion about it as far as I remember.

comment:11 in reply to:  10 Changed 13 days ago by Don-vip

Replying to skyper:

One more reason to have an option to disable the easter egg animation. Was quite some discussion about it as far as I remember.

It's already there (gui.start.animation since r15602)... I remember the "discussions" and insults quite well. Please don't raise this subject again.

comment:12 Changed 13 days ago by skyper

I am completely sorry. I never intended to open up old sores or start the discussion again.

comment:13 Changed 8 days ago by Don-vip

Milestone: 20.1020.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.