Modify

Opened 15 months ago

Closed 15 months ago

Last modified 14 months ago

#19960 closed defect (fixed)

NPE in OsmJsonReader.readRelationMembersAndTags

Reported by: anonymous Owned by: team
Priority: normal Milestone: 20.11
Component: Core Version:
Keywords: template_report json Cc:

Description (last modified by simon04)

What steps will reproduce the problem?

  1. Load JOSM with large memory support (java -Xmx10G -jar josm-tested.jar)
  2. Download from overpass API with query http://overpass-turbo.eu/s/Z89

What is the expected result?

Load data

What happens instead?

Stack trace

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-03 13:42:38 +0200 (Sat, 03 Oct 2020)
Build-Date:2020-10-04 01:30:47
Revision:17084
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17084 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1903 (18362)
Memory Usage: 8478 MB / 9102 MB (2086 MB allocated, but free)
Java version: 1.8.0_251-b08, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32

Plugins:
+ FastDraw (35499)
+ RelationDissolve (0.2.0)
+ apache-commons (35524)
+ auto_tools (73)
+ conflation (0.6.6)
+ contourmerge (v0.1.6)
+ ejml (35313)
+ geotools (35169)
+ jaxb (35092)
+ jts (35122)
+ log4j (35092)
+ merge-overlap (35248)
+ opendata (35513)
+ reverter (35556)
+ shrinkwrap (v1.0.3)
+ undelete (35521)
+ utilsplugin2 (35487)

Last errors/warnings:
- 00354.337 E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.io.OsmJsonReader.readRelationMembersAndTags(OsmJsonReader.java:159)
	at org.openstreetmap.josm.io.OsmJsonReader.lambda$parseRelation$5(OsmJsonReader.java:154)
	at org.openstreetmap.josm.io.AbstractReader.parseRelation(AbstractReader.java:704)
	at org.openstreetmap.josm.io.OsmJsonReader.parseRelation(OsmJsonReader.java:154)
	at org.openstreetmap.josm.io.OsmJsonReader.parseElements(OsmJsonReader.java:88)
	at org.openstreetmap.josm.io.OsmJsonReader.parseRoot(OsmJsonReader.java:68)
	at org.openstreetmap.josm.io.OsmJsonReader.parse(OsmJsonReader.java:57)
	at org.openstreetmap.josm.io.OsmJsonReader.lambda$doParseDataSet$6(OsmJsonReader.java:180)
	at org.openstreetmap.josm.io.AbstractReader.doParseDataSet(AbstractReader.java:298)
	at org.openstreetmap.josm.io.OsmJsonReader.doParseDataSet(OsmJsonReader.java:178)
	at org.openstreetmap.josm.io.OverpassDownloadReader.parseDataSet(OverpassDownloadReader.java:383)
	at org.openstreetmap.josm.io.BoundingBoxDownloader.parseOsm(BoundingBoxDownloader.java:198)
	at org.openstreetmap.josm.io.OverpassDownloadReader.parseOsm(OverpassDownloadReader.java:389)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.parseDataSet(DownloadOsmTask.java:462)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.realRun(DownloadOsmTask.java:470)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:94)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:142)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (5)

comment:1 Changed 15 months ago by simon04

Description: modified (diff)
Summary: JOSM error on large data loadNPE in OsmJsonReader.readRelationMembersAndTags

comment:2 Changed 15 months ago by simon04

Resolution: fixed
Status: newclosed

In 17232/josm:

fix #19960 - NPE in OsmJsonReader.readRelationMembersAndTags

comment:3 Changed 15 months ago by simon04

Keywords: json added
Milestone: 20.10

comment:4 Changed 15 months ago by GerdP

Ticket #20036 has been marked as a duplicate of this ticket.

comment:5 Changed 14 months ago by Don-vip

Milestone: 20.1020.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.