Modify

Opened 5 days ago

Closed 5 days ago

Last modified 5 days ago

#19946 closed defect (duplicate)

Could not save relations

Reported by: riemer.kerkstra@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Duplicate 1 route relation
  2. Update the duplicated relation with new route elements
  3. Push okay

What is the expected result?

The relation should be saved

What happens instead?

Nothing

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-09-06 16:54:59 +0200 (Sun, 06 Sep 2020)
Revision:17013
Build-Date:2020-09-07 01:30:48
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17013 en_GB) Linux Manjaro Linux
Memory Usage: 505 MB / 960 MB (343 MB allocated, but free)
Java version: 14.0.2+12, N/A, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1440x900 (scaling 1.0x1.0)
Maximum Screen Size: 1440x900
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Desktop environment: KDE
VM arguments: [-Djosm.restart=true]

Dataset consistency test:
[NO DATASET] {Way id=-101859 version=0 MVT nodes=[{Node id=2524668026 version=3 V lat=52.4532722,lon=4.6106722}, {Node id=2524668025 version=2 V lat=52.4531511,lon=4.6101259}, {Node id=2524668024 version=2 V lat=52.4530209,lon=4.6098145}, {Node id=1976415972 version=2 VT lat=52.4526689,lon=4.6092474}]} is referenced by {Relation id=-99781 version=0 VT [way -101859, way 285287664, way -101899, way 6633068, way -101922, way -101924, way -101995, way -102006, way 6633506, way 85873841, way 6633442, way -102028, way 354959880, way 395974135, way 6633459, node 1495169893]} but not found in dataset
[NO DATASET] {Way id=-101859 version=0 MVT nodes=[{Node id=2524668026 version=3 V lat=52.4532722,lon=4.6106722}, {Node id=2524668025 version=2 V lat=52.4531511,lon=4.6101259}, {Node id=2524668024 version=2 V lat=52.4530209,lon=4.6098145}, {Node id=1976415972 version=2 VT lat=52.4526689,lon=4.6092474}]} is referenced by {Relation id=-99784 version=0 VT [way -101859, way 285287664, way -101899, way 6633068, way -101922, way -101924, way -101995, way -102006, way 6633506, way 85873841, way 6633442, way -102028, way 354959880, way 395974135, way 6633459, node 1495169893]} but not found in dataset
[NO DATASET] {Way id=-101859 version=0 MVT nodes=[{Node id=2524668026 version=3 V lat=52.4532722,lon=4.6106722}, {Node id=2524668025 version=2 V lat=52.4531511,lon=4.6101259}, {Node id=2524668024 version=2 V lat=52.4530209,lon=4.6098145}, {Node id=1976415972 version=2 VT lat=52.4526689,lon=4.6092474}]} is referenced by {Relation id=-99804 version=0 VT [way -101859, way 285287664, way -101899, way 6633068, way -101922, way -101924, way -101995, way -102006, way 6633506, way 85873841, way 6633442, way -102028, way 354959880, way 395974135, way 6633459]} but not found in dataset
[NO DATASET] {Way id=-101859 version=0 MVT nodes=[{Node id=2524668026 version=3 V lat=52.4532722,lon=4.6106722}, {Node id=2524668025 version=2 V lat=52.4531511,lon=4.6101259}, {Node id=2524668024 version=2 V lat=52.4530209,lon=4.6098145}, {Node id=1976415972 version=2 VT lat=52.4526689,lon=4.6092474}]} is referenced by {Relation id=-99783 version=0 VT [way -101859, way 285287664, way -101899, way 6633068, way -101922, way -101924, way -101995, way -102006, way 6633506, way 85873841, way 6633442, way -102028, way 354959880, way 395974135, way 6633459, node 1495169893]} but not found in dataset
[NO DATASET] {Way id=-101859 version=0 MVT nodes=[{Node id=2524668026 version=3 V lat=52.4532722,lon=4.6106722}, {Node id=2524668025 version=2 V lat=52.4531511,lon=4.6101259}, {Node id=2524668024 version=2 V lat=52.4530209,lon=4.6098145}, {Node id=1976415972 version=2 VT lat=52.4526689,lon=4.6092474}]} is referenced by {Relation id=-99803 version=0 VT [way -101859, way 285287664, way -101899, way 6633068, way -101922, way -101924, way -101995, way -102006, way 6633506, way 85873841, way 6633442, way -102028, way 354959880, way 395974135, way 6633459, node 1495169893]} but not found in dataset
[NO DATASET] {Way id=-101859 version=0 MVT nodes=[{Node id=2524668026 version=3 V lat=52.4532722,lon=4.6106722}, {Node id=2524668025 version=2 V lat=52.4531511,lon=4.6101259}, {Node id=2524668024 version=2 V lat=52.4530209,lon=4.6098145}, {Node id=1976415972 version=2 VT lat=52.4526689,lon=4.6092474}]} is referenced by {Relation id=-99782 version=0 VT [way -101859, way 285287664, way -101899, way 6633068, way -101922, way -101924, way -101995, way -102006, way 6633506, way 85873841, way 6633442, way -102028, way 354959880, way 395974135, way 6633459, node 1495169893]} but not found in dataset


Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ ${HOME}/osm/presets/oneclick.xml

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/NumberedWalkingNodeNetworks&zip=1

Last errors/warnings:
- 00967.038 E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Relation member must be part of the same dataset as relation(relation -99781, way -101859) (changed by the following commands: )
- 00979.648 E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Relation member must be part of the same dataset as relation(relation -99782, way -101859) (changed by the following commands: )
- 01066.488 E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Relation member must be part of the same dataset as relation(relation -99783, way -101859) (changed by the following commands: )
- 01081.309 E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Relation member must be part of the same dataset as relation(relation -99784, way -101859) (changed by the following commands: )
- 01262.684 W: Unsaved changes - <html>The relation has been changed.<br><br>Do you want to save your changes?</html>
- 01368.125 E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Relation member must be part of the same dataset as relation(relation -99803, way -101859) (changed by the following commands: )
- 01374.171 E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Relation member must be part of the same dataset as relation(relation -99804, way -101859) (changed by the following commands: )


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Relation member must be part of the same dataset as relation(relation -99804, way -101859) (changed by the following commands: )
	at org.openstreetmap.josm.data.osm.Relation.checkMembers(Relation.java:487)
	at org.openstreetmap.josm.data.osm.Relation.setDataset(Relation.java:471)
	at org.openstreetmap.josm.data.osm.DataSet.lambda$addPrimitive$5(DataSet.java:502)
	at org.openstreetmap.josm.data.osm.DataSet.update(DataSet.java:955)
	at org.openstreetmap.josm.data.osm.DataSet.addPrimitive(DataSet.java:495)
	at org.openstreetmap.josm.command.AddCommand.executeCommand(AddCommand.java:54)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:300)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:354)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.SavingAction.applyNewRelation(SavingAction.java:66)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.SavingAction.applyChanges(SavingAction.java:161)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.OKAction.actionPerformed(OKAction.java:33)
	at java.desktop/javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1967)
	at java.desktop/javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2308)
	at java.desktop/javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:405)
	at java.desktop/javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:262)
	at java.desktop/javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:279)
	at java.desktop/java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:297)
	at java.desktop/java.awt.Component.processMouseEvent(Component.java:6636)
	at java.desktop/javax.swing.JComponent.processMouseEvent(JComponent.java:3342)
	at java.desktop/java.awt.Component.processEvent(Component.java:6401)
	at java.desktop/java.awt.Container.processEvent(Container.java:2263)
	at java.desktop/java.awt.Component.dispatchEventImpl(Component.java:5012)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2321)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4844)
	at java.desktop/java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4919)
	at java.desktop/java.awt.LightweightDispatcher.processMouseEvent(Container.java:4548)
	at java.desktop/java.awt.LightweightDispatcher.dispatchEvent(Container.java:4489)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2307)
	at java.desktop/java.awt.Window.dispatchEventImpl(Window.java:2764)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4844)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:772)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(AccessController.java:391)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:95)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:745)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:743)
	at java.base/java.security.AccessController.doPrivileged(AccessController.java:391)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:742)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

Attachments (1)

Screenshot_20201016_093024.png (52.6 KB) - added by riemer.kerkstra@… 5 days ago.

Download all attachments as: .zip

Change History (2)

Changed 5 days ago by riemer.kerkstra@…

comment:1 Changed 5 days ago by GerdP

Resolution: duplicate
Status: newclosed

Closed as duplicate of #19353.
Please reopen if you can reproduce this problem with the current tested version (r17084).

Last edited 5 days ago by GerdP (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.