Modify

Opened 8 days ago

Closed 7 days ago

Last modified 3 days ago

#19932 closed defect (duplicate)

wrong with the load of one of gpx file

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc: simon04

Description

What steps will reproduce the problem?

  1. read one of gpx files

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-03 13:42:38 +0200 (Sat, 03 Oct 2020)
Build-Date:2020-10-04 01:30:47
Revision:17084
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17084 zh_CN) Windows 10 64-Bit
OS Build number: Windows 10 Home China 1903 (18362)
Memory Usage: 247 MB / 989 MB (151 MB allocated, but free)
Java version: 1.8.0_251-b08, Oracle Corporation, Java HotSpot(TM) Client VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32

Plugins:
+ imagery_offset_db (35405)
+ turnrestrictions (35577)

Last errors/warnings:
- 00012.035 W: java.nio.file.FileSystemException: %UserProfile%\AppData\Local\Temp\josm_exec_powershell_4931276397840899449.txt: 另一个程序正在使用此文件,进程无法访问。
- 00012.036 W: Unable to request certificate of https://www.certigna.fr
- 00020.965 W: java.nio.file.FileSystemException: %UserProfile%\AppData\Local\Temp\josm_exec_powershell_5743641272318353549.txt: 另一个程序正在使用此文件,进程无法访问。
- 00020.966 W: Unable to request certificate of https://grca.nat.gov.tw
- 00026.053 W: java.nio.file.FileSystemException: %UserProfile%\AppData\Local\Temp\josm_exec_powershell_4206478707689965742.txt: 另一个程序正在使用此文件,进程无法访问。
- 00026.054 W: Unable to request certificate of https://grca.nat.gov.tw
- 00027.621 W: 更新插件 - 您已经更新了 JOSM 软件。 为了避免问题也应该更新插件。  是否立即更新?
- 00157.648 E: Region [TMS_BLOCK_v2] : Problem loading keys for file TMS_BLOCK_v2
- 00178.099 E: Handled by bug report queue: java.time.DateTimeException: Invalid value for SecondOfMinute (valid values 0 - 59): 60
- 00463.942 E: Handled by bug report queue: java.time.DateTimeException: Invalid value for SecondOfMinute (valid values 0 - 59): 60


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-0 (61) of main
java.time.DateTimeException: Invalid value for SecondOfMinute (valid values 0 - 59): 60
	at java.time.temporal.ValueRange.checkValidValue(Unknown Source)
	at java.time.temporal.ChronoField.checkValidValue(Unknown Source)
	at java.time.LocalTime.of(Unknown Source)
	at java.time.LocalDateTime.of(Unknown Source)
	at java.time.ZonedDateTime.of(Unknown Source)
	at org.openstreetmap.josm.tools.date.DateUtils.tsFromString(DateUtils.java:114)
	at org.openstreetmap.josm.io.GpxReader$Parser.endElement(GpxReader.java:478)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanEndElement(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl.parse(Unknown Source)
	at org.openstreetmap.josm.tools.XmlUtils.parseSafeSAX(XmlUtils.java:123)
	at org.openstreetmap.josm.io.GpxReader.parse(GpxReader.java:642)
	at org.openstreetmap.josm.gui.io.importexport.GpxImporter.importData(GpxImporter.java:125)
	at org.openstreetmap.josm.gui.io.importexport.FileImporter.importDataHandleExceptions(FileImporter.java:98)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:370)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:320)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:94)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:142)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (7)

comment:1 Changed 7 days ago by skyper

Owner: changed from team to anonymous
Status: newneedinfo
Version: tested

The file seems to have an invalid format as seconds are only allowed between 0 and 59 but your file contains fields with 60.

How was this file generated?
Is it possible to attach it to the ticket, thanks ?

comment:2 Changed 7 days ago by Klumbumbus

Cc: simon04 added

Might already be fixed with r17166?

comment:3 Changed 7 days ago by simon04

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #17925.
Yes, related and the exception is no longer surfacing.

The cause for "Invalid value for SecondOfMinute (valid values 0 - 59): 60" might be a leap second" which is tracked in #17925.

comment:4 in reply to:  3 Changed 6 days ago by stoecker

Replying to simon04:

The cause for "Invalid value for SecondOfMinute (valid values 0 - 59): 60" might be a leap second" which is tracked in #17925.

Very unlikely. The last was 2016. Chances are higher that it is a rounding issue.

comment:5 Changed 3 days ago by simon04

The exception is happening immediately after JOSM has read the timestamp string from the GPX file. I wonder what kind of rounding issue in the GPX generating software would lead to a SecondOfMinute=60… Having an example file would help to resolve this mystery. :-)

comment:6 in reply to:  5 ; Changed 3 days ago by stoecker

Replying to simon04:

The exception is happening immediately after JOSM has read the timestamp string from the GPX file. I wonder what kind of rounding issue in the GPX generating software would lead to a SecondOfMinute=60… Having an example file would help to resolve this mystery. :-)

Seen the same lately with other data at work. Probably they had timestamps like 2020-09-13 13:12:59.675 that get 2020-09-13 13:12:60 when output as int without proper care of the time handling. Interestingly our dataset also contained 24:00:00 (probably for same reason).

Never underestimate lazy programmers.

comment:7 in reply to:  6 Changed 3 days ago by Klumbumbus

I guess the same software also generated this:

Replying to #19914:

Invalid value for MonthOfYear (valid values 1 - 12): 17434

so there seems to be something a bit more broken than just rounding in this software :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.