Modify

Opened 2 years ago

Closed 7 weeks ago

#19910 closed enhancement (duplicate)

Add support for cycleway:both

Reported by: Romwriter Owned by: team
Priority: normal Milestone:
Component: Internal mappaint style Version: tested
Keywords: cycleway Cc:

Description (last modified by Klumbumbus)

cycleway:both=* tag should be displayed like cycleway=* tag

Suggestion for patching resources/styles/standard/elemstyles.mapcss is:

@990
 way[oneway=no][cycleway=lane]::core_cycleway,
-way[!oneway][cycleway=lane]::core_cycleway {
+way[!oneway][cycleway=lane]::core_cycleway,
+way[cycleway:both=lane]::core_cycleway {
     set laneLeft;
     set laneRight;
 }

@1017
 way[oneway=no][cycleway=shared_lane]::core_cycleway,
-way[!oneway][cycleway=shared_lane]::core_cycleway {
+way[!oneway][cycleway=shared_lane]::core_cycleway,
+way[cycleway:both=shared_lane]::core_cycleway {
     set shared_laneLeft;
     set shared_laneRight;
 }

@1048
 way[oneway=no][cycleway=track]::core_cycleway,
-way[!oneway][cycleway=track]::core_cycleway {
+way[!oneway][cycleway=track]::core_cycleway,
+way[cycleway:both=track]::core_cycleway {
     set trackLeft;
     set trackRight;
 }

Attachments (0)

Change History (7)

comment:1 Changed 2 years ago by Don-vip

Component: Core mappaintInternal mappaint style
Keywords: cycleway added

comment:2 Changed 2 years ago by skyper

Thought :both is especially needed together with oneway=yes. For cases without oneway, cycleway=* is defined as on both sides and :both does not give more information.

comment:3 Changed 2 years ago by Klumbumbus

Description: modified (diff)

comment:4 Changed 6 months ago by mcliquid

I think this is related to https://josm.openstreetmap.de/ticket/10317

cycleway:both=* has a significant increase in usage due to its implementation in StreetComplete.
Even though it only makes up 6% so far compared to cycleway=*, usage is increasing exponentially. See https://taginfo.openstreetmap.org/tags/cycleway%3Aboth=lane#chronology

If the effort is kept within limits, I would very much appreciate such an implementation, so that also the values entered by StreetComplete are immediately visible in JOSM in map style. Thanks a lot!

P.S.: From my point of view it would then also make sense that cycleway:both:lane=exclusive and cycleway:both:lane=advisory are considered accordingly. See: https://wiki.openstreetmap.org/wiki/Key:cycleway:lane

comment:5 Changed 4 months ago by GerdP

+1 It is really confusing that JOSM doesn't render cycleway:both=track. Why wasn't this patch applied?

comment:6 Changed 4 months ago by taylor.smock

Good question. I haven't applied it since it was 20+ months old, and I have a tendency to prefer newer patches (more likely to apply cleanly, less likely to have been looked at by other maintainers). Maybe #10317? Except I think the reason #10317 was closed as WONTFIX is no longer relevant (it is now documented on the wiki and the usage numbers went from something like 100 in 2014 to more than 22k today).

EDIT: Or maybe it was because it is not currently part of a preset? See source:trunk/resources/data/validator/ignoretags.cfg#L91 for the only location of cycleway:both in source:trunk/resources.

Last edited 4 months ago by taylor.smock (previous) (diff)

comment:7 Changed 7 weeks ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #19826.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.