Modify

Opened 20 months ago

Closed 20 months ago

Last modified 18 months ago

#19902 closed defect (fixed)

Advanced preferences: add-button unreadable (language: Dutch)

Reported by: Famlam Owned by: team
Priority: normal Milestone: 20.11
Component: Core Version: tested
Keywords: template_report preferences Cc:

Description (last modified by Famlam)

What steps will reproduce the problem?

  1. Set language to Dutch (or probably any long-word-language)
  2. Open advanced preferences

What is the expected result?

Button text readable (or perhaps all with a minimum size, showing at least the first - say - 15 characters)

What happens instead?

Only one button gets truncated (to just "...")

Please provide any additional information below. Attach a screenshot if possible.

https://josm.openstreetmap.de/raw-attachment/ticket/19902/AdvancedPreferences.png

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-03 13:42:38 +0200 (Sat, 03 Oct 2020)
Build-Date:2020-10-04 01:30:47
Revision:17084
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17084 nl) Windows 10 64-Bit
OS Build number: Windows 10 Home 2004 (19041)
Memory Usage: 760 MB / 1820 MB (465 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32

Plugins:
+ OpeningHoursEditor (35414)
+ imagery_offset_db (35405)
+ pt_assistant (2.1.10-80-g7d9bba3)
+ reverter (35556)
+ tageditor (35258)
+ turnlanes-tagging (283)
+ undelete (35521)
+ utilsplugin2 (35487)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
+ %UserProfile%\Documents\tijdelijke bestanden\josm-eigen.mappaint.mapcss

Validator rules:
+ %UserProfile%\Documents\tijdelijke bestanden\josm-eigen.validator.mapcss

Attachments (2)

AdvancedPreferences.png (48.5 KB) - added by Famlam 20 months ago.
2020-10-10-190646_3840x2160_scrot.png (70.9 KB) - added by simon04 20 months ago.

Download all attachments as: .zip

Change History (10)

Changed 20 months ago by Famlam

Attachment: AdvancedPreferences.png added

comment:1 Changed 20 months ago by Famlam

Description: modified (diff)

comment:2 Changed 20 months ago by GerdP

Since r17097 the position and size of the dialog is (re-)stored. So, once you set it to a better size this problem should be solved.

comment:3 Changed 20 months ago by Famlam

Ah thanks! That lowers the priority of this issue quite a bit. I can confirm this using build 17137.

I just discovered that behind the export button, there's another button hidden as well :)

It would be nice if JOSM automatically calculates the best size first time though. Also, only the very first button is truncated upon shrinkage. The Edit/Restore/Import/Export/More buttons are never truncated, which is a bit strange. Should I open a new issue for this?

Last edited 20 months ago by Famlam (previous) (diff)

comment:4 Changed 20 months ago by simon04

In 17146/josm:

see #19902 - Advanced preferences: use FlowLayout for buttons, add tooltip

Changed 20 months ago by simon04

comment:5 Changed 20 months ago by Famlam

Thanks! That looks very good!
I guess I can close this issue?

comment:6 Changed 20 months ago by Don-vip

Resolution: fixed
Status: newclosed

comment:7 Changed 20 months ago by Don-vip

Milestone: 20.10

comment:8 Changed 18 months ago by Don-vip

Milestone: 20.1020.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.