Modify

Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#199 closed enhancement (fixed)

create parallel set of segments

Reported by: m-schmitt@… Owned by: josm@…
Priority: major Milestone:
Component: Core Version:
Keywords: Cc:

Description

Having a way defined I would like to automatically create
a new one running parallel in a certain distance.

Function should be:

select segments
tell the distance
point with cursor to the direction
place the new segments

ay be that this request has already brought up under a deifferent
name, but I did'nt catch this one.

m-schmitt@…

Attachments (0)

Change History (5)

comment:1 Changed 14 years ago by imi

This will be possible in a much more natural way once #22 (Clipboard) is implemented. Ctrl+c, Ctrl+v and a bit moving (or better: Holding Ctrl down while dragging the selection. See #11).

comment:2 Changed 14 years ago by imi

Resolution: duplicate
Status: newclosed

ok, comment:1 does not hold, as the new way should not be a shifted copy but should follow some set distance around curves.

So this seems to be a duplicate of #67.

comment:3 Changed 13 years ago by Plenz

Priority: minormajor
Resolution: duplicate
Status: closedreopened

I just had the same idea. I developed some formulars and algorithms to calculate the locations of the shifted points. They work already very well in Excel - but that's it already. I am programming in several languages, but not in Java, and I am not very much interested of learning Java only for one single JOSM plugin.

I would be very glad if you would implement such a feature in JOSM, and in this case I would give and explain my formulas to you.

comment:4 Changed 13 years ago by Gabriel Ebner <ge@…>

Resolution: fixed
Status: reopenedclosed

JOSM already has such a feature (at least in recent versions). :-)

Ctrl-C to copy the selection, Ctrl-V to paste it (in the center of the screen).

comment:5 in reply to:  4 Changed 13 years ago by anonymous

Replying to Gabriel Ebner <ge@gabrielebner.at>:

JOSM already has such a feature (at least in recent versions). :-)

Ctrl-C to copy the selection, Ctrl-V to paste it (in the center of the screen).

Sorry, but if your way is a curve with a radius = 100 m and if it should be shifted by 20 m, then the radius of the shifted curve must be 80 m rsp. 120 m. You can't do this whith Copy&Paste.

Anyway, I solved the task with my own program: http://www.lenz-online.de/divers/mapping.htm

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain josm@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.