Modify

Opened 14 months ago

Closed 14 months ago

Last modified 12 months ago

#19876 closed defect (fixed)

Preference dialog only shows Advanced Preferences

Reported by: GerdP Owned by: GerdP
Priority: normal Milestone: 20.11
Component: Core Version:
Keywords: template_report regression Cc: simon04

Description (last modified by GerdP)

What steps will reproduce the problem?

  1. Start JOSM
  2. Press F12 for the preferences dialog (all looks normal)
  3. click the down button on the left side until nothing moves
  4. click on the icon for "Advanced preferences"
  5. click OK without any further actions
  6. Press F12 for the preferences dialog

What is the expected result?

Same dialog as in 2.

What happens instead?

Dialog shows only the entry for Advanced Preferences:

Please provide any additional information below. Attach a screenshot if possible.

The dialog still contains all panels, one has to scroll down to see them. I think this was introduced with the new icons. Regression from #19732. Might also depend on plugins which add dialogs.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-09-06 16:54:59 +0200 (Sun, 06 Sep 2020)
Build-Date:2020-09-07 01:30:48
Revision:17013
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17013 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 2004 (19041)
Memory Usage: 995 MB / 3641 MB (713 MB allocated, but free)
Java version: 1.8.0_221-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
VM arguments: [-XX:StartFlightRecording=name=MyRecording2,settings=d:\dbg\gerd.jfc, -XX:FlightRecorderOptions=defaultrecording=true,dumponexit=true,dumponexitpath=e:\ld\perf_20201003_082205.jfr]

Plugins:
+ OpeningHoursEditor (35414)
+ PolygonCutOut (v0.7)
+ apache-commons (35524)
+ buildings_tools (35563)
+ continuosDownload (91)
+ ejml (35313)
+ geotools (35169)
+ gridify (1588746833)
+ jaxb (35092)
+ jts (35122)
+ merge-overlap (35248)
+ o5m (35248)
+ opendata (35513)
+ pbf (35446)
+ poly (35248)
+ reverter (35556)
+ terracer (35560)
+ undelete (35521)
+ utilsplugin2 (35487)

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Bench&zip=1

Attachments (5)

only-advanced.PNG (19.9 KB) - added by GerdP 14 months ago.
19876.patch (1.4 KB) - added by GerdP 14 months ago.
wrongicon.PNG (103.6 KB) - added by GerdP 14 months ago.
19876.2.patch (876 bytes) - added by GerdP 14 months ago.
use pack() in constructor of PreferenceDialog
19876.3.patch (1.9 KB) - added by GerdP 14 months ago.
solution, opendata plugin needs similar change in OpenPreferencesActions

Download all attachments as: .zip

Change History (15)

Changed 14 months ago by GerdP

Attachment: only-advanced.PNG added

comment:1 Changed 14 months ago by GerdP

Description: modified (diff)

comment:2 Changed 14 months ago by GerdP

regression of #19732?

comment:3 Changed 14 months ago by GerdP

Cc: simon04 added
Description: modified (diff)
Keywords: regression added

comment:4 Changed 14 months ago by GerdP

Problem is in fact related to the number of plugins. When I remove one of the plugins continousDownload or opendata the problem disappears. When I add it again the problem is again reproducable.
So, whenever the list on the left doesn't fit into the dialog the list is not scrolled correctly.

comment:5 Changed 14 months ago by GerdP

I think the error is old, the changes for #19732 just made it more obvious.

Changed 14 months ago by GerdP

Attachment: 19876.patch added

Changed 14 months ago by GerdP

Attachment: wrongicon.PNG added

comment:6 Changed 14 months ago by GerdP

The patch doesn't fix the problem but fixes two other related problems:

  1. Position of the PreferenceDialog was not saved
  2. When using e.g. Imagery -> Imagere Preferences the icon in the left pane doesn't match the dialog in the right pane, it is always off by 1.


Changed 14 months ago by GerdP

Attachment: 19876.2.patch added

use pack() in constructor of PreferenceDialog

comment:7 Changed 14 months ago by GerdP

Milestone: 20.10
Owner: changed from team to GerdP
Status: newassigned

Changed 14 months ago by GerdP

Attachment: 19876.3.patch added

solution, opendata plugin needs similar change in OpenPreferencesActions

comment:8 Changed 14 months ago by GerdP

Resolution: fixed
Status: assignedclosed

In 17097/josm:

fix #19876: Preference dialog only shows Advanced Preferences
Use SwingUtilities.invokeLater() so that dialog is completely build before last tab or wanted tab is restored

comment:9 Changed 14 months ago by simon04

Thank you for debugging and fixing this issue!

comment:10 Changed 12 months ago by Don-vip

Milestone: 20.1020.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain GerdP.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.