Modify

Opened 15 months ago

Closed 15 months ago

Last modified 14 months ago

#19821 closed enhancement (fixed)

Allow oneway on leisure=track

Reported by: Famlam Owned by: team
Priority: normal Milestone: 20.09
Component: Core validator Version:
Keywords: oneway track Cc:

Description

What steps will reproduce the problem?

  1. Validate i.e. https://www.openstreetmap.org/way/27232924

What is the expected result?

No warning: (among others) cycle sports and (ice) skating tracks often have defined mandatory directions

What happens instead?

https://josm.openstreetmap.de/browser/josm/trunk/resources/data/validator/combinations.mapcss#L228
missing tag - oneway without highway, railway or aerialway

Please provide any additional information below. Attach a screenshot if possible.

It's not listed in the wiki, but it definitely makes sense as the most logical tag to indicate the direction for the sporters. Affects 736 ways currently.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-09-06 16:54:59 +0200 (Sun, 06 Sep 2020)
Build-Date:2020-09-07 01:30:48
Revision:17013
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17013 nl) Windows 10 64-Bit
OS Build number: Windows 10 Home 2004 (19041)
Memory Usage: 802 MB / 1820 MB (641 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (35414)
+ imagery_offset_db (35405)
+ pt_assistant (2.1.10-80-g7d9bba3)
+ tageditor (35258)
+ turnlanes-tagging (283)
+ undelete (35521)
+ utilsplugin2 (35487)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
+ %UserProfile%\Documents\tijdelijke bestanden\josm-eigen.mappaint.mapcss

Validator rules:
+ %UserProfile%\Documents\tijdelijke bestanden\josm-eigen.validator.mapcss

Attachments (0)

Change History (3)

comment:1 Changed 15 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 17046/josm:

fix #19821 - Don't warn about oneway on leisure=track

comment:2 Changed 15 months ago by Klumbumbus

Milestone: 20.09

comment:3 Changed 14 months ago by Klumbumbus

Ticket #19846 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.