Modify

Opened 5 days ago

Closed 5 days ago

#19804 closed defect (duplicate)

JOSM crash when uploading changes

Reported by: Matthijs Kooijman <matthijs@…> Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

My JOSM crashed and offered to submit a bug report, so here it is. I haven't really looked for duplicate reports, or tried to reproduce this.

What steps will reproduce the problem?

Not sure, but I had been editing with the same datafile for a while, uploading changes in between. Since the last upload, I added a path, clicked upload, filled in a messages, clicked upload changes, then JOSM crashed.

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-09-06 16:54:59 +0200 (Sun, 06 Sep 2020)
Revision:17013
Build-Date:2020-09-07 01:30:48
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (17013 en) Linux Ubuntu 20.04.1 LTS
Memory Usage: 394 MB / 2048 MB (110 MB allocated, but free)
Java version: 11.0.8+10-post-Ubuntu-0ubuntu120.04, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1280x1024 (scaling 1.0x1.0)
Maximum Screen Size: 1280x1024
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Desktop environment: GNOME
Java package: openjdk-11-jre:amd64-11.0.8+10-0ubuntu1~20.04
WebStart package: icedtea-netx:amd64-1.8-0ubuntu8
Java ATK Wrapper package: libatk-wrapper-java:all-0.37.1-1
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:-
VM arguments: [--add-reads=java.base=ALL-UNNAMED,java.desktop, --add-reads=java.desktop=ALL-UNNAMED,java.naming, --add-reads=java.naming=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.awt=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/javax.jnlp=ALL-UNNAMED,java.desktop, --add-exports=java.base/com.sun.net.ssl.internal.ssl=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.net.www.protocol.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.action=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.provider=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.util=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.validator=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.x509=ALL-UNNAMED,java.desktop, --add-exports=java.base/jdk.internal.util.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.net.www.protocol.http=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.awt.X11=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,jdk.jsobject, --add-exports=java.naming/com.sun.jndi.toolkit.url=ALL-UNNAMED,java.desktop, -Dicedtea-web.bin.name=javaws, -Dicedtea-web.bin.location=/usr/lib/icedtea-web/bin/javaws]
Dataset consistency test: No problems found

Plugins:
+ measurement (35405)
+ utilsplugin2 (35487)

Last errors/warnings:
- 05469.836 E: Region [WMS_BLOCK_v2] : Failure getting from disk, key = PDOK aerial imagery Beeldmateriaal.nl 25cm latest:https://geodata.nationaalgeoregister.nl/luchtfoto/rgb/wms?REQUEST=GetMap&LAYERS=Actueel_ortho25&STYLES=&FORMAT=image/jpeg&VERSION=1.3.0&CRS=EPSG:3857&WIDTH=512&HEIGHT=512&BBOX=592845.5913798,6828578.3588845,593151.3394930,6828884.1069976EPSG:3857
- 05469.836 E: Region [WMS_BLOCK_v2] : Failure getting from disk, key = PDOK aerial imagery Beeldmateriaal.nl 25cm latest:https://geodata.nationaalgeoregister.nl/luchtfoto/rgb/wms?REQUEST=GetMap&LAYERS=Actueel_ortho25&STYLES=&FORMAT=image/jpeg&VERSION=1.3.0&CRS=EPSG:3857&WIDTH=512&HEIGHT=512&BBOX=592845.5913798,6828884.1069976,593151.3394930,6829189.8551108EPSG:3857
- 05469.837 E: Region [WMS_BLOCK_v2] : Failure getting from disk, key = PDOK aerial imagery Beeldmateriaal.nl 25cm latest:https://geodata.nationaalgeoregister.nl/luchtfoto/rgb/wms?REQUEST=GetMap&LAYERS=Actueel_ortho25&STYLES=&FORMAT=image/jpeg&VERSION=1.3.0&CRS=EPSG:3857&WIDTH=512&HEIGHT=512&BBOX=592845.5913798,6828272.6107714,593151.3394930,6828578.3588845EPSG:3857
- 05470.005 E: Region [WMS_BLOCK_v2] : Failure getting from disk, key = PDOK aerial imagery Beeldmateriaal.nl 25cm latest:https://geodata.nationaalgeoregister.nl/luchtfoto/rgb/wms?REQUEST=GetMap&LAYERS=Actueel_ortho25&STYLES=&FORMAT=image/jpeg&VERSION=1.3.0&CRS=EPSG:3857&WIDTH=512&HEIGHT=512&BBOX=592845.5913798,6827661.1145451,593151.3394930,6827966.8626582EPSG:3857
- 05470.006 E: Region [WMS_BLOCK_v2] : Failure getting from disk, key = PDOK aerial imagery Beeldmateriaal.nl 25cm latest:https://geodata.nationaalgeoregister.nl/luchtfoto/rgb/wms?REQUEST=GetMap&LAYERS=Actueel_ortho25&STYLES=&FORMAT=image/jpeg&VERSION=1.3.0&CRS=EPSG:3857&WIDTH=512&HEIGHT=512&BBOX=592845.5913798,6827966.8626582,593151.3394930,6828272.6107714EPSG:3857
- 05470.007 E: Region [WMS_BLOCK_v2] : Failure getting from disk, key = PDOK aerial imagery Beeldmateriaal.nl 25cm latest:https://geodata.nationaalgeoregister.nl/luchtfoto/rgb/wms?REQUEST=GetMap&LAYERS=Actueel_ortho25&STYLES=&FORMAT=image/jpeg&VERSION=1.3.0&CRS=EPSG:3857&WIDTH=512&HEIGHT=512&BBOX=593151.3394930,6828884.1069976,593457.0876061,6829189.8551108EPSG:3857
- 05470.113 E: Region [WMS_BLOCK_v2] : Failure getting from disk, key = PDOK aerial imagery Beeldmateriaal.nl 25cm latest:https://geodata.nationaalgeoregister.nl/luchtfoto/rgb/wms?REQUEST=GetMap&LAYERS=Actueel_ortho25&STYLES=&FORMAT=image/jpeg&VERSION=1.3.0&CRS=EPSG:3857&WIDTH=512&HEIGHT=512&BBOX=593457.0876061,6828884.1069976,593762.8357193,6829189.8551108EPSG:3857
- 05470.123 E: Region [WMS_BLOCK_v2] : Failure getting from disk, key = PDOK aerial imagery Beeldmateriaal.nl 25cm latest:https://geodata.nationaalgeoregister.nl/luchtfoto/rgb/wms?REQUEST=GetMap&LAYERS=Actueel_ortho25&STYLES=&FORMAT=image/jpeg&VERSION=1.3.0&CRS=EPSG:3857&WIDTH=512&HEIGHT=512&BBOX=593762.8357193,6828884.1069976,594068.5838324,6829189.8551108EPSG:3857
- 05470.148 E: Region [WMS_BLOCK_v2] : Failure getting from disk, key = PDOK aerial imagery Beeldmateriaal.nl 25cm latest:https://geodata.nationaalgeoregister.nl/luchtfoto/rgb/wms?REQUEST=GetMap&LAYERS=Actueel_ortho25&STYLES=&FORMAT=image/jpeg&VERSION=1.3.0&CRS=EPSG:3857&WIDTH=512&HEIGHT=512&BBOX=594068.5838324,6828884.1069976,594374.3319455,6829189.8551108EPSG:3857
- 05481.517 E: Handled by bug report queue: java.lang.IllegalArgumentException: Width and height must be >= 0


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-1 (43) of JOSM
java.lang.IllegalArgumentException: Width and height must be >= 0
	at java.desktop/javax.swing.plaf.basic.BasicHTML.getHTMLBaseline(BasicHTML.java:91)
	at java.desktop/javax.swing.plaf.metal.MetalToolTipUI.paint(MetalToolTipUI.java:126)
	at java.desktop/javax.swing.plaf.ComponentUI.update(ComponentUI.java:161)
	at java.desktop/javax.swing.JComponent.paintComponent(JComponent.java:797)
	at java.desktop/javax.swing.JComponent.paint(JComponent.java:1074)
	at java.desktop/javax.swing.JComponent.paintChildren(JComponent.java:907)
	at java.desktop/javax.swing.JComponent.paint(JComponent.java:1083)
	at java.desktop/javax.swing.JComponent.paintChildren(JComponent.java:907)
	at java.desktop/javax.swing.JComponent.paint(JComponent.java:1083)
	at java.desktop/javax.swing.JLayeredPane.paint(JLayeredPane.java:590)
	at java.desktop/javax.swing.JComponent.paintChildren(JComponent.java:907)
	at java.desktop/javax.swing.JComponent.paintToOffscreen(JComponent.java:5262)
	at java.desktop/javax.swing.RepaintManager$PaintManager.paintDoubleBufferedImpl(RepaintManager.java:1643)
	at java.desktop/javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1618)
	at java.desktop/javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1556)
	at java.desktop/javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:262)
	at java.desktop/javax.swing.RepaintManager.paint(RepaintManager.java:1323)
	at java.desktop/javax.swing.JComponent.paint(JComponent.java:1060)
	at java.desktop/java.awt.GraphicsCallback$PaintCallback.run(GraphicsCallback.java:39)
	at java.desktop/sun.awt.SunGraphicsCallback.runOneComponent(SunGraphicsCallback.java:78)
	at java.desktop/sun.awt.SunGraphicsCallback.runComponents(SunGraphicsCallback.java:115)
	at java.desktop/java.awt.Container.paint(Container.java:2002)
	at java.desktop/java.awt.Window.paint(Window.java:3940)
	at java.desktop/javax.swing.RepaintManager$4.run(RepaintManager.java:876)
	at java.desktop/javax.swing.RepaintManager$4.run(RepaintManager.java:848)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:848)
	at java.desktop/javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:823)
	at java.desktop/javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:772)
	at java.desktop/javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1890)
	at java.desktop/java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:313)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:770)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:740)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:117)
	at java.desktop/java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:190)
	at java.desktop/java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:235)
	at java.desktop/java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:233)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.desktop/java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:233)
	at java.desktop/java.awt.Dialog.show(Dialog.java:1070)
	at java.desktop/java.awt.Component.show(Component.java:1716)
	at java.desktop/java.awt.Component.setVisible(Component.java:1663)
	at java.desktop/java.awt.Window.setVisible(Window.java:1031)
	at java.desktop/java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.io.UploadDialog.setVisible(UploadDialog.java:407)
	at org.openstreetmap.josm.actions.UploadAction.uploadData(UploadAction.java:244)
	at org.openstreetmap.josm.actions.UploadAction.actionPerformed(UploadAction.java:292)
	at java.desktop/javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1967)
	at java.desktop/javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2308)
	at java.desktop/javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:405)
	at java.desktop/javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:262)
	at java.desktop/javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:279)
	at java.desktop/java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:297)
	at java.desktop/java.awt.Component.processMouseEvent(Component.java:6635)
	at java.desktop/javax.swing.JComponent.processMouseEvent(JComponent.java:3342)
	at java.desktop/java.awt.Component.processEvent(Component.java:6400)
	at java.desktop/java.awt.Container.processEvent(Container.java:2263)
	at java.desktop/java.awt.Component.dispatchEventImpl(Component.java:5011)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2321)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4843)
	at java.desktop/java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4918)
	at java.desktop/java.awt.LightweightDispatcher.processMouseEvent(Container.java:4547)
	at java.desktop/java.awt.LightweightDispatcher.dispatchEvent(Container.java:4488)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2307)
	at java.desktop/java.awt.Window.dispatchEventImpl(Window.java:2772)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4843)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:772)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:95)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:745)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:743)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:742)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

Attachments (0)

Change History (2)

comment:1 Changed 5 days ago by Matthijs Kooijman <matthijs@…>

Apparently not entirely a crash, clicking "Ignore this error" and then "Upload changes" again allowed me to upload the changes.

comment:2 Changed 5 days ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #19585.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.