Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#19741 closed defect (worksforme)

Constant reload of tiles from any background layer

Reported by: sharcrash Owned by: sharcrash
Priority: normal Milestone:
Component: Core imagery Version:
Keywords: template_report tiles reload Cc: wiktorn

Description

What steps will reproduce the problem?

  1. No peculiar steps i guess
  2. I just have loaded my usual layers from a "start" joz file without data, only background layers,
  3. browse/zoom in/out the map, maybe more often when plugin "continuousdownload" downloads data from OSM servers at the same time.

What is the expected result?

Tiles should be loaded in the cache maybe for one session

What happens instead?

Tiles get reloaded about every 5 minutes

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-07-30 12:44:04 +0200 (Thu, 30 Jul 2020)
Build-Date:2020-07-31 01:30:49
Revision:16812
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16812 en) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 1180 MB / 1820 MB (178 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1280x1024 (scaling 1.0x1.0), \Display1 1280x1024 (scaling 1.0x1.0)
Maximum Screen Size: 1280x1024
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32

Plugins:
+ ImageWayPoint (35248)
+ SimplifyArea (35405)
+ apache-commons (35362)
+ areaselector (359)
+ austriaaddresshelper (57)
+ buildings_tools (35500)
+ continuosDownload (91)
+ contourmerge (v0.1.6)
+ ejml (35313)
+ geochat (35405)
+ imagery_offset_db (35405)
+ log4j (35092)
+ photo_geotagging (35499)
+ photoadjust (35405)
+ reltoolbox (35405)
+ reverter (35499)
+ turnrestrictions (35515)
+ undelete (35499)
+ utilsplugin2 (35487)
+ wikipedia (1.1.4)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
+ https://github.com/gmgeo/osmic-josm-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Enhanced_Lane_and_Road_Attributes&zip=1

Last errors/warnings:
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.SocketTimeoutException: connect timed out
- W: java.net.UnknownHostException: api.openstreetmap.org
- W: Already here java.net.SocketTimeoutException: connect timed out
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.UnknownHostException: api.openstreetmap.org
- W: javax.net.ssl.SSLException: Socket Closed. Cause: java.net.SocketException: Socket Closed
- E: javax.net.ssl.SSLException: Socket Closed. Cause: java.net.SocketException: Socket Closed
- W: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server
- E: org.openstreetmap.josm.io.OsmTransferException: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server
- E: Network exception - <html>Failed to open a connection to the remote server<br>'https://api.openstreetmap.org/api/0.6/'.<br>Please check your internet connection.</html>

Attachments (1)

Screen Recording 2020-11-01 at 17.19.10.mp4 (2.5 MB) - added by Stereo 2 years ago.
Screen recording showing the issue

Change History (15)

comment:1 Changed 2 years ago by Stereo

To maybe help narrow this down: I've also had this happen to me on a recent SVN JOSM, with Java 14, on macOS, without the continuousdownload plugin and without a joz file (nice idea to bookmark your usual layers!).

It feels like JOSM downloads the image tiles, somehow invalidates them right away, and re-downloads them.

comment:2 Changed 2 years ago by simon04

Cc: wiktorn added
Component: CoreCore imagery
Keywords: tiles reload added

Which imagery have you been using? Does clearing the cache via Help/Preferences/Imagery#Cache change anything?

comment:3 Changed 2 years ago by wiktorn

@sharcrash, @Stereo: can you name specific imagery layer, where you observe this behaviour?

comment:4 Changed 2 years ago by simon04

Owner: changed from team to sharcrash
Status: newneedinfo

comment:5 Changed 2 years ago by sharcrash

As said, any layer, whether it's the standard OSM carto layer, Geoportail.lu layers, etc...

I tried clearing all cache from each layer, didn't seem to help, the tiles sometimes still take time to reload after i've been moving/sooming around.

comment:6 Changed 2 years ago by wiktorn

@sharcrash, @simon04 - one more follow up question: how do you now, that tiles are re-downloaded? Did you monitor your network usage or checked anything?

As far as I tried to reproduce this problem with Bing layer, both JOSM logs and tcptrack tool doesn't mention any connection going out to other servers.

On the other hand, there are moments, when you can see hourglass for a moment, before tile shows and they will show with some delay. That's because loading the image into memory (even from cache) is quite expensive operation.

Are you sure, that the tiles are re-downloaded?

comment:7 Changed 2 years ago by sharcrash

I had the impression that the tiles are re-downloaded because they are first pixelated and then get better definition, like in the old times of internet when images used to take a long time to be downloaded.

I just tried now again with the layer "Openstreetmap.lu Lidar Hillshade". I first browsed around so that the images are loaded in all zoom levels and then browsed zooming in/out again around making sure i stay in the same area but I still got this pixel effect by just zooming in/out. This time the effect was fast enough to be nearly unnoticeable. I also monitored, i do get download activity (around 150KB/s - 300KB/s) and some upload (around 2KB/s). I monitored with Net Limiter 4. Then i tried with "Esri World Imagery" and i think the effect got worse, zooming effect was more noticeable.

For the "Hourglass" layer not sure i get it but i do get tiles filled with black for a fraction of second.

comment:8 Changed 2 years ago by wiktorn

I tried also "Openstreetmap.lu Lidar Hillshade". If i have keep specific node in center of the view (just to be sure, that I don't have any location changed) I don't see extra network activity when zooming out/in.

In case of this imagery, I get the impression that last ~3 zoom levels don't provide any extra information/resolution and could be easily dropped, so JOSM would use the tiles from upper levels without needing to download anything.

What other bug it might be, that not best (highest) zoom tile is used, while the tile that is missing, is downloaded. Can't confirm, that's constant re-downloading of tiles.

comment:9 Changed 2 years ago by stoecker

Resolution: worksforme
Status: needinfoclosed

JOSM displays in-memory zoom-levels in zooming until new data is available. That's wanted.

Seems this bug is only a misunderstanding of the way the software works.

In case there is real network traffic generated I recommend checking the cache directory free space or permissions and reset JOSM settings.

comment:10 Changed 2 years ago by anonymous

So let's interpret this differently then: somehow the tiles disappear and take time to reappear. Still it is very inconvenient since it slows down the workflow.

I have 512MB per imagery, i guess that is enough. As for permissions, i don't see what you mean, i haven't seen any permissions option in the "Cache" section tab and i never touched anything about permissions.

comment:11 Changed 2 years ago by sharcrash

So let's interpret this differently then: somehow the tiles disappear and take time to reappear. Still it is very inconvenient since it slows down the workflow.

I have 512MB per imagery, i guess that is enough. As for permissions, i don't see what you mean, i haven't seen any permissions option in the "Cache" section tab and i never touched anything about permissions.

comment:12 Changed 2 years ago by Klumbumbus

I think there was a regression like 2 years ago (rough estimate) which introduced this behavior. Tiles which are in cache disappear for a short time when moving the map.

Last edited 2 years ago by Klumbumbus (previous) (diff)

comment:13 Changed 2 years ago by sharcrash

Where are we at about this issue after 2 months? I just experienced now what seems an obvious behaviour of what i have already reported: I had selected a background layer from which i didn't know the sever was under maintenance. So obviously the tiles where taking a lot of time to load (not the first time i use this layer though). After they have loaded, i moved the map without changing zoom level and they disappeared (black background) and after some seconds, some of them reappeared with a huge pixel effect, others stayed black. Isn't this another fact that tiles are being constantly downloaded again thus resulting in recurrent visual artefacts disrupting us?

Changed 2 years ago by Stereo

Screen recording showing the issue

comment:14 Changed 2 years ago by wiktorn

[17516] should help for that.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain sharcrash.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.