Modify

Opened 4 weeks ago

Closed 4 weeks ago

#19734 closed defect (fixed)

Autofilter: clicking active rule/key opens GPS settings instead of OSM settings

Reported by: simon04 Owned by: simon04
Priority: minor Milestone: 20.08
Component: Core Version:
Keywords: template_report autofilter Cc:

Description

What steps will reproduce the problem?

  1. Add node level=1
  2. Click the autofilter button "level"

What is the expected result?

"Display Settings" opens with tab "OSM Data" (where the autofilter settings can be changed)

What happens instead?

"Display Settings" opens with tab "GPS Points"

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-07-30 12:44:04 +0200 (Thu, 30 Jul 2020)
Revision:16812
Build-Date:2020-07-31 01:30:49
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (16812 en_GB) Linux Arch Linux
Memory Usage: 750 MB / 7870 MB (344 MB allocated, but free)
Java version: 11.0.8+10, N/A, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 3840x2160 (scaling 1.0x1.0)
Maximum Screen Size: 3840x2160
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
VM arguments: [-Djosm.restart=true]
Dataset consistency test: No problems found

Relates to #18628. Might have been caused by #18702.

Attachments (0)

Change History (1)

comment:1 Changed 4 weeks ago by simon04

Resolution: fixed
Status: assignedclosed

In 16979/josm:

fix #19734 - Autofilter: clicking active rule/key opens GPS settings instead of OSM settings

Extract GPXPreference from DrawingPreference

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.