Modify

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#19697 closed defect (duplicate)

ClassNotFoundException: java.sql.Time

Reported by: toaskoas@… Owned by: team
Priority: normal Milestone:
Component: Plugin openstreetcam Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-07-30 12:44:04 +0200 (Thu, 30 Jul 2020)
Revision:16812
Build-Date:2020-07-31 01:30:49
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (16812 de) Linux Debian GNU/Linux 10 (buster)
Memory Usage: 339 MB / 2048 MB (167 MB allocated, but free)
Java version: 11.0.8+10-post-Debian-1deb10u1, Debian, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Java package: openjdk-11-jre:amd64-11.0.8+10-1~deb10u1
WebStart package: icedtea-netx:all-1.7.2-2
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-22
libcommons-compress-java: libcommons-compress-java:all-1.18-2
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:all-20181227-1
liboauth-signpost-java: liboauth-signpost-java:all-1.2.1.2-2
VM arguments: [--patch-module=java.desktop=/usr/share/icedtea-web/netx.jar:, --add-reads=java.base=ALL-UNNAMED,java.desktop, --add-reads=java.desktop=ALL-UNNAMED,java.naming, --add-reads=java.naming=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.awt=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/javax.jnlp=ALL-UNNAMED,java.desktop, --add-exports=java.base/com.sun.net.ssl.internal.ssl=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.net.www.protocol.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.action=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.provider=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.util=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.validator=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.x509=ALL-UNNAMED,java.desktop, --add-exports=java.base/jdk.internal.util.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.net.www.protocol.http=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.awt.X11=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,jdk.jsobject, --add-exports=java.naming/com.sun.jndi.toolkit.url=ALL-UNNAMED,java.desktop, -Dicedtea-web.bin.name=javaws, -Dicedtea-web.bin.location=/usr/share/icedtea-web/bin/javaws.sh, -Djava.security.manager, -Djava.security.policy=/etc/icedtea-web/javaws.policy]

Plugins:
+ FixAddresses (35343)
+ Mapillary (1.5.23)
+ OpenStreetCam (327)
+ OpeningHoursEditor (35414)
+ apache-commons (35362)
+ apache-http (35092)
+ javafx-unixoid (35458)
+ jna (35092)
+ notesolver (0.3.2)
+ todo (30306)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1

Last errors/warnings:
- E: java.lang.UnsatisfiedLinkError: <josm.userdata>/plugins/javafx/libavplugin-56.so: libavcodec.so.56: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
- E: java.lang.UnsatisfiedLinkError: <josm.userdata>/plugins/javafx/libavplugin-54.so: libavcodec.so.54: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
- E: java.lang.UnsatisfiedLinkError: <josm.userdata>/plugins/javafx/libavplugin-ffmpeg-56.so: libavcodec-ffmpeg.so.56: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
- E: java.lang.UnsatisfiedLinkError: <josm.userdata>/plugins/javafx/libavplugin-ffmpeg-57.so: libavcodec.so.57: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
- E: java.lang.UnsatisfiedLinkError: <josm.userdata>/plugins/javafx/libavplugin-57.so: libavcodec.so.57: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: java/sql/Time. Ursache: java.lang.ClassNotFoundException: java.sql.Time


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: pool-1-thread-1 (53)
java.lang.NoClassDefFoundError: java/sql/Time
	at com.google.gson.Gson.<init>(Gson.java:241)
	at com.google.gson.GsonBuilder.create(GsonBuilder.java:545)
	at org.openstreetmap.josm.plugins.openstreetcam.service.photo.OpenStreetCamService.createGson(OpenStreetCamService.java:56)
	at org.openstreetmap.josm.plugins.openstreetcam.service.BaseService.<init>(BaseService.java:40)
	at org.openstreetmap.josm.plugins.openstreetcam.service.photo.OpenStreetCamService.<init>(OpenStreetCamService.java:46)
	at org.openstreetmap.josm.plugins.openstreetcam.handler.SearchServiceHandler.<init>(SearchServiceHandler.java:58)
	at org.openstreetmap.josm.plugins.openstreetcam.handler.ServiceHandler.<init>(ServiceHandler.java:48)
	at org.openstreetmap.josm.plugins.openstreetcam.handler.ServiceHandler.<clinit>(ServiceHandler.java:53)
	at org.openstreetmap.josm.plugins.openstreetcam.gui.details.filter.DetectionTypeContent.generateSigns(DetectionTypeContent.java:43)
	at org.openstreetmap.josm.plugins.openstreetcam.gui.details.filter.DetectionTypeContent.<init>(DetectionTypeContent.java:34)
	at org.openstreetmap.josm.plugins.openstreetcam.gui.details.filter.DetectionTypeContent.<clinit>(DetectionTypeContent.java:31)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: java.lang.ClassNotFoundException: java.sql.Time
	at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:471)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:589)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:73)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522)
	... 14 more

Attachments (0)

Change History (3)

comment:1 Changed 3 months ago by toaskoas@…

When I deactivate the OpenStreetCam plugin, no error message appears anymore.

comment:2 Changed 3 months ago by stoecker

Resolution: duplicate
Status: newclosed

Closed as duplicate of #17673.

comment:3 Changed 3 months ago by stoecker

Component: CorePlugin openstreetcam
Summary: PluginsClassNotFoundException: java.sql.Time

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.