Modify

#19678 closed defect (duplicate)

opened josm after computer reboot

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-08-08 22:09:52 +0200 (Sat, 08 Aug 2020)
Revision:16855
Build-Date:2020-08-09 01:30:49
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (16855 en_GB) Linux Debian GNU/Linux 10 (buster)
Memory Usage: 222 MB / 1966 MB (153 MB allocated, but free)
Java version: 11.0.8+10-post-Debian-1deb10u1, Debian, OpenJDK 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.gtk.GTKLookAndFeel
Screen: :0.0 1366x768 (scaling 1.0x1.0)
Maximum Screen Size: 1366x768
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Java package: openjdk-11-jre:amd64-11.0.8+10-1~deb10u1
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-22
libcommons-compress-java: libcommons-compress-java:all-1.18-2
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:all-20181227-1
VM arguments: [-Djosm.restart=true, -Djosm.dir.name=JOSM-latest, -Djava.net.useSystemProxies=true]

Plugins:
+ apache-commons
+ buildings_tools
+ ejml
+ geotools
+ jaxb (35092)
+ jts
+ opendata
+ turnlanes
+ turnrestrictions
+ utilsplugin2

Last errors/warnings:
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Cannot modify the id counter backwards. Cause: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Cannot modify the id counter backwards. Cause: java.lang.IllegalArgumentException: Cannot modify the id counter backwards


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Cannot modify the id counter backwards
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:89)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:915)
	at org.openstreetmap.josm.gui.MainApplication$3.processArguments(MainApplication.java:276)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:713)
Caused by: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: Cannot modify the id counter backwards
	at java.base/java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.base/java.util.concurrent.FutureTask.get(FutureTask.java:191)
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:78)
	... 3 more
Caused by: java.lang.IllegalArgumentException: Cannot modify the id counter backwards
	at org.openstreetmap.josm.data.osm.UniqueIdGenerator.advanceUniqueId(UniqueIdGenerator.java:38)
	at org.openstreetmap.josm.io.AbstractReader.buildPrimitive(AbstractReader.java:627)
	at org.openstreetmap.josm.io.AbstractReader.addNode(AbstractReader.java:638)
	at org.openstreetmap.josm.io.AbstractReader.parseNode(AbstractReader.java:680)
	at org.openstreetmap.josm.io.OsmReader.parseNode(OsmReader.java:230)
	at org.openstreetmap.josm.io.OsmReader.parseOsm(OsmReader.java:169)
	at org.openstreetmap.josm.io.OsmReader.parseRoot(OsmReader.java:135)
	at org.openstreetmap.josm.io.OsmReader.parse(OsmReader.java:121)
	at org.openstreetmap.josm.io.OsmReader.lambda$doParseDataSet$0(OsmReader.java:491)
	at org.openstreetmap.josm.io.AbstractReader.doParseDataSet(AbstractReader.java:298)
	at org.openstreetmap.josm.io.OsmReader.doParseDataSet(OsmReader.java:488)
	at org.openstreetmap.josm.io.OsmReader.parseDataSet(OsmReader.java:538)
	at org.openstreetmap.josm.io.OsmReader.parseDataSet(OsmReader.java:521)
	at org.openstreetmap.josm.tools.Territories.initializeInternalData(Territories.java:137)
	at org.openstreetmap.josm.tools.Territories.initialize(Territories.java:123)
	at org.openstreetmap.josm.gui.MainInitialization.lambda$parallelInitializationTasks$6(MainInitialization.java:114)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:33)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:11)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:834)

Attachments (0)

Change History (1)

comment:1 Changed 18 months ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #19532.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.