Modify

#19671 closed defect (fixed)

Error when trying to upload images to Mapillary (with Mapillary plugin)

Reported by: ggrab Owned by: taylor.smock
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

The steps are described in:
https://wiki.openstreetmap.org/wiki/JOSM/Plugins/Mapillary#Upload_images_from_a_.22GeoImage_layer.22_to_mapillary.com

What is the expected result?

The images are uploaded to Mapillary.

What happens instead?

An error message: "An unexpected exception occurred." See attachment.

Please provide any additional information below. Attach a screenshot if possible.

Both JOSM and the Mapillary plugin are up to date.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-07-30 12:44:04 +0200 (Thu, 30 Jul 2020)
Revision:16812
Build-Date:2020-07-31 01:30:49
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (16812 en) Linux Ubuntu 20.04.1 LTS
Memory Usage: 1143 MB / 1962 MB (767 MB allocated, but free)
Java version: 11.0.8+10-post-Ubuntu-0ubuntu120.04, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1600x900 (scaling 1.0x1.0), :0.1 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Java package: openjdk-11-jre:amd64-11.0.8+10-0ubuntu1~20.04
Java ATK Wrapper package: libatk-wrapper-java:all-0.37.1-1
fonts-noto: fonts-noto:-
VM arguments: [--add-modules=java.scripting,java.sql, -Djosm.restart=true, -Djava.net.useSystemProxies=true, -Dawt.useSystemAAFontSettings=on, -Dswing.aatext=true]
Dataset consistency test: No problems found

Plugins:
+ Mapillary (1.5.23)
+ apache-commons (35362)
+ apache-http (35092)
+ ejml (35313)
+ geotools (35169)
+ javafx-unixoid (35458)
+ jaxb (35092)
+ jna (35092)
+ jts (35122)
+ opendata (35513)
+ pbf (35446)
+ utilsplugin2 (35487)

Last errors/warnings:
- E: java.lang.UnsatisfiedLinkError: <josm.userdata>/plugins/javafx/libfxplugins.so: libgstreamer-lite.so: cannot open shared object file: No such file or directory
- E: java.lang.UnsatisfiedLinkError: <josm.userdata>/plugins/javafx/libavplugin-ffmpeg-57.so: libgstreamer-lite.so: cannot open shared object file: No such file or directory
- E: java.lang.UnsatisfiedLinkError: <josm.userdata>/plugins/javafx/libavplugin-54.so: libgstreamer-lite.so: cannot open shared object file: No such file or directory
- E: java.lang.UnsatisfiedLinkError: <josm.userdata>/plugins/javafx/libavplugin-56.so: libgstreamer-lite.so: cannot open shared object file: No such file or directory
- E: java.lang.UnsatisfiedLinkError: <josm.userdata>/plugins/javafx/libavplugin-ffmpeg-56.so: libavcodec-ffmpeg.so.56: cannot open shared object file: No such file or directory
- E: Trying to get https://www.mapillary.com/developer/api-documentation/images/traffic_sign/general--traffic-sign--g1.png general--traffic-sign--g1
- W: Failed to download icon. ID unknown to the icon list: general--traffic-sign--g1: java.io.IOException: The requested URL https://www.mapillary.com/developer/api-documentation/images/traffic_sign/general--traffic-sign--g1.png was not found
- W: Invalid Mapillary token, resetting field: java.io.FileNotFoundException: https://a.mapillary.com/v2/me/uploads/secrets?client_id=UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory. Cause: java.lang.ClassNotFoundException: org.apache.commons.logging.LogFactory
- W: Warning - <html>JOSM could not find information about the following plugins:<ul><li>apache-commons</li><li>geotools</li><li>opendata</li><li>jts</li><li>Mapillary</li><li>ejml</li><li>jaxb</li><li>utilsplugin2</li><li>pbf</li><li>javafx-unixoid</li><li>jna</li><li>apache-http</li></ul>The plugins are not going to be loaded.</html>


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: pool-5-thread-1 (392)
java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory
	at org.apache.http.conn.ssl.DefaultHostnameVerifier.<init>(DefaultHostnameVerifier.java:82)
	at org.apache.http.impl.client.HttpClientBuilder.build(HttpClientBuilder.java:955)
	at org.openstreetmap.josm.plugins.mapillary.oauth.UploadUtils.uploadFile(UploadUtils.java:271)
	at org.openstreetmap.josm.plugins.mapillary.oauth.UploadUtils.upload(UploadUtils.java:235)
	at org.openstreetmap.josm.plugins.mapillary.oauth.UploadUtils$SequenceUploadRunnable.lambda$run$1(UploadUtils.java:109)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: java.lang.ClassNotFoundException: org.apache.commons.logging.LogFactory
	at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:471)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:589)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:73)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522)
	... 8 more

Attachments (1)

Screenshot from 2020-08-13 22-59-13.png (23.5 KB) - added by ggrab 16 months ago.

Download all attachments as: .zip

Change History (5)

Changed 16 months ago by ggrab

comment:1 Changed 16 months ago by stoecker

Component: CorePlugin mapillary
Owner: changed from team to taylor.smock

comment:2 Changed 16 months ago by taylor.smock

I've got a fix for the root problem here: https://josm.openstreetmap.de/ticket/19562

The problem is that the apache-http plugin requires apache-logging for some functions. While I can include apache-logging in the Mapillary plugin, I don't think it is the proper place to "fix" the issue. Since apache-http requires apache-logging for some functions, either apache-http should include apache-logging or apache-commons should include apache-logging (which, IIRC, apache-http depends upon).

comment:3 Changed 16 months ago by ggrab

Thx!
The integration of apache-logging into apache-common sounds like a good solution (although I'm not a JOSM developer). Is there a chance that this is being implemented before long?

comment:4 Changed 15 months ago by taylor.smock

Resolution: fixed
Status: newclosed

This should be fixed now.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain taylor.smock.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.