Modify

Opened 7 weeks ago

Closed 7 weeks ago

#19660 closed enhancement (fixed)

"Area is unnecessary for leisure" warning with free flying field

Reported by: surveyorgirl Owned by: Klumbumbus
Priority: normal Milestone: 20.08
Component: Core validator Version:
Keywords: template_report area leisure free_flying Cc:

Description

What steps will reproduce the problem?

  1. Create an area
  2. Tag the area with sport=free_flying leisure=pitch
  3. Upload

What is the expected result?

Changes are uploaded with no warnings

What happens instead?

I get an "area is unnecessary for leisure" warning

Please provide any additional information below. Attach a screenshot if possible.

Free flying takeoff/landing sites are large areas, with very specific boundaries. A point would be inappropriate

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-07-30 12:44:04 +0200 (Thu, 30 Jul 2020)
Build-Date:2020-07-31 01:30:49
Revision:16812
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16812 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1909 (18363)
Memory Usage: 889 MB / 1820 MB (743 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Plugins:
+ imagery_offset_db (35405)
+ turnrestrictions (35515)

Attachments (0)

Change History (4)

comment:1 Changed 7 weeks ago by skyper

Owner: changed from team to surveyorgirl
Status: newneedinfo

I only get the warning with an unneeded area=yes, which is correct. Are you sure you get the warning without area yes, cause I cannot reproduce.

Last edited 7 weeks ago by skyper (previous) (diff)

comment:2 Changed 7 weeks ago by Klumbumbus

Milestone: 20.08
Type: defectenhancement

Yes it only warns if area=yes is tagged. So the warning is correct. However we can improve the warning text.

comment:3 Changed 7 weeks ago by Klumbumbus

Owner: changed from surveyorgirl to Klumbumbus
Status: needinfonew

comment:4 Changed 7 weeks ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 16856/josm:

fix #19660 - Improve warning text

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Klumbumbus.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.