Modify

Opened 10 years ago

Closed 10 years ago

#1962 closed defect (duplicate)

two exceptions when downloading

Reported by: p4e+xpamso@… Owned by: framm
Priority: major Milestone:
Component: unspecified Version: latest
Keywords: Cc:

Description

I selected a area on the slippymap-plugin and clicked on OK.

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1208
Node Kind: directory
Last Changed Author: ulfl
Last Changed Rev: 1208
Last Changed Date: 2009-01-03 16:03:54 +0100 (Sat, 03 Jan 2009)

Plugins: namefinder;openstreetbugs;plastic_laf;slippy_map_chooser;slippymap;usertools;wmsplugin
Plugin plastic_laf Version: 10336
Plugin namefinder Version: 9236
Plugin openstreetbugs Version: 0.5.6
Plugin slippy_map_chooser Version: 11783
Plugin slippymap Version: 12104
Plugin wmsplugin Version: 12335

java.lang.NullPointerException

at org.openstreetmap.josm.plugins.osb.OsbPlugin.layerAdded(OsbPlugin.java:216)
at org.openstreetmap.josm.gui.MapView.addLayer(MapView.java:166)
at org.openstreetmap.josm.Main.addLayer(Main.java:349)
at org.openstreetmap.josm.actions.NewAction.actionPerformed(NewAction.java:22)
at org.openstreetmap.josm.Main.editLayer(Main.java:356)
at org.openstreetmap.josm.gui.MapView.zoomToEditLayerBoundingBox(MapView.java:387)
at org.openstreetmap.josm.gui.MapView$1.componentResized(MapView.java:89)
at java.awt.Component.processComponentEvent(Component.java:5934)
at java.awt.Component.processEvent(Component.java:5888)
at java.awt.Container.processEvent(Container.java:2105)
at java.awt.Component.dispatchEventImpl(Component.java:4469)
at java.awt.Container.dispatchEventImpl(Container.java:2163)
at java.awt.Component.dispatchEvent(Component.java:4295)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:604)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1208
Node Kind: directory
Last Changed Author: ulfl
Last Changed Rev: 1208
Last Changed Date: 2009-01-03 16:03:54 +0100 (Sat, 03 Jan 2009)

Plugins: namefinder;openstreetbugs;plastic_laf;slippy_map_chooser;slippymap;usertools;wmsplugin
Plugin plastic_laf Version: 10336
Plugin namefinder Version: 9236
Plugin openstreetbugs Version: 0.5.6
Plugin slippy_map_chooser Version: 11783
Plugin slippymap Version: 12104
Plugin wmsplugin Version: 12335

java.lang.RuntimeException: java.lang.reflect.InvocationTargetException

at org.openstreetmap.josm.gui.PleaseWaitRunnable.closeDialog(PleaseWaitRunnable.java:146)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:95)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:636)

Caused by: java.lang.reflect.InvocationTargetException

at java.awt.EventQueue.invokeAndWait(EventQueue.java:1000)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.closeDialog(PleaseWaitRunnable.java:142)
... 4 more

Caused by: org.openstreetmap.josm.plugins.PluginException: Ein Fehler ist in dem Plugin openstreetbugs aufgetreten.

at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:33)
at org.openstreetmap.josm.Main.setMapFrame(Main.java:166)
at org.openstreetmap.josm.Main.addLayer(Main.java:344)
at org.openstreetmap.josm.actions.NewAction.actionPerformed(NewAction.java:22)
at org.openstreetmap.josm.Main.editLayer(Main.java:356)
at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$Task.finish(DownloadOsmTask.java:62)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$4.run(PleaseWaitRunnable.java:128)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:216)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:194)
at java.awt.Dialog$1.run(Dialog.java:1072)
at java.awt.Dialog$3.run(Dialog.java:1126)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Dialog.java:1124)
at java.awt.Component.show(Component.java:1464)
at java.awt.Component.setVisible(Component.java:1416)
at java.awt.Window.setVisible(Window.java:842)
at java.awt.Dialog.setVisible(Dialog.java:1011)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$3.run(PleaseWaitRunnable.java:78)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Caused by: java.lang.reflect.InvocationTargetException

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:616)
at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:30)
... 28 more

Caused by: java.lang.NoSuchMethodError: org.openstreetmap.josm.gui.MapFrame.addToggleDialog(Lorg/openstreetmap/josm/gui/dialogs/ToggleDialog;)V

at org.openstreetmap.josm.plugins.osb.OsbPlugin.mapFrameInitialized(OsbPlugin.java:178)
... 33 more

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by stoecker

Resolution: duplicate
Status: newclosed

Duplicate of #1883.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.