Modify

Opened 7 weeks ago

Closed 3 weeks ago

Last modified 3 weeks ago

#19619 closed defect (fixed)

Parameter 'data' must not be null via TagChecker.check

Reported by: simon04 Owned by: team
Priority: minor Milestone: 20.08
Component: Core validator Version:
Keywords: template_report regression Cc: GerdP

Description

What steps will reproduce the problem?

  1. Validate node 743050836 version 7

What is the expected result?

2020-08-03 19:41:17.037 SEVERE: java.lang.IllegalArgumentException: Parameter 'data' must not be null
java.lang.IllegalArgumentException: Parameter 'data' must not be null
	at org.openstreetmap.josm.tools.CheckParameterUtil.ensureParameterNotNull(CheckParameterUtil.java:26)
	at org.openstreetmap.josm.command.Command.<init>(Command.java:138)
	at org.openstreetmap.josm.command.ChangePropertyCommand.<init>(ChangePropertyCommand.java:106)
	at org.openstreetmap.josm.command.ChangePropertyCommand.<init>(ChangePropertyCommand.java:120)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker$FixCommand$1.createCommand(MapCSSTagChecker.java:152)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker$TagCheck.lambda$fixPrimitive$1(MapCSSTagChecker.java:466)
	at java.base/java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:195)
	at java.base/java.util.Collections$2.tryAdvance(Collections.java:4747)
	at java.base/java.util.Collections$2.forEachRemaining(Collections.java:4755)
	at java.base/java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:484)
	at java.base/java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:474)
	at java.base/java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:913)
	at java.base/java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
	at java.base/java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:578)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker$TagCheck.fixPrimitive(MapCSSTagChecker.java:467)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker$TagCheck.getErrorsForPrimitive(MapCSSTagChecker.java:547)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker.getErrorsForPrimitive(MapCSSTagChecker.java:675)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker.check(MapCSSTagChecker.java:755)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker.visit(MapCSSTagChecker.java:924)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker.runOnly(MapCSSTagChecker.java:994)
	at org.openstreetmap.josm.data.validation.tests.TagChecker.countDeprecated(TagChecker.java:995)
	at org.openstreetmap.josm.data.validation.tests.TagChecker.filterDeprecatedTags(TagChecker.java:986)
	at org.openstreetmap.josm.data.validation.tests.TagChecker.tryGuess(TagChecker.java:929)
	at org.openstreetmap.josm.data.validation.tests.TagChecker.checkSingleTagComplex(TagChecker.java:843)
	at org.openstreetmap.josm.data.validation.tests.TagChecker.check(TagChecker.java:625)
	at org.openstreetmap.josm.data.validation.Test$TagTest.visit(Test.java:129)
	at org.openstreetmap.josm.data.osm.Node.accept(Node.java:210)
	at org.openstreetmap.josm.data.validation.Test.visit(Test.java:216)
	at org.openstreetmap.josm.data.validation.tests.TagChecker.visit(TagChecker.java:1061)
	at org.openstreetmap.josm.actions.ValidateAction$ValidationTask.realRun(ValidateAction.java:169)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:94)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:142)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
	at java.base/java.util.concurrent.FutureTask.run$$$capture(FutureTask.java:264)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:834)

2020-08-03 19:41:19.815 INFO: POST https://josm.openstreetmap.de/josmticket (1.42 kB) ...
2020-08-03 19:41:20.030 INFO: POST https://josm.openstreetmap.de/josmticket -> HTTP/1.1 200 (84 ms)
2020-08-03 19:41:20.102 INFO: Opening URL: https://josm.openstreetmap.de/josmticket?pdata_stored=8202d42b5a078eaad808ef7f

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Revision:16826
Is-Local-Build:true
Build-Date:2020-08-03 19:26:00

Identification: JOSM/1.5 (16826 SVN en) Linux Arch Linux
Memory Usage: 308 MB / 3970 MB (154 MB allocated, but free)
Java version: 11.0.8+10, N/A, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 3840x2160 (scaling 1.0x1.0)
Maximum Screen Size: 3840x2160
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
VM arguments: [-agentlib:jdwp=transport=dt_socket,address=127.0.0.1:36767,suspend=y,server=n, -Djosm.home=<josm.pref>, -javaagent:/home/simon/.local/share/JetBrains/Toolbox/apps/IDEA-U/ch-0/202.6397.94/plugins/Groovy/lib/agent/gragent.jar, -javaagent:/home/simon/.local/share/JetBrains/Toolbox/apps/IDEA-U/ch-0/202.6397.94/plugins/java/lib/rt/debugger-agent.jar, -Dfile.encoding=UTF-8]
Program arguments: [--set=expert=true, --set=iso.dates=true, --set=debug.edt-checker.enable=true, --set=tls.add-missing-certificates=false]
Dataset consistency test: No problems found

Last errors/warnings:
- E: java.lang.IllegalArgumentException: Parameter 'data' must not be null

Attachments (1)

n743050836.xml (817 bytes) - added by simon04 7 weeks ago.

Download all attachments as: .zip

Change History (7)

Changed 7 weeks ago by simon04

Attachment: n743050836.xml added

comment:1 Changed 3 weeks ago by simon04

Milestone: 20.0820.09
Priority: normalminor

The error is just printed to the console. So no real harm is done…

comment:3 Changed 3 weeks ago by simon04

Yes, pretty much, since the other stack traces do not contain TagChecker/MapCSSTagChecker

The IllegalArgumentException: Parameter 'data' must not be null can happen in many places which check that a given DataSet data is not null.

comment:4 Changed 3 weeks ago by GerdP

Resolution: fixed
Status: newclosed

In 17011/josm:

fix #19619: Parameter 'data' must not be null via TagChecker.check
Add a null check, we never need a fix command for a primitive without a dataset.

comment:5 Changed 3 weeks ago by GerdP

Keywords: regression added

Regression of r16812, see #19180.

comment:6 Changed 3 weeks ago by Klumbumbus

Milestone: 20.0920.08

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.