Modify

Opened 8 days ago

Closed 8 days ago

Last modified 7 days ago

#19610 closed defect (duplicate)

JOSM error when map is displayed

Reported by: InsertUser Owned by: Tyndare
Priority: normal Milestone:
Component: Plugin conflation Version:
Keywords: template_report, conflate Cc:

Description

What steps will reproduce the problem?

  1. Open JOSM
  2. Create new data layer or load an imagery layer.

What is the expected result?

JOSM displays imagery layer.

What happens instead?

JOSM displays the error message:

Update plugins

An unexpected exception occured that may have ocome form the 'conflation' plug-in.
According to the informaiotn within theplug-in, the author is Josh Doe.
Try updating to the new version of this plug-in before reporting a bug.
Update plugin | Disable plug-in | Keep plug-in | Help

Selecting Update plugin gives the message:

Warning

JOSM could not find information about the following plug-ins:
tageditor
opendata
ShapeTools
editgpx
turnlanes-tagging
utilsplugin2
terracer
jna
PicLayer
contourmerge
rex
ImproveOsm
Mapillary
ejml
reverter
pt_assistant
photo_geotagging
undelete
waydownloader
ImproveWay
SeaMapEditor
apache-commons
HouseNumberTaggingTool
conflation
geotools
RoadSigns
javafx-windows
FixAddresses
measurement
OpenStreetCam
continuosDownload
jaxb
routing
SeaChart
jogl
turnrestrictions
log4j
CustomizePublicTransportStop
Create_grid_of_ways
jts
kendzi3d-resources
mapdust
graphview
changeset-viewer
turnlanes
FastDraw
kendzi3d
ImportImagePlugin
OpeningHoursEditor
buildings_tools
gson
apache-http
The plug-ins are not going to be loaded.

Accepting that warning leads to the "You have encountered a bug in JOSM" window that redirects here.

Ignoring the errors and manually doing a plugin update sppears to succesfully load the list of plugins and return a statement that they are all up to date. Opening hours editor, kenzi 3d and other plugins seem to load OK despite the warning that they will not. The conflate plugin does not.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-07-30 12:44:04 +0200 (Thu, 30 Jul 2020)
Build-Date:2020-07-31 01:30:49
Revision:16812
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16812 en_GB) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1909 (18363)
Memory Usage: 1463 MB / 1820 MB (491 MB allocated, but free)
Java version: 1.8.0_181-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 2560x1440 (scaling 1.0x1.0)
Maximum Screen Size: 2560x1440
Best cursor sizes: 16x16 -> 48x48, 32x32 -> 48x48
Dataset consistency test: No problems found

Plugins:
+ Create_grid_of_ways (35405)
+ CustomizePublicTransportStop (35248)
+ FastDraw (35499)
+ FixAddresses (35343)
+ HouseNumberTaggingTool (35508)
+ ImportImagePlugin (35248)
+ ImproveOsm (199)
+ ImproveWay (29)
+ Mapillary (1.5.23)
+ OpenStreetCam (327)
+ OpeningHoursEditor (35414)
+ PicLayer (35405)
+ RoadSigns (35510)
+ SeaChart (35483)
+ SeaMapEditor (35480)
+ ShapeTools (1240)
+ apache-commons (35362)
+ apache-http (35092)
+ buildings_tools (35500)
+ changeset-viewer (22)
+ conflation (0.6.5)
+ continuosDownload (91)
+ contourmerge (v0.1.6)
+ editgpx (35248)
+ ejml (35313)
+ geotools (35169)
+ graphview (35405)
+ gson (35313)
+ javafx-windows (35458)
+ jaxb (35092)
+ jna (35092)
+ jogl (1.2.3)
+ jts (35122)
+ kendzi3d (1.0.205)
+ kendzi3d-resources (0.0.2)
+ log4j (35092)
+ mapdust (35248)
+ measurement (35405)
+ opendata (35513)
+ photo_geotagging (35499)
+ pt_assistant (2.1.10-80-g7d9bba3)
+ reverter (35499)
+ rex (53)
+ routing (35405)
+ tageditor (35258)
+ terracer (35499)
+ turnlanes (35405)
+ turnlanes-tagging (283)
+ turnrestrictions (35515)
+ undelete (35499)
+ utilsplugin2 (35487)
+ waydownloader (35405)

Tagging presets:
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/INT-1-preset.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/OpenSeaMap-PresetForSeamarks&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Simple_Indoor_Tagging&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Power_Mapping_Utility_Simple&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Diving&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
+ https://github.com/kendzi/Simple3dBuildingsPreset/releases/download/0.9_2018-05-08/s3db-preset.zip
+ https://raw.githubusercontent.com/osmlab/name-suggestion-index/master/dist/name-suggestions.presets.xml
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/Presets_Hafen.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historic_Stone&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Industrial&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/GB.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/COVID-19&zip=1
+ https://github.com/simonpoole/beautified-JOSM-preset/releases/latest/download/josm.zip

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://github.com/GlassOceanos/indoor-JOSM-style/archive/master.zip
+ https://raw.githubusercontent.com/OpenSeaMap/josm/master/INT1_Seamark.mapcss
- https://raw.githubusercontent.com/yopaseopor/indoormap/master/indoormap-style.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/Bench&zip=1
- https://raw.githubusercontent.com/OpenSeaMap/josm/master/BNIWR_MapCSS.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Building_Levels_Labels&zip=1
- https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Power&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PowerMapping&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleBuildingTags&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleRoofTags&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/TreeCrownDiameter&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs_EUR_OC.zip

Last errors/warnings:
- E: Broken tagging preset "service-Service way type" - number of items in 'display_values' must be the same as in 'values'
- E: Detailed information: [Alley, Driveway, Parking, Parking aisle, Drive-through, Emergency access] <> [alley, driveway, parking_aisle, drive-through, emergency_access]
- E: Broken tagging preset "area:highway-Street type" - number of items in 'display_values' must be the same as in 'values'
- E: Detailed information: [Bus stop, Crossing, Cycleway, Footway, Junction, Living street, Motorway, Motorway link, Parking space, Parking lane, Pedestrian, Primary, Primary link, Residential, Secondary, Secondary link, Service, Steps, Tertiary, Tertiary link, Traffic island, Trunk, Trunk link, Unclassified, Yes] <> [bus_stop, crossing, cycleway, footway, junction, living_street, motorway, motorway_link, , parking_space, parking_lane, pedestrian, primary, primary_link, residential, secondary, secondary_link, service, steps, tertiary, tertiary_link, traffic_island, trunk, trunk_link, unclassified, yes]
- E: Broken tagging preset "dance:style-Styles" - number of items in 'display_values' must be the same as in 'values'
- E: Detailed information: [Ballroom, Latin] <> [ballroom, latin, Tango]
- E: Failed to locate image 'dialogs/settings'
- E: Handled by bug report queue: org.openstreetmap.josm.plugins.PluginException: An error occurred in plug-in conflation. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.IllegalArgumentException: No icon provided
- W: Warning - <html>JOSM could not find information about the following plug-ins:<ul><li>tageditor</li><li>opendata</li><li>ShapeTools</li><li>editgpx</li><li>turnlanes-tagging</li><li>utilsplugin2</li><li>terracer</li><li>jna</li><li>PicLayer</li><li>contourmerge</li><li>rex</li><li>ImproveOsm</li><li>Mapillary</li><li>ejml</li><li>reverter</li><li>pt_assistant</li><li>photo_geotagging</li><li>undelete</li><li>waydownloader</li><li>ImproveWay</li><li>SeaMapEditor</li><li>apache-commons</li><li>HouseNumberTaggingTool</li><li>conflation</li><li>geotools</li><li>RoadSigns</li><li>javafx-windows</li><li>FixAddresses</li><li>measurement</li><li>OpenStreetCam</li><li>continuosDownload</li><li>jaxb</li><li>routing</li><li>SeaChart</li><li>jogl</li><li>turnrestrictions</li><li>log4j</li><li>CustomizePublicTransportStop</li><li>Create_grid_of_ways</li><li>jts</li><li>kendzi3d-resources</li><li>mapdust</li><li>graphview</li><li>changeset-viewer</li><li>turnlanes</li><li>FastDraw</li><li>kendzi3d</li><li>ImportImagePlugin</li><li>OpeningHoursEditor</li><li>buildings_tools</li><li>gson</li><li>apache-http</li></ul>The plug-ins are not going to be loaded.</html>
- W: Missing plugin main version in plugin scoutsigns


=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
org.openstreetmap.josm.plugins.PluginException: An error occurred in plug-in conflation
	at org.openstreetmap.josm.plugins.PluginProxy.handlePluginException(PluginProxy.java:60)
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:71)
	at org.openstreetmap.josm.gui.MainPanel.updateContent(MainPanel.java:80)
	at org.openstreetmap.josm.gui.MainPanel$1.beforeFirstLayerAdded(MainPanel.java:157)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realAddLayer(MainLayerManager.java:281)
	at org.openstreetmap.josm.gui.layer.LayerManager.lambda$addLayer$0(LayerManager.java:217)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:240)
	at org.openstreetmap.josm.gui.layer.LayerManager.addLayer(LayerManager.java:217)
	at org.openstreetmap.josm.gui.layer.LayerManager.addLayer(LayerManager.java:206)
	at org.openstreetmap.josm.actions.NewAction.actionPerformed(NewAction.java:31)
	at javax.swing.SwingUtilities.notifyAction(Unknown Source)
	at javax.swing.JComponent.processKeyBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
	at javax.swing.JComponent.processKeyBindings(Unknown Source)
	at javax.swing.JComponent.processKeyEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:66)
	... 47 more
Caused by: java.lang.IllegalArgumentException: No icon provided
	at org.openstreetmap.josm.gui.SideButton.<init>(SideButton.java:43)
	at org.openstreetmap.josm.plugins.conflation.ConflationToggleDialog.<init>(ConflationToggleDialog.java:223)
	at org.openstreetmap.josm.plugins.conflation.ConflationPlugin.mapFrameInitialized(ConflationPlugin.java:23)
	... 52 more

Attachments (0)

Change History (2)

comment:1 Changed 8 days ago by Klumbumbus

Component: CorePlugin conflation
Owner: changed from team to Tyndare
Resolution: duplicate
Status: newclosed

Closed as duplicate of #19592.

comment:2 Changed 7 days ago by Klumbumbus

Please update the conflation plugin to version 0.6.6.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Tyndare.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.