Modify

Opened 7 days ago

Closed 4 days ago

#19608 closed defect (duplicate)

Josm can't open gpx track that contains russian letters in filename

Reported by: dbf Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Try to open gpx track that contains russian letters in file name

What is the expected result?

Track is loaded

What happens instead?

Error is displayed

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-04-06 02:17:07 +0200 (Mon, 06 Apr 2020)
Build-Date:2020-04-06 00:18:43
Revision:16239
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16239 en) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 695 MB / 1820 MB (175 MB allocated, but free)
Java version: 1.8.0_161-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1680x1050
Maximum Screen Size: 1680x1050
Program arguments: [%UserProfile%\AppData\Local\Temp\2020-08-01_?????????.gpx]

Plugins:
+ MicrosoftStreetside (35248)
+ apache-commons (35362)
+ apache-http (35092)
+ buildings_tools (35500)
+ imagery_offset_db (35405)
+ javafx-windows (35458)
+ jna (35092)
+ turnrestrictions (35405)
+ utilsplugin2 (35476)

Last errors/warnings:
- E: java.io.IOException: java.nio.file.InvalidPathException: Illegal char <?> at index 41: %UserProfile%\AppData\Local\Temp\2020-08-01_?????????.gpx. Cause: java.nio.file.InvalidPathException: Illegal char <?> at index 41: %UserProfile%\AppData\Local\Temp\2020-08-01_?????????.gpx
- W: java.io.IOException: Invalid argument
- E: Error - <html>Could not read file '2020-08-01_?????????.gpx'.<br>Error is:<br>java.nio.file.InvalidPathException: Illegal char &lt;?&gt; at index 41: %UserProfile%\AppData\Local\Temp\2020-08-01_?????????.gpx</html>

Attachments (1)

Clip2net_200801193832.png (11.9 KB) - added by anonymous 7 days ago.

Download all attachments as: .zip

Change History (2)

Changed 7 days ago by anonymous

Attachment: Clip2net_200801193832.png added

comment:1 Changed 4 days ago by simon04

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14596.
Unfortunately, a known problem without a fix…

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.