Modify

Opened 3 months ago

Closed 6 days ago

#19530 closed defect (duplicate)

DataIntegrityProblemException: Deleted node referenced

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report deleted node Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-04-06 02:17:07 +0200 (Mon, 06 Apr 2020)
Build-Date:2020-04-06 00:18:43
Revision:16239
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16239 en) Windows 7 32-Bit
OS Build number: Windows 7 Ultimate (7601)
Memory Usage: 209 MB / 247 MB (86 MB allocated, but free)
Java version: 1.8.0_231-b11, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768

Dataset consistency test:
[DELETED REFERENCED] {Way id=98627970 version=1 MVT nodes=[{Node id=-112580 version=0 MV lat=38.704143873602455,lon=-9.167647138937465}, {Node id=1141067272 version=1 MV lat=38.70410657997648,lon=-9.167402792949357}, {Node id=1141067826 version=1 V lat=38.7041831,lon=-9.1674096}, {Node id=1141067921 version=1 V lat=38.7042082,lon=-9.1674069}, {Node id=1141067600 version=1 V lat=38.7042082,lon=-9.1676483}, {Node id=1141067543 version=1 MVD lat=38.70410647997648,lon=-9.16763960327706}]} refers to deleted primitive {Node id=1141067543 version=1 MVD lat=38.70410647997648,lon=-9.16763960327706}


Plugins:
+ PicLayer (35405)
+ alignways (35474)
+ pdfimport (35494)
+ reverter (35474)
+ tageditor (35258)
+ turnlanes-tagging (283)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1

Last errors/warnings:
- E: Failed to locate image 'http://www.igeo.pt/favicon.ico'
- E: Failed to locate image 'http://www.igeo.pt/favicon.ico'
- E: Failed to locate image 'http://www.igeo.pt/favicon.ico'
- E: Failed to locate image 'http://www.igeo.pt/favicon.ico'
- E: Failed to locate image 'http://www.igeo.pt/favicon.ico'
- E: Failed to locate image 'http://www.igeo.pt/favicon.ico'
- E: Failed to locate image 'http://www.igeo.pt/favicon.ico'
- W: Conflicts detected - <html>There were 2 conflicts detected.</html>
- W: Warning - <html>The data to be uploaded participates in unresolved conflicts of layer 'Data Layer 1_20200713_235453084.osm'.<br>You have to resolve them first.</html>
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted node referenced: {Way id=98627970 version=1 MVT nodes=[{Node id=-112580 version=0 MV lat=38.704143873602455,lon=-9.167647138937465}, {Node id=1141067272 version=1 MV lat=38.70410657997648,lon=-9.167402792949357}, {Node id=1141067826 version=1 V lat=38.7041831,lon=-9.1674096}, {Node id=1141067921 version=1 V lat=38.7042082,lon=-9.1674069}, {Node id=1141067600 version=1 V lat=38.7042082,lon=-9.1676483}, {Node id=1141067543 version=1 MVD lat=38.70410647997648,lon=-9.16763960327706}]}


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (15) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted node referenced: {Way id=98627970 version=1 MVT nodes=[{Node id=-112580 version=0 MV lat=38.704143873602455,lon=-9.167647138937465}, {Node id=1141067272 version=1 MV lat=38.70410657997648,lon=-9.167402792949357}, {Node id=1141067826 version=1 V lat=38.7041831,lon=-9.1674096}, {Node id=1141067921 version=1 V lat=38.7042082,lon=-9.1674069}, {Node id=1141067600 version=1 V lat=38.7042082,lon=-9.1676483}, {Node id=1141067543 version=1 MVD lat=38.70410647997648,lon=-9.16763960327706}]}
	at org.openstreetmap.josm.data.osm.Way.checkNodes(Way.java:551)
	at org.openstreetmap.josm.data.osm.Way.fireNodesChanged(Way.java:567)
	at org.openstreetmap.josm.data.osm.Way.setNodes(Way.java:65)
	at org.openstreetmap.josm.data.osm.Way.cloneFrom(Way.java:307)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.cloneFrom(OsmPrimitive.java:886)
	at org.openstreetmap.josm.command.ChangeCommand.executeCommand(ChangeCommand.java:67)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:79)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:300)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:354)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.mouseReleased(DrawAction.java:661)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 3 months ago by skyper

Keywords: deleted node added
Owner: changed from team to anonymous
Status: newneedinfo
Summary: bugDataIntegrityProblemException: Deleted node referenced

What did you do?
Please, describe as detailed as possible your last actions/steps before the conflicts.
Is it reproducible?
How?
How did you get the data inconsistency?

Last edited 3 months ago by skyper (previous) (diff)

comment:2 Changed 6 days ago by GerdP

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #19438.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.