Modify

Opened 9 months ago

Closed 7 months ago

#19516 closed defect (fixed)

Mapillary green dots are misaligned with 125% scale

Reported by: vasony <vasony.tamas@…> Owned by: cbeddow
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: template_report hidpi Cc: taylor.smock

Description (last modified by Klumbumbus)

What steps will reproduce the problem?

  1. Set the text size to 125% in Windows 10
  2. Start using mapillary plugin

What is the expected result?

The green dots are in the right place. Mapillary (1.5.22) works great with JOSM 16239.

What happens instead?

The green dots are not aligned to the green line (see screenshot) and are not clickable.

Please provide any additional information below. Attach a screenshot if possible.


Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-06-30 19:13:42 +0200 (Tue, 30 Jun 2020)
Revision:16731
Build-Date:2020-07-01 01:30:51
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (16731 en) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 1809 (17763)
Memory Usage: 283 MB / 2048 MB (114 MB allocated, but free)
Java version: 12.0.1-ojdkbuild+12, N/A, OpenJDK 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.25x1.25)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Plugins:
+ Mapillary (1.5.23)
+ apache-commons (35362)
+ apache-http (35092)
+ javafx-windows (35458)
+ jna (35092)

Last errors/warnings:
- W: Region [userProfile_BLOCK_v2] : Problem verifying disk.
- W: java.net.SocketTimeoutException: Read timed out. Cause: java.net.SocketTimeoutException: Read timed out

Attachments (1)

mapillary.jpg (67.9 KB) - added by vasony <vasony.tamas@…> 9 months ago.

Download all attachments as: .zip

Change History (13)

Changed 9 months ago by vasony <vasony.tamas@…>

Attachment: mapillary.jpg added

comment:1 Changed 9 months ago by Klumbumbus

Description: modified (diff)
Keywords: hidpi added

comment:2 Changed 9 months ago by taylor.smock

Cc: taylor.smock added

This is probably due to a change I made to try and improve performance of the application when there are many images.

https://github.com/JOSM/Mapillary/blob/master/src/main/java/org/openstreetmap/josm/plugins/mapillary/gui/layer/MapillaryLayer.java#L104

I don't know how I can reproduce right now, since I don't currently have access to a Windows machine. I'll try to repro in Linux, but it isn't an issue on Mac.

comment:3 Changed 9 months ago by taylor.smock

Resolution: fixed
Status: newclosed

comment:4 Changed 9 months ago by Klumbumbus

Taylor, should we assign you as default owner of new tickets of mapillary plugin? Currently it is user cbeddow, but I don't find a single activity from this user here.

comment:5 Changed 9 months ago by taylor.smock

It is up to you.

Just as an FYI though, I may or may not have the time to work on Mapillary plugin bugs (or other JOSM bugs for that matter) in the near future, so it might be pointless.

For example, this was a fairly simple fix, but it took me ~2 weeks to actually fix it, largely due to other time constraints.

comment:6 in reply to:  5 Changed 9 months ago by stoecker

Replying to taylor.smock:

It is up to you.

Just as an FYI though, I may or may not have the time to work on Mapillary plugin bugs (or other JOSM bugs for that matter) in the near future, so it might be pointless.

For example, this was a fairly simple fix, but it took me ~2 weeks to actually fix it, largely due to other time constraints.

That situation applies to most (all?) of us. Question is only if you are willing to do fixes for mapillary. Alternative is "team" target which means "nobody feels responsible :-)"

comment:7 Changed 9 months ago by taylor.smock

I am willing to do fixes on the Mapillary plugin, so go for it. :)

comment:8 Changed 8 months ago by anonymous

Thanks for fixing this! When is the next release planned?

comment:9 Changed 8 months ago by taylor.smock

Hopefully soonish -- there is a GSOC student working on the plugin right now (most of the time I am currently spending on the plugin is reviewing his work, and testing it). There are a couple of other things I want to do to the plugin (for example, removing the dependency on JavaFX -- see #19591 where I am trying to see if there is interest in JOSM core for it. I may have to make it a subtree of the plugin to keep everything working if the options I'd prefer aren't currently possible).

comment:10 Changed 8 months ago by vasony.tamas@…

Sorry, but still not good with 1.5.24.

Identification: JOSM/1.5 (17013 en) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 1809 (17763)
Memory Usage: 569 MB / 2048 MB (97 MB allocated, but free)
Java version: 12.0.1-ojdkbuild+12, N/A, OpenJDK 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsClassicLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.25x1.25)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Plugins:
+ Mapillary (1.5.24)
+ apache-commons (35524)
+ apache-http (35092)
+ javafx-windows (35458)
+ jna (35092)
...

comment:11 Changed 7 months ago by vasony.tamas@…

Resolution: fixed
Status: closedreopened

comment:12 Changed 7 months ago by taylor.smock

Resolution: fixed
Status: reopenedclosed

GhostFoxSledgeHammer found the problem and fixed it ( see https://github.com/JOSM/Mapillary/pull/134 ).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain cbeddow.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.