Modify

Opened 11 days ago

Closed 11 days ago

Last modified 11 days ago

#19446 closed defect (fixed)

exception when trying to revert a changeset

Reported by: Andre68 Owned by: team
Priority: normal Milestone:
Component: Plugin reverter Version: latest
Keywords: template_report regression Cc:

Description

What steps will reproduce the problem?

  1. Click on Data->Revert changeset

What is the expected result?

The revert changeset dialog opens

What happens instead?

Exception

Please provide any additional information below. Attach a screenshot if possible.

Revision:16725
Is-Local-Build:true
Build-Date:2020-06-28 08:20:02

Identification: JOSM/1.5 (16725 SVN en) Linux Antergos Linux
Memory Usage: 501 MB / 3072 MB (210 MB allocated, but free)
Java version: 11.0.7+10, Oracle Corporation, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32

Plugins:
+ FixAddresses (35343)
+ ImproveWay (29)
+ OpeningHoursEditor (35414)
+ RoadSigns (35424)
+ SimplifyArea (35405)
+ alignways (35474)
+ apache-commons (35362)
+ apache-http (35092)
+ editgpx (35248)
+ imagery_offset_db (35405)
+ jna (35092)
+ log4j (35092)
+ measurement (35405)
+ merge-overlap (35248)
+ pbf (35446)
+ photo_geotagging (35405)
+ public_transport (35405)
+ reverter (35487)
+ routing (35405)
+ tageditor (35258)
+ turnlanes (35405)
+ turnlanes-tagging (283)
+ turnrestrictions (35405)
+ undelete (35474)
+ utilsplugin2 (35487)
+ waydownloader (35405)

Tagging presets:
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/DE.zip

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Enhanced_Lane_and_Road_Attributes&zip=1

Last errors/warnings:
- W: Not a single layer for the name 'Bing Sat': []
- W: Not a single layer for the name 'Bing Sat': []
- W: Not a single layer for the name 'Bing Sat': []
- E: Failed to locate image 'traffic_signs_presets/ES_tertiary.png'
- W:  Tertiary: Could not get presets icon traffic_signs_presets/ES_tertiary.png
- W: javax.imageio.IIOException: Caught exception during read:. Cause: java.lang.ArrayIndexOutOfBoundsException: Index 1 out of bounds for length 1
- E: Failed to locate image 'traffic_signs_presets/tunnel.png'
- W:  Tunnel: Could not get presets icon traffic_signs_presets/tunnel.png
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: Fatal: failed to locate image 'cancel.png'. This is a serious configuration problem. JOSM will stop working.
- W: Warning - <html>JOSM could not find information about the following plugins:<ul><li>ImproveWay</li><li>apache-commons</li><li>tageditor</li><li>RoadSigns</li><li>SimplifyArea</li><li>public_transport</li><li>FixAddresses</li><li>alignways</li><li>measurement</li><li>routing</li><li>editgpx</li><li>turnlanes-tagging</li><li>utilsplugin2</li><li>turnrestrictions</li><li>jna</li><li>log4j</li><li>imagery_offset_db</li><li>turnlanes</li><li>reverter</li><li>pbf</li><li>photo_geotagging</li><li>OpeningHoursEditor</li><li>undelete</li><li>waydownloader</li><li>apache-http</li><li>merge-overlap</li></ul>The plugins are not going to be loaded.</html>


=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
org.openstreetmap.josm.tools.JosmRuntimeException: Fatal: failed to locate image 'cancel.png'. This is a serious configuration problem. JOSM will stop working.
	at org.openstreetmap.josm.tools.ImageProvider.getResource(ImageProvider.java:706)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:666)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:812)
	at org.openstreetmap.josm.gui.ExtendedDialog.setButtonIcons(ExtendedDialog.java:187)
	at reverter.ChangesetIdQuery.setupDialog(ChangesetIdQuery.java:106)
	at org.openstreetmap.josm.gui.ExtendedDialog.showDialog(ExtendedDialog.java:247)
	at reverter.RevertChangesetAction.actionPerformed(RevertChangesetAction.java:27)
	at java.desktop/javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1967)
	at java.desktop/javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2308)
	at java.desktop/javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:405)
	at java.desktop/javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:262)
	at java.desktop/javax.swing.AbstractButton.doClick(AbstractButton.java:369)
	at java.desktop/javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1020)
	at java.desktop/javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1064)
	at java.desktop/java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:297)
	at java.desktop/java.awt.Component.processMouseEvent(Component.java:6631)
	at java.desktop/javax.swing.JComponent.processMouseEvent(JComponent.java:3342)
	at java.desktop/java.awt.Component.processEvent(Component.java:6396)
	at java.desktop/java.awt.Container.processEvent(Container.java:2263)
	at java.desktop/java.awt.Component.dispatchEventImpl(Component.java:5007)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2321)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4839)
	at java.desktop/java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4918)
	at java.desktop/java.awt.LightweightDispatcher.processMouseEvent(Container.java:4547)
	at java.desktop/java.awt.LightweightDispatcher.dispatchEvent(Container.java:4488)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2307)
	at java.desktop/java.awt.Window.dispatchEventImpl(Window.java:2772)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4839)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:772)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:95)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:745)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:743)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:742)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

Attachments (0)

Change History (8)

comment:1 Changed 11 days ago by skyper

Cannot reproduce! Is it a problem of your local build?

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-06-27 22:42:13 +0200 (Sat, 27 Jun 2020)
Revision:16725
Build-Date:2020-06-28 01:30:49
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (16725 en) Linux Debian GNU/Linux 10 (buster)
Java version: 11.0.7+10-post-Debian-3deb10u1, Debian, OpenJDK 64-Bit Server VM

Plugins:
+ reverter (35487)
Last edited 11 days ago by skyper (previous) (diff)

comment:2 Changed 11 days ago by skyper

Owner: changed from team to Andre68
Priority: majornormal
Status: newneedinfo

comment:3 Changed 11 days ago by Klumbumbus

Component: CorePlugin reverter
Keywords: regression added
Owner: changed from Andre68 to team
Status: needinfonew

It is a regression of r16719 and because reverter plugin included the file extension.

comment:4 Changed 11 days ago by Klumbumbus

Resolution: fixed
Status: newclosed

fixed in [o35496:35497]. Changing it to automatic file extension would even be better but I don't know how to do it.

comment:5 Changed 11 days ago by skyper

Why did it work in my case ? Same plugin version.

comment:6 Changed 11 days ago by Klumbumbus

I don't know. Maybe the reverter took the cancel.png from somewhere else on your PC, e.g. outdated svn.

(I had the exception too.)

comment:7 Changed 11 days ago by skyper

Strange, no svn only the .deb package from this site, just updated. I just rechecked. No line on the console output and I reverted a changeset.

comment:8 in reply to:  4 Changed 11 days ago by stoecker

Replying to Klumbumbus:

fixed in [o35496:35497]. Changing it to automatic file extension would even be better but I don't know how to do it.

Simply remove the extension completely.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.