Modify

Opened 4 months ago

Closed 6 days ago

#19429 closed defect (duplicate)

DataIntegrityProblemException: Deleted node referenced resolving some conflict

Reported by: Micheal Kaluba <micealkal@…> Owned by: Micheal Kaluba <micealkal@…>
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report DataIntegrityProblemException Deleted node referenced conflict Cc:

Description (last modified by skyper)

Hello i found a bug in Josm r16538 as i was resolving some conflict.

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-06-02 08:27:29 +0200 (Tue, 02 Jun 2020)
Build-Date:2020-06-02 11:11:35
Revision:16538
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16538 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1709 (16299)
Memory Usage: 247 MB / 247 MB (76 MB allocated, but free)
Java version: 1.8.0_251-b08, Oracle Corporation, Java HotSpot(TM) Client VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768

Dataset consistency test:
[DELETED REFERENCED] {Way id=377919976 version=1 MV nodes=[{Node id=-104531 version=0 MV lat=0.0274148579656954,lon=32.44714580409229}, {Node id=3813297868 version=2 MV lat=0.027431759508626398,lon=32.44696392944775}, {Node id=3813297869 version=2 MV lat=0.02735055950862848,lon=32.44695712944775}, {Node id=3813297870 version=2 MV lat=0.02733225950861464,lon=32.447175229447744}, {Node id=3813297867 version=2 MVD lat=0.027416259508641443,lon=32.447148529447745}]} refers to deleted primitive {Node id=3813297867 version=2 MVD lat=0.027416259508641443,lon=32.447148529447745}


Plugins:
+ buildings_tools (35474)
+ imagery_offset_db (35405)

Last errors/warnings:
- W: Unable to delete archived backup file <josm.pref>\autosave\deleted_layers\OSM Data_9_20200622_121910969.osm
- W: java.net.SocketTimeoutException: Read timed out
- E: Error header: Precondition failed: Node 3813297866 is still used by ways 377919976.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=412, Error Header=<Precondition failed: Node 3813297866 is still used by ways 377919976.>
- E: Object still in use - <html><strong>Failed</strong> to delete <strong>node 3813297866</strong>. It is still referred to by way 377919976.<br>Please load the way, remove the reference to the node, and upload again.<br><br>Click <strong>Prepare conflict resolution</strong> to load them now.<br>If necessary JOSM will create conflicts which you can resolve in the Conflict Resolution Dialog.</html>
- W: Warning - <html>The data to be uploaded participates in unresolved conflicts of layer 'OSM Data'.<br>You have to resolve them first.</html>
- E: Handled by bug report queue: java.lang.IllegalArgumentException: {Node id=3813297867 version=2 MVD lat=0.027416259508641443,lon=32.447148529447745} is already deleted
- E: Handled by bug report queue: java.lang.IllegalArgumentException: {Node id=3813297867 version=2 MVD lat=0.027416259508641443,lon=32.447148529447745} is already deleted
- E: Handled by bug report queue: java.lang.IllegalArgumentException: {Node id=3813297867 version=2 MVD lat=0.027416259508641443,lon=32.447148529447745} is already deleted
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted node referenced: {Way id=377919976 version=1 MV nodes=[{Node id=-104531 version=0 MV lat=0.0274148579656954,lon=32.44714580409229}, {Node id=3813297868 version=2 MV lat=0.027431759508626398,lon=32.44696392944775}, {Node id=3813297869 version=2 MV lat=0.02735055950862848,lon=32.44695712944775}, {Node id=3813297870 version=2 MV lat=0.02733225950861464,lon=32.447175229447744}, {Node id=3813297867 version=2 MVD lat=0.027416259508641443,lon=32.447148529447745}]}


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (16) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted node referenced: {Way id=377919976 version=1 MV nodes=[{Node id=-104531 version=0 MV lat=0.0274148579656954,lon=32.44714580409229}, {Node id=3813297868 version=2 MV lat=0.027431759508626398,lon=32.44696392944775}, {Node id=3813297869 version=2 MV lat=0.02735055950862848,lon=32.44695712944775}, {Node id=3813297870 version=2 MV lat=0.02733225950861464,lon=32.447175229447744}, {Node id=3813297867 version=2 MVD lat=0.027416259508641443,lon=32.447148529447745}]}
	at org.openstreetmap.josm.data.osm.Way.checkNodes(Way.java:537)
	at org.openstreetmap.josm.data.osm.Way.fireNodesChanged(Way.java:553)
	at org.openstreetmap.josm.data.osm.Way.setNodes(Way.java:66)
	at org.openstreetmap.josm.data.osm.Way.cloneFrom(Way.java:302)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.cloneFrom(OsmPrimitive.java:864)
	at org.openstreetmap.josm.command.ChangeCommand.executeCommand(ChangeCommand.java:67)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:79)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:299)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:353)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.mouseReleased(DrawAction.java:656)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 4 months ago by skyper

Description: modified (diff)
Summary: Hello i found a bug in Josm 16538 as i was resolving some conflictDataIntegrityProblemException: Deleted node referenced resolving some conflict
Version: tested

How did you get/create the conflicts?
What data sources did you use?
Is it reproducible?

comment:2 Changed 4 months ago by skyper

Keywords: DataIntegrityProblemException Deleted node referenced conflict added
Owner: changed from team to Micheal Kaluba <micealkal@…>
Status: newneedinfo

comment:3 Changed 6 days ago by GerdP

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #19438.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Micheal Kaluba <micealkal@…>.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.