Modify

Opened 10 years ago

Closed 10 years ago

#1942 closed defect (worksforme)

Uploading data with 0.6 results in NPE

Reported by: stoecker Owned by: stoecker
Priority: major Milestone:
Component: Core Version:
Keywords: Cc: Gubaer

Description

Manifest-Version: 1.0
Ant-Version: Apache Ant 1.7.0
Created-By: 11.0-b15 (Sun Microsystems Inc.)
Main-class: JOSM
Main-Version: 1196 SVN
Main-Date: 2008-12-31T11:35:50.511750Z

java.lang.RuntimeException: Unexpected end of file from server java.net.SocketException

at org.openstreetmap.josm.io.OsmServerWriter.stopChangeset(OsmServerWriter.java:453)
at org.openstreetmap.josm.io.OsmServerWriter.uploadOsm(OsmServerWriter.java:155)
at org.openstreetmap.josm.actions.UploadAction$2.realRun(UploadAction.java:152)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:84)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:619)

Caused by: java.net.SocketException: Unexpected end of file from server

at sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:769)
at sun.net.www.http.HttpClient.parseHTTP(HttpClient.java:632)
at sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:766)
at sun.net.www.http.HttpClient.parseHTTP(HttpClient.java:632)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1049)
at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:373)
at org.openstreetmap.josm.io.OsmServerWriter.stopChangeset(OsmServerWriter.java:402)
... 6 more

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by Gubaer

Cc: Gubaer added
Owner: changed from framm to stoecker
Status: newneedinfo

This is quite old and it doesn't seem to be a major issue today.

Can we close it?

comment:2 Changed 10 years ago by anonymous

Resolution: worksforme
Status: needinfoclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain stoecker.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.