Modify

Opened 3 weeks ago

Closed 2 weeks ago

Last modified 2 weeks ago

#19380 closed defect (fixed)

Unclear "Role verification problem - Role 'route' is not in templates '///guidepost' (1)"

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 20.06
Component: Core validator Version:
Keywords: template_report relation role verification Cc:

Description (last modified by mkoniecz)

What steps will reproduce the problem?

  1. load https://www.openstreetmap.org/way/30730185
  2. run validator

What is the expected result?

I get legible warning if any

What happens instead?

Role verification problem - Role 'route' is not in templates '///guidepost' (1)

Is it complaining about "route" role? Maybe it should be empty? But why it mentions guidepost? https://www.openstreetmap.org/relation/2033747 has nothing guidepost related that I see.

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-06-12 19:48:35 +0200 (Fri, 12 Jun 2020)
Revision:16610
Build-Date:2020-06-13 01:30:48
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (16610 en_GB) Linux Ubuntu 19.10
Memory Usage: 800 MB / 976 MB (212 MB allocated, but free)
Java version: 11.0.7+10-post-Ubuntu-2ubuntu219.10, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Java package: openjdk-11-jre:amd64-11.0.7+10-2ubuntu2~19.10
Java ATK Wrapper package: libatk-wrapper-java:all-0.35.0-3
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:-
Dataset consistency test: No problems found

Plugins:
+ buildings_tools (35474)
+ measurement (35405)
+ reverter (35487)

Last errors/warnings:
- W: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server
- W: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server
- W: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server
- W: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server
- W: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server
- W: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server
- W: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server
- W: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server
- W: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server
- W: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server

Attachments (1)

19380.PNG (24.9 KB) - added by Klumbumbus 3 weeks ago.

Download all attachments as: .zip

Change History (21)

comment:1 Changed 3 weeks ago by mkoniecz

Description: modified (diff)

comment:2 Changed 3 weeks ago by mkoniecz

Description: modified (diff)

comment:3 Changed 3 weeks ago by mkoniecz

Description: modified (diff)

comment:4 Changed 3 weeks ago by GerdP

I cannot reproduce this. I see not a single warning for the area around the way. I see that you changed both the way and the relation. Did that fix the problem?

Changed 3 weeks ago by Klumbumbus

Attachment: 19380.PNG added

comment:5 in reply to:  description Changed 3 weeks ago by Klumbumbus

Replying to mkoniecz:

Is it complaining about "route" role?

Yes.

Maybe it should be empty?

Yes.

But why it mentions guidepost? https://www.openstreetmap.org/relation/2033747 has nothing guidepost related that I see.

Because it lists all possible roles defined in the preset of the hiking route, separated by slash:


comment:6 Changed 3 weeks ago by mkoniecz

I tried with https://www.openstreetmap.org/way/30730185

You need to download data around this way and unselect it.

It is possible that I partially destroyed test case as I was editing route at this location (as one of trails got destroyed and blocked by apiary placed to obstruct passage)

comment:7 Changed 3 weeks ago by mkoniecz

would it be possible to replace

Role 'route' is not in templates '///guidepost'

by

Role 'route' is not among expected values: "" (empty role) / "guidepost"

or

Role 'route' is not among expected values '///guidepost'

The "templates" is, at least for me, not clear at all (I never used this UI window and I have no idea how to trigger it - despite editing fair bit of signed route relations).

Last edited 3 weeks ago by mkoniecz (previous) (diff)

comment:8 Changed 3 weeks ago by simon04

Resolution: fixed
Status: newclosed

In 16616/josm:

fix #19380 - RelationChecker: improve validation message "Role verification problem - Role 'route' is not among expected values '<empty>/guidepost'"

comment:9 Changed 3 weeks ago by simon04

Milestone: 20.06

comment:10 Changed 3 weeks ago by mkoniecz

<empty> is even better, thanks!

And again thanks for a quick fix - JOSM is the largest project known to me where user can report such deficiency/missing feature and it is actually likely that it will be fixed.

comment:11 Changed 3 weeks ago by simon04

You're welcome, thanks for your kind words :)

comment:12 Changed 3 weeks ago by skyper

Is it possible to split this test into three, one per object type, to get shorter messages and to only offer the correct roles for the object type.

comment:13 Changed 3 weeks ago by simon04

Keywords: relation role verification added

Replying to skyper:

Is it possible to split this test into three, one per object type, to get shorter messages and to only offer the correct roles for the object type.

Is this making things clearer? I'm not convinced. To be precise/correct, the message would need to be changed to "Role R is not among expected values Rs for type T". For incorrect types, there's the separate test "Type T of relation member with role R does not match accepted types Ts in preset P".

Last edited 3 weeks ago by simon04 (previous) (diff)

comment:14 Changed 3 weeks ago by mkoniecz

"Is this making things clearer?"

For me? Yes?

Role 'route' is not in templates '///guidepost' is completely unclear and looks like output of a crashed program.

Role 'route' is not among expected values '<empty>/guidepost' is clear to me.

comment:15 in reply to:  14 Changed 3 weeks ago by simon04

Replying to mkoniecz:

For me? Yes?

I was relating to skyper's suggestion to filter by object type from comment:12.

comment:16 in reply to:  13 Changed 3 weeks ago by skyper

Replying to simon04:

Replying to skyper:

Is it possible to split this test into three, one per object type, to get shorter messages and to only offer the correct roles for the object type.

Is this making things clearer? I'm not convinced. To be precise/correct, the message would need to be changed to "Role R is not among expected values Rs for type T". For incorrect types, there's the separate test "Type T of relation member with role R does not match accepted types Ts in preset P".

You are right, let's keep it as it is.

comment:17 Changed 2 weeks ago by skyper

Resolution: fixed
Status: closedreopened

I get warnings about backward/forward in a PTv1 relation with only incomplete members:

  1. Download object r5563137 without children
  2. Run validator
Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-06-15 21:37:22 +0200 (Mon, 15 Jun 2020)
Revision:16649
Build-Date:2020-06-16 01:30:48
URL:https://josm.openstreetmap.de/svn/trunk

comment:18 in reply to:  17 ; Changed 2 weeks ago by simon04

Replying to skyper:

I get warnings about backward/forward in a PTv1 relation with only incomplete members:

  1. Download object r5563137 without children

This relation specifies public_transport:version=2 and is therefore validated as PTv2 relation.

comment:19 Changed 2 weeks ago by Klumbumbus

Resolution: fixed
Status: reopenedclosed

Also it would not really be related to this ticket.

comment:20 in reply to:  18 Changed 2 weeks ago by skyper

Replying to simon04:

Replying to skyper:

I get warnings about backward/forward in a PTv1 relation with only incomplete members:

  1. Download object r5563137 without children

This relation specifies public_transport:version=2 and is therefore validated as PTv2 relation.

Damn, what I mistake I made. Thanks for notifying.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.