Modify

Opened 5 months ago

Closed 13 days ago

#19352 closed enhancement (wontfix)

Unglue ways: Remaining node with tags moved

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report unglue Cc: GerdP

Description (last modified by skyper)

What steps will reproduce the problem?

  1. Have an unconnected way with two node with one node with tags
  2. Select the end node with tags
  3. Unglue ways

What is the expected result?

The way is unglued and a new node is added at the same position as the selected node. The selected node remains unchanged.

What happens instead?

Unglue works but the selected node is moved similar to "extract node" from utilsplugin2

Please provide any additional information below. Attach a screenshot if possible.

Seems to be a regression of the better handling of tags and memberships.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-06-03 21:59:58 +0200 (Wed, 03 Jun 2020)
Revision:16540
Build-Date:2020-06-04 01:30:48
URL:https://josm.openstreetmap.de/svn/trunk

Attachments (0)

Change History (14)

comment:1 Changed 5 months ago by skyper

It does also happen with middle nodes and is a regression of r16300. Before unglueing a node with only one parent was not possible.

comment:2 Changed 5 months ago by GerdP

I just tried r16102 and the node is unglued. What exactly is the regression?

comment:3 Changed 5 months ago by skyper

The position of the node with positive id is moved but it should not. Before, you needed "Disconnect Node from Way" which only changes the way but keeps the node untouched.

comment:4 Changed 5 months ago by GerdP

So, you suggest that the new node is moved instead? That would change the geometry of the way. I am sure this did not happen before. Or should both nodes be at the same place no matter where the cursor is?

comment:5 in reply to:  4 Changed 5 months ago by skyper

Replying to GerdP:

So, you suggest that the new node is moved instead? That would change the geometry of the way. I am sure this did not happen before. Or should both nodes be at the same place no matter where the cursor is?

Before, you got a notification and unglueing was denied, which is the same behavior as with nodes without membership nor tag. Now, to be consistent, I would say, both nodes should be at the same place, all the time.

comment:6 Changed 5 months ago by GerdP

What version do you mean with before? Are we both talking about the action with shortcut G?

comment:7 Changed 5 months ago by skyper

Description: modified (diff)
Keywords: regression removed

I am completely sorry. I can swore that I had a notification, The node is not glued to anything else, with a tagged node with r16294 but now I cannot reproduce it. Maybe, it is time for some glasses or new hardware.

comment:8 Changed 5 months ago by skyper

Type: defectenhancement

comment:9 Changed 5 months ago by GerdP

OK, so we are only discussing wether or not the node should be moved. See also r16362.
My understanding was that one wants to unglue the tagged node because it was never meant to be at the position where it is, e.g. because it snapped to the way. If you don't want to change the position of the node Alt+J (Disconnect Node from Way) could be an alternative.

comment:10 Changed 5 months ago by skyper

I know and use "Disconnect Node from Way" but what is the difference between "Unglue" and "Extract nodes" Alt+Shift+J from utilsplugin2?

comment:11 Changed 5 months ago by GerdP

Looking at the code I's say: Extract nodes creates a single new node and replaces the first occurence of the selected node with this new node in every refering way. Unglue may create multiple new nodes. When the node is only referrenced by one way there seems to be no difference.

comment:12 Changed 5 months ago by skyper

So, I would suggest to be consistent and let "Extract nodes" move the node and have unglue keep the position but as it is no regression I do not want to upset users in changing the behavior, so maybe, this is even a wontfix.

comment:13 Changed 5 months ago by GerdP

I prefer wontfix.

comment:14 Changed 13 days ago by skyper

Resolution: wontfix
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.