Modify

Opened 5 months ago

Closed 10 days ago

#19332 closed defect (duplicate)

DataIntegrityProblemException: Deleted node referenced

Reported by: alt.people.davidcalman@… Owned by: alt.people.davidcalman@…
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Deleted node referenced Cc:

Description

What steps will reproduce the problem?

  1. dunno

What is the expected result?

Don't crash when closing a lake

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-04-06 02:17:07 +0200 (Mon, 06 Apr 2020)
Build-Date:2020-04-06 00:18:43
Revision:16239
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16239 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1909 (18363)
Memory Usage: 289 MB / 1820 MB (94 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1680x1050
Maximum Screen Size: 1680x1050

Dataset consistency test:
[DELETED REFERENCED] {Way id=15348876 version=2 MVT nodes=[{Node id=-103317 version=0 MV lat=-7.181111326857452,lon=172.98852008981254}, {Node id=148582667 version=1 V lat=-7.1851727,lon=172.9890806}, {Node id=148582668 version=1 V lat=-7.1890461,lon=172.9905937}, {Node id=148582669 version=1 V lat=-7.1933273,lon=172.9862226}, {Node id=148582670 version=1 V lat=-7.1954215,lon=172.9842799}, {Node id=148582671 version=1 V lat=-7.1969041,lon=172.9827855}, {Node id=148582673 version=1 V lat=-7.1895651,lon=172.9836074}, {Node id=148582674 version=1 V lat=-7.1838012,lon=172.9850084}, {Node id=-103317 version=0 MV lat=-7.181111326857452,lon=172.98852008981254}, {Node id=148582675 version=1 V lat=-7.1810397,lon=172.9886136}, {Node id=148582666 version=1 MVD lat=-7.1811656,lon=172.9886987}]} refers to deleted primitive {Node id=148582666 version=1 MVD lat=-7.1811656,lon=172.9886987}


Plugins:
+ Create_grid_of_ways (35405)
+ FastDraw (35405)
+ OpeningHoursEditor (35414)
+ PicLayer (35405)
+ buildings_tools (35405)
+ gridify (1588746833)
+ imagery_offset_db (35405)
+ measurement (35405)
+ rex (53)
+ splinex (35454)
+ terracer (35327)
+ turnrestrictions (35405)
+ utilsplugin2 (35440)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/TurnLanes&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/iD&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1

Last errors/warnings:
- W: Region [TMS_BLOCK_v2]  Problem verifying disk.
- W: Conflicts detected - <html>There were 2 conflicts detected.</html>
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<The maximum bbox size is 0.25, and your request was too large. Either request a smaller area, or use planet.osm>
- E: Bad Request - <html>The OSM server 'opengeofiction.net' reported a bad request.<br><br>The area you tried to download is too big or your request was too large.<br>Either request a smaller area or use an export file provided by the OSM community.</html>
- W: Conflicts detected - <html>There was 1 conflict detected.</html>
- W: Conflicts detected - <html>There was 1 conflict detected.</html>
- E: Error header: Precondition failed: Node 148582666 is still used by ways 15348876,15348876.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=412, Error Header=<Precondition failed: Node 148582666 is still used by ways 15348876,15348876.>
- E: Object still in use - <html><strong>Failed</strong> to delete <strong>node 148582666</strong>. It is still referred to by way 15348876.<br>Please load the way, remove the reference to the node, and upload again.<br><br>Click <strong>Prepare conflict resolution</strong> to load them now.<br>If necessary JOSM will create conflicts which you can resolve in the Conflict Resolution Dialog.</html>
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted node referenced: {Way id=15348876 version=2 MVT nodes=[{Node id=-103317 version=0 MV lat=-7.181111326857452,lon=172.98852008981254}, {Node id=148582667 version=1 V lat=-7.1851727,lon=172.9890806}, {Node id=148582668 version=1 V lat=-7.1890461,lon=172.9905937}, {Node id=148582669 version=1 V lat=-7.1933273,lon=172.9862226}, {Node id=148582670 version=1 V lat=-7.1954215,lon=172.9842799}, {Node id=148582671 version=1 V lat=-7.1969041,lon=172.9827855}, {Node id=148582673 version=1 V lat=-7.1895651,lon=172.9836074}, {Node id=148582674 version=1 V lat=-7.1838012,lon=172.9850084}, {Node id=-103317 version=0 MV lat=-7.181111326857452,lon=172.98852008981254}, {Node id=148582675 version=1 V lat=-7.1810397,lon=172.9886136}, {Node id=148582666 version=1 MVD lat=-7.1811656,lon=172.9886987}]}

OSM API: https://opengeofiction.net/api


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted node referenced: {Way id=15348876 version=2 MVT nodes=[{Node id=-103317 version=0 MV lat=-7.181111326857452,lon=172.98852008981254}, {Node id=148582667 version=1 V lat=-7.1851727,lon=172.9890806}, {Node id=148582668 version=1 V lat=-7.1890461,lon=172.9905937}, {Node id=148582669 version=1 V lat=-7.1933273,lon=172.9862226}, {Node id=148582670 version=1 V lat=-7.1954215,lon=172.9842799}, {Node id=148582671 version=1 V lat=-7.1969041,lon=172.9827855}, {Node id=148582673 version=1 V lat=-7.1895651,lon=172.9836074}, {Node id=148582674 version=1 V lat=-7.1838012,lon=172.9850084}, {Node id=-103317 version=0 MV lat=-7.181111326857452,lon=172.98852008981254}, {Node id=148582675 version=1 V lat=-7.1810397,lon=172.9886136}, {Node id=148582666 version=1 MVD lat=-7.1811656,lon=172.9886987}]}
	at org.openstreetmap.josm.data.osm.Way.checkNodes(Way.java:551)
	at org.openstreetmap.josm.data.osm.Way.fireNodesChanged(Way.java:567)
	at org.openstreetmap.josm.data.osm.Way.setNodes(Way.java:65)
	at org.openstreetmap.josm.data.osm.Way.cloneFrom(Way.java:307)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.cloneFrom(OsmPrimitive.java:886)
	at org.openstreetmap.josm.command.ChangeCommand.executeCommand(ChangeCommand.java:67)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:79)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:300)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:354)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.mouseReleased(DrawAction.java:661)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 5 months ago by skyper

Keywords: Deleted node referenced added
Owner: changed from team to alt.people.davidcalman@…
Status: newneedinfo
Summary: crash when closing a way with an area tagDataIntegrityProblemException: Deleted node referenced
Version: tested

We need more info:

  • What data sources did you use?
  • How did you get the data inconsistency?
  • There were conflicts detected. Did you solve them or was there a conflict remaining on the way you tried to close?
  • A step by step description would be useful.

Thanks

comment:2 Changed 10 days ago by GerdP

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #19438.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain alt.people.davidcalman@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.