Modify

Opened 2 weeks ago

Closed 3 days ago

Last modified 3 days ago

#19283 closed defect (fixed)

NoClassDefFoundError: org/apache/commons/jcs/engine/behavior/ICompositeCacheAttributes

Reported by: Glassman Owned by: jBeata
Priority: normal Milestone:
Component: Plugin openstreetcam Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Download an area
  2. Attempt to view a openstreetcam image

What is the expected result?

Image shows in viewer window

What happens instead?

Error message to disable plugin

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-05-21 00:29:30 +0200 (Thu, 21 May 2020)
Build-Date:2020-05-21 01:30:46
Revision:16472
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16472 en) Linux Fedora release 32 (Thirty Two)
Memory Usage: 6791 MB / 7282 MB (6232 MB allocated, but free)
Java version: 1.8.0_252-b09, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 3840x1080, :0.1 1920x1080
Maximum Screen Size: 3840x1080
Java package: java-1.8.0-openjdk:x86_64-1.8.0.252.b09
VM arguments: [-Djosm.home=<josm.pref>]
Dataset consistency test: No problems found

Plugins:
+ EasyPresets (1583691763)
+ ImportImagePlugin (35248)
+ OpenStreetCam (312)
+ OpeningHoursEditor (35414)
+ apache-commons (35362)
+ apache-http (35092)
+ auto_tools (73)
+ buildings_tools (35405)
+ ejml (35313)
+ geochat (35405)
+ geotools (35169)
+ javafx-unixoid (35375)
+ jaxb (35092)
+ jna (35092)
+ jts (35122)
+ log4j (35092)
+ measurement (35405)
+ opendata (35405)
+ osm-obj-info (56)
+ pt_assistant (2.1.10-79-gb14a159)
+ reltoolbox (35405)
+ reverter (35409)
+ tageditor (35258)
+ todo (30306)
+ turnlanes-tagging (283)
+ turnrestrictions (35405)
+ utilsplugin2 (35468)
+ wikipedia (1.1.4)

Tagging presets:
+ https://raw.githubusercontent.com/osmlab/name-suggestion-index/master/dist/name-suggestions.presets.xml
+ ${HOME}/Downloads/MikeN_Presets.zip
+ ${HOME}/Development/josm_sidewalk_presets/sidewalk_preset.xml

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1
+ ${HOME}/foo.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Kerbs&zip=1
- https://raw.githubusercontent.com/OpenSidewalks/OpenSidewalks-Schema/master/open_sidewalks.mapcss
+ ${HOME}/OSM/open_sidewalks2.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1

Last errors/warnings:
- E: Skipping to the next rule, because of an error:
- E: org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Encountered " <UINT> "5 "" at line 17, column 8.
- W: Initializing map style ${HOME}/OSM/open_sidewalks2.mapcss completed in 7 ms (1 errors, 0 warnings)
- E: Region [TMS_BLOCK_v2] : Problem loading keys for file TMS_BLOCK_v2
- W: javax.imageio.IIOException: Inconsistent metadata read from stream
- W: javax.imageio.IIOException: Inconsistent metadata read from stream
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: org/apache/commons/jcs/engine/behavior/ICompositeCacheAttributes. Cause: java.lang.ClassNotFoundException: org.apache.commons.jcs.engine.behavior.ICompositeCacheAttributes
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: Could not initialize class org.openstreetmap.josm.plugins.openstreetcam.handler.PhotoHandler


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: pool-2-thread-2 (171)
java.lang.NoClassDefFoundError: org/apache/commons/jcs/engine/behavior/ICompositeCacheAttributes
	at org.openstreetmap.josm.plugins.openstreetcam.handler.PhotoHandler.<init>(PhotoHandler.java:36)
	at org.openstreetmap.josm.plugins.openstreetcam.handler.PhotoHandler.<clinit>(PhotoHandler.java:37)
	at org.openstreetmap.josm.plugins.openstreetcam.gui.details.photo.PhotoDetailsDialog.loadPhoto(PhotoDetailsDialog.java:190)
	at org.openstreetmap.josm.plugins.openstreetcam.gui.details.photo.PhotoDetailsDialog.lambda$updateUI$0(PhotoDetailsDialog.java:176)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.ClassNotFoundException: org.apache.commons.jcs.engine.behavior.ICompositeCacheAttributes
	at java.net.URLClassLoader.findClass(URLClassLoader.java:382)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:418)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:73)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:351)
	... 7 more

Attachments (0)

Change History (6)

comment:1 Changed 2 weeks ago by Klumbumbus

Component: CorePlugin openstreetcam
Owner: changed from team to jBeata

comment:2 Changed 2 weeks ago by Klumbumbus

Summary: OpenStreetCam Plugin causes errorNoClassDefFoundError: org/apache/commons/jcs/engine/behavior/ICompositeCacheAttributes

comment:3 Changed 13 days ago by skyper

Plugin needs to be adapted, see #19208.

comment:5 Changed 3 days ago by jBeata

Resolution: fixed
Status: newclosed

Fixed in build 317.

comment:6 Changed 3 days ago by simon04

Thank you!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jBeata.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.