Modify

Opened 2 weeks ago

Closed 2 weeks ago

#19266 closed defect (duplicate)

JOSM fails to save a new relation

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-04-06 02:17:07 +0200 (Mon, 06 Apr 2020)
Build-Date:2020-04-06 00:18:43
Revision:16239
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16239 de) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 1909 (18363)
Memory Usage: 323 MB / 989 MB (121 MB allocated, but free)
Java version: 1.8.0_211-b12, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ imagery_offset_db (35405)
+ turnrestrictions (35405)

Last errors/warnings:
- W: java.net.SocketTimeoutException: Read timed out
- E: java.net.SocketTimeoutException: Read timed out
- E: org.openstreetmap.josm.io.OsmTransferException: Verbindung zum OSM-Server fehlgeschlagen. Bitte überprüfen Sie Ihre Internetverbindung.. Ursache: java.net.SocketTimeoutException: Read timed out
- E: Ein-/Ausgabefehler - <html>Datenübertragungsfehler zum Server<br>"https://api.openstreetmap.org/api/0.6/map?bbox=7.5915527,47.8601672,7.6725769,47.9002325"<br>beim Hoch- oder Herunterladen.<br>Details: Read timed out</html>
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Parameter 'data' must not be null
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Parameter 'data' must not be null
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Parameter 'data' must not be null
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Parameter 'data' must not be null
- W: Ungespeicherte Änderungen - <html>Die Relation wurde geändert.<br><br>Wollen Sie die Änderungen speichern?</html>
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Parameter 'data' must not be null


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (15) of main
java.lang.IllegalArgumentException: Parameter 'data' must not be null
	at org.openstreetmap.josm.tools.CheckParameterUtil.ensureParameterNotNull(CheckParameterUtil.java:26)
	at org.openstreetmap.josm.command.Command.<init>(Command.java:138)
	at org.openstreetmap.josm.command.ChangeCommand.<init>(ChangeCommand.java:49)
	at org.openstreetmap.josm.command.ChangeCommand.<init>(ChangeCommand.java:37)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.SavingAction.applyExistingNonConflictingRelation(SavingAction.java:104)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.SavingAction.applyChanges(SavingAction.java:177)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.CancelAction.actionPerformed(CancelAction.java:53)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor.cancel(GenericRelationEditor.java:356)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor$2.windowClosing(GenericRelationEditor.java:277)
	at java.awt.AWTEventMulticaster.windowClosing(Unknown Source)
	at java.awt.AWTEventMulticaster.windowClosing(Unknown Source)
	at java.awt.AWTEventMulticaster.windowClosing(Unknown Source)
	at java.awt.Window.processWindowEvent(Unknown Source)
	at javax.swing.JDialog.processWindowEvent(Unknown Source)
	at java.awt.Window.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 2 weeks ago by skyper

Duplicate of #18771?

comment:2 Changed 2 weeks ago by GerdP

Yes, looks similar. Unfortunately there is no hint how to reproduce the problem.

comment:3 Changed 2 weeks ago by GerdP

Resolution: duplicate
Status: newclosed

Closed as duplicate of #18771.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.