Modify

Opened 4 weeks ago

Closed 2 weeks ago

#19191 closed defect (fixed)

Mapillary Layer not loading

Reported by: danielle.fleig@… Owned by: taylor.smock
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Went to download Mapillary layer
  2. was told to update
  3. Updated Mapillary and it returned bug error message.

What is the expected result?

Load mapillary layer

What happens instead?

Bug prompt. Mapillary layer shows in "layers" does not load tracks

Please provide any additional information below. Attach a screenshot if possible

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-04-06 02:17:07 +0200 (Mon, 06 Apr 2020)
Build-Date:2020-04-06 00:18:43
Revision:16239
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16239 en) Mac OS X 10.15.3
OS Build number: Mac OS X 10.15.3 (19D76)
Memory Usage: 1028 MB / 1820 MB (348 MB allocated, but free)
Java version: 1.8.0_251-b08, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 69935512 2048x1152, Display 188916758 1920x1080
Maximum Screen Size: 2048x1152
VM arguments: [-Djnlp.application.href=https://josm.openstreetmap.de/download/josm.jnlp, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlp.tk=awt, -Djnlpx.jvm=<java.home>/bin/java, -Djnlpx.splashport=-1, -Djnlpx.home=<java.home>/bin, -Djnlpx.remove=false, -Djnlpx.offline=false, -Djnlpx.relaunch=true, -Djnlpx.session.data=/var/folders/7s/631t3xzs7t7crf6xg19kxc_00000gn/T/session1751832670821725373, -Djnlpx.heapsize=-1,2147483648, -Djava.security.policy=file:<java.home>/lib/security/javaws.policy, -DtrustProxy=true, -Djnlpx.origFilenameArg=${HOME}/Library/Application Support/Oracle/Java/Deployment/cache/6.0/56/1ee8cfb8-185700ed, -Dsun.awt.warmup=true, -Djava.security.manager]
Dataset consistency test: No problems found

Plugins:
+ EasyPresets (1583691763)
+ FastDraw (35405)
+ Mapillary (1.5.22)
+ OpenStreetCam (307)
+ apache-commons (35362)
+ apache-http (35092)
+ auto_tools (73)
+ buildings_tools (35405)
+ conflation (0.6.4)
+ editgpx (35248)
+ graphview (35405)
+ gridify (1577091848)
+ highwayNameModification (0.0.9)
+ imagery_offset_db (35405)
+ intersection (0.0.7)
+ javafx-osx (35375)
+ jaxb (35092)
+ jna (35092)
+ jts (35122)
+ log4j (35092)
+ markseen (14)
+ osm-obj-info (56)
+ reverter (35409)
+ rex (53)
+ tageditor (35258)
+ turnlanes-tagging (283)
+ turnrestrictions (35405)
+ utilsplugin2 (35405)

Tagging presets:
+ https://raw.githubusercontent.com/osmlab/name-suggestion-index/master/dist/name-suggestions.presets.xml

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ https://raw.githubusercontent.com/KaartGroup/Kaart-Styles/master/Kaart-Styles.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://raw.githubusercontent.com/KaartGroup/Kaart-Styles/master/Kaart_QC.mapcss
- https://raw.githubusercontent.com/KaartGroup/Kaart-Styles/master/Overlapping%20Ways.mapcss

Validator rules:
+ https://raw.githubusercontent.com/KaartGroup/KaartValidator/master/kaart.clingstone.validator.mapcss
- https://raw.githubusercontent.com/KaartGroup/KaartValidator/master/kaart.dwarf.validator.mapcss
+ /Applications/JOSM-Buddy/assets/validators/forbidden-tag-check.validator.mapcss

Last errors/warnings:
- W: Unsupported throwwarning instruction. Allowed instructions are throwError/throwWarning/throwOther.: (no error)
- E: Cannot add MapCss rule: No throwError/throwWarning/throwOther given! You should specify a validation error message for [way[highway][turn:lanes:backward][lanes:backward][ParameterFunction~not_equal(class java.lang.Object ParameterFunction~count(interface java.util.List ParameterFunction~split(class java.lang.String <|>,class java.lang.String org.openstreetmap.josm.gui.mappaint.mapcss.ExpressionFactory$NullExpression@6c0baf75)),class java.lang.Object org.openstreetmap.josm.gui.mappaint.mapcss.ExpressionFactory$NullExpression@6c0baf75)][org.openstreetmap.josm.gui.mappaint.mapcss.ExpressionFactory$OrOperator@2c9ece38], way[highway][turn:lanes:backward][!lanes:backward][ParameterFunction~not_equal(class java.lang.Object ParameterFunction~count(interface java.util.List ParameterFunction~split(class java.lang.String <|>,class java.lang.String org.openstreetmap.josm.gui.mappaint.mapcss.ExpressionFactory$NullExpression@6c0baf75)),class java.lang.Object ArrayFunction~divided_by(float org.openstreetmap.josm.gui.mappaint.mapcss.ExpressionFactory$NullExpression@6c0baf75,float <2.0>))][org.openstreetmap.josm.gui.mappaint.mapcss.ExpressionFactory$OrOperator@2d4e26b9], way[highway][turn:lanes:backward][!lanes][!lanes:backward][org.openstreetmap.josm.gui.mappaint.mapcss.ExpressionFactory$OrOperator@1c04520d]]
- W: javax.imageio.IIOException: Inconsistent metadata read from stream
- W: javax.imageio.IIOException: Inconsistent metadata read from stream
- E: https://a.mapillary.com/v3/organizations/O0K377md1CVrVkzGu4PV5z?client_id=UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm
- W: Region [userProfile_BLOCK_v2]  Problem verifying disk.
- E: java.io.IOException: stream is closed
- W: Error when downloading user profile for user key 'l9wyotK_xALSJlSJCR20vA'!: java.io.IOException: Server returned HTTP response code: 500 for URL: https://a.mapillary.com/v3/users/l9wyotK_xALSJlSJCR20vA?client_id=UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: org.openstreetmap.josm.tools.JosmRuntimeException: Fatal: failed to locate image '<josm.cache>/mirror_https___a.mapillary.com_v3_organizations_O0K377md1CVrVkzGu4PV5z_avatar_client_id_UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm'. This is a serious configuration problem. JOSM will stop working.. Cause: org.openstreetmap.josm.tools.JosmRuntimeException: Fatal: failed to locate image '<josm.cache>/mirror_https___a.mapillary.com_v3_organizations_O0K377md1CVrVkzGu4PV5z_avatar_client_id_UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm'. This is a serious configuration problem. JOSM will stop working.
- W: Warning - <html>JOSM could not find information about the following plugins:<ul><li>apache-commons</li><li>conflation</li><li>tageditor</li><li>OpenStreetCam</li><li>jaxb</li><li>editgpx</li><li>turnlanes-tagging</li><li>utilsplugin2</li><li>EasyPresets</li><li>gridify</li><li>intersection</li><li>turnrestrictions</li><li>jna</li><li>log4j</li><li>auto_tools</li><li>imagery_offset_db</li><li>rex</li><li>javafx-osx</li><li>jts</li><li>Mapillary</li><li>graphview</li><li>osm-obj-info</li><li>reverter</li><li>FastDraw</li><li>highwayNameModification</li><li>markseen</li><li>buildings_tools</li><li>apache-http</li></ul>The plugins are not going to be loaded.</html>


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: pool-7-thread-1 (139)
org.openstreetmap.josm.tools.JosmRuntimeException: org.openstreetmap.josm.tools.JosmRuntimeException: Fatal: failed to locate image '/Users/imac63/Library/Caches/JOSM/mirror_https___a.mapillary.com_v3_organizations_O0K377md1CVrVkzGu4PV5z_avatar_client_id_UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm'. This is a serious configuration problem. JOSM will stop working.
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
	at java.util.concurrent.ForkJoinTask.getThrowableException(ForkJoinTask.java:593)
	at java.util.concurrent.ForkJoinTask.reportException(ForkJoinTask.java:677)
	at java.util.concurrent.ForkJoinTask.join(ForkJoinTask.java:720)
	at java.util.concurrent.ForkJoinPool.invoke(ForkJoinPool.java:2616)
	at org.openstreetmap.josm.plugins.mapillary.io.download.MapillarySquareDownloadRunnable.run(MapillarySquareDownloadRunnable.java:39)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)
Caused by: org.openstreetmap.josm.tools.JosmRuntimeException: Fatal: failed to locate image '/Users/imac63/Library/Caches/JOSM/mirror_https___a.mapillary.com_v3_organizations_O0K377md1CVrVkzGu4PV5z_avatar_client_id_UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm'. This is a serious configuration problem. JOSM will stop working.
	at org.openstreetmap.josm.tools.ImageProvider.getResource(ImageProvider.java:704)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:664)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:810)
	at org.openstreetmap.josm.plugins.mapillary.data.mapillary.OrganizationRecord.createAvatarIcon(OrganizationRecord.java:63)
	at org.openstreetmap.josm.plugins.mapillary.data.mapillary.OrganizationRecord.<init>(OrganizationRecord.java:46)
	at org.openstreetmap.josm.plugins.mapillary.data.mapillary.OrganizationRecord.getNewOrganization(OrganizationRecord.java:113)
	at java.util.concurrent.ConcurrentHashMap.computeIfAbsent(ConcurrentHashMap.java:1660)
	at org.openstreetmap.josm.plugins.mapillary.data.mapillary.OrganizationRecord.getOrganization(OrganizationRecord.java:93)
	at org.openstreetmap.josm.plugins.mapillary.MapillarySequence.setOrganization(MapillarySequence.java:204)
	at org.openstreetmap.josm.plugins.mapillary.MapillarySequence.<init>(MapillarySequence.java:64)
	at org.openstreetmap.josm.plugins.mapillary.utils.api.JsonSequencesDecoder.decodeSequence(JsonSequencesDecoder.java:43)
	at org.openstreetmap.josm.plugins.mapillary.utils.api.JsonDecoder.decodeFeatureCollection(JsonDecoder.java:44)
	at org.openstreetmap.josm.plugins.mapillary.io.download.SequenceDownloadRunnable.run(SequenceDownloadRunnable.java:58)
	at org.openstreetmap.josm.plugins.mapillary.io.download.BoundsDownloadRunnable.realRun(BoundsDownloadRunnable.java:67)
	at org.openstreetmap.josm.plugins.mapillary.io.download.BoundsDownloadRunnable.run(BoundsDownloadRunnable.java:48)
	at org.openstreetmap.josm.plugins.mapillary.io.download.SequenceDownloadRunnable.compute(SequenceDownloadRunnable.java:47)
	at java.util.concurrent.RecursiveAction.exec(RecursiveAction.java:189)
	at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:289)
	at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1056)
	at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1692)
	at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:157)

Attachments (0)

Change History (2)

comment:1 Changed 4 weeks ago by taylor.smock

Component: CorePlugin mapillary
Owner: changed from team to taylor.smock

comment:2 Changed 2 weeks ago by taylor.smock

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain taylor.smock.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.