Modify

Opened 4 years ago

Closed 3 years ago

#19187 closed enhancement (duplicate)

[TaggingPreset] Enhance <combo /> to set multiple keys per entry (or create a <combo_set /> element)

Reported by: KorneySan Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: preset Cc:

Description (last modified by skyper)

Proposal is to allow <combo /> (or new <combo_set />) to set multiple keys per entry.

Current <combo /> abilities (in short):

<combo
  key="key" 
  text="Some description"
  >
  <list_entry value="value 1" short_description="desc 1" icon="..." icon_size="..." />
  <list_entry value="value 2" short_description="desc 3" icon="..." icon_size="..." />
  ...
</combo>

where any value x is set to key by selection of an entry.

Proposal for <combo_set /> element:

<combo_set
  text="Some description"
  >
  <list_entry_set
    display_value="text 1"
    short_description="desc 1"
    icon="..."
    icon_size="..." 
    >
    <list_entry_set_item key="key 1" value="value 1" />
    <list_entry_set_item key="key 2" value="value 2" />
    ...
  </list_entry_set>
  <list_entry_set
    display_value="text 2"
    short_description="desc 2"
    icon="..."
    icon_size="..." 
    >
    <list_entry_set_item key="key 3" value="value 3" />
    <list_entry_set_item key="key 4" value="value 4" />
    ...
  </list_entry_set>
  ...
</combo_set>

where combo_set displays a list of display_values as usual combo, but on selection of certain entry it should set all the keys mentioned in that entry to the appropriate values.

I think it should not be match properties for <combo_set /> because it is too complicated.

Example of use

<combo_set
  text="Main language"
  >
  <list_entry_set
    display_value="Set to English"
    >
    <list_entry_set_item key="language:en" value="main" />
    <list_entry_set_item key="language:de" value="yes" />
  </list_entry_set>
  <list_entry_set
    display_value="Set to German"
    >
    <list_entry_set_item key="language:en" value="yes" />
    <list_entry_set_item key="language:de" value="main" />
  </list_entry_set>
</combo_set>

Attachments (0)

Change History (2)

comment:1 by skyper, 4 years ago

Component: Internal presetCore
Description: modified (diff)

comment:2 by simon04, 3 years ago

Resolution: duplicate
Status: newclosed

Closed as duplicate of #8177.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.