Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1899 closed defect (duplicate)

error occured after first Start of 1182 and updating two plugins

Reported by: christianl Owned by: framm
Priority: major Milestone:
Component: unspecified Version: latest
Keywords: Cc:

Description

I just updated josm-latest to 1182.
At start I got a message, that the plugin "utilsplugin" could not be loaded. I choosed to let the plugin active, went to "Einstellungen ..." and "Plugins" choosed "aktualisieren" and was requested to restart josm, when the error occured.

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1182
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1182
Last Changed Date: 2008-12-27 00:09:20 +0100 (Sat, 27 Dec 2008)

java.lang.AbstractMethodError

at org.openstreetmap.josm.gui.preferences.PreferenceDialog.ok(PreferenceDialog.java:94)
at org.openstreetmap.josm.actions.PreferencesAction.actionPerformed(PreferencesAction.java:75)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

At the Moment I had to deactivate utilsplugin because even the explicite deactivate an activate of this plugin will yield to an error. Maybe I have to reboot the system or things like this. I don't know. I'm quite new with osm.

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by anonymous

Resolution: duplicate
Status: newclosed

Until utilsplugin is updated, that error will remain. Duplicate of #1183.

comment:2 Changed 10 years ago by anonymous

Uhhm, #1883.

comment:3 Changed 10 years ago by anonymous

Sorry, I mixed utilsplugin and usertools.

When booting with deactivated utilsplugin (no error) and activating it you are asked to delete it. Say yes and redownload it (and all other plugins it offers you for update). This should solve problems.If not, reopen bug.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.