Modify

Opened 4 months ago

Closed 4 months ago

Last modified 3 months ago

#18957 closed defect (duplicate)

just crashed ...

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Plugin tracer Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-02-26 10:50:27 +0100 (Wed, 26 Feb 2020)
Build-Date:2020-02-26 09:52:41
Revision:15937
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15937 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1511 (10586)
Memory Usage: 947 MB / 1820 MB (378 MB allocated, but free)
Java version: 1.8.0_73-b02, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768
Dataset consistency test: No problems found

Plugins:
+ ColorPlugin (1537115529)
+ CustomizePublicTransportStop (35248)
+ DxfImport (1013)
+ ImageWayPoint (35248)
+ Mapillary (1.5.20)
+ Tracer (35313)
+ Tracer-testing (1580583983)
+ apache-commons (35092)
+ apache-http (35092)
+ buildings_tools (35248)
+ ejml (35122)
+ geotools (35169)
+ gpsblam (35221)
+ jna (35092)
+ jogl (1.2.3)
+ jts (35122)
+ pdfimport (35248)
+ print (35248)
+ turnrestrictions (35313)
+ wikipedia (1.1.3)

Last errors/warnings:
- W: Unable to request certificate of https://grca.nat.gov.tw
- W: Unable to request certificate of https://grca.nat.gov.tw
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.plugins.tracer.TracerAction@62e7dffa (instance of org.openstreetmap.josm.plugins.tracer.TracerAction) was not registered before or already removed.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.plugins.tracer.TracerAction@62e7dffa (instance of org.openstreetmap.josm.plugins.tracer.TracerAction) was not registered before or already removed.


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.plugins.tracer.TracerAction@62e7dffa (instance of org.openstreetmap.josm.plugins.tracer.TracerAction) was not registered before or already removed.
	at org.openstreetmap.josm.tools.ListenerList.failRemove(ListenerList.java:138)
	at org.openstreetmap.josm.tools.ListenerList.removeListener(ListenerList.java:132)
	at org.openstreetmap.josm.data.Preferences.removePreferenceChangeListener(Preferences.java:264)
	at org.openstreetmap.josm.actions.mapmode.MapMode.exitMode(MapMode.java:85)
	at org.openstreetmap.josm.plugins.tracer.TracerAction.exitMode(TracerAction.java:67)
	at org.openstreetmap.josm.gui.MapFrame.selectMapMode(MapFrame.java:488)
	at org.openstreetmap.josm.gui.MapFrame.selectMapMode(MapFrame.java:465)
	at org.openstreetmap.josm.actions.mapmode.MapMode.actionPerformed(MapMode.java:113)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.JToggleButton$ToggleButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (5)

comment:1 Changed 4 months ago by tmaqelepo@…

the draw function just hungup but everything seems tobe working well even when this function is still stuck

comment:2 Changed 4 months ago by stoecker

Ticket #18958 has been marked as a duplicate of this ticket.

comment:3 Changed 4 months ago by stoecker

Component: CorePlugin tracer
Resolution: duplicate
Status: newclosed

Closed as duplicate of #18834.

comment:4 Changed 4 months ago by skyper

Component: Plugin tracerPlugin tracer2

comment:5 Changed 3 months ago by skyper

Component: Plugin tracer2Plugin tracer

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.