Modify

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#18926 closed defect (fixed)

RFC: Drop last-check from maps.xsd and maps

Reported by: stoecker Owned by: team
Priority: normal Milestone: 20.03
Component: Core Version:
Keywords: Cc: Don-vip, Klumbumbus

Description

Because asked if our wiki features are used I checked.

https://github.com/osmlab/editor-layer-index/pull/815

Thinking about last-check it seems this flag is obsolete nowadays. The idea was to have an indication whether a maps entry is old and stale or brand new and fine. Wiki editors never really cared much about that flag, so that did not really work as intended.

We have integrity tests now which check the entries, so maybe it is time to retire that flag altogether?

Comments?

Attachments (0)

Change History (5)

comment:1 Changed 3 months ago by Klumbumbus

+1 for removing it. It is not really useful imo.

comment:2 Changed 3 months ago by stoecker

Resolution: fixed
Status: newclosed

In 16117/josm:

fix #18926 - drop last-check attribute

comment:3 Changed 3 months ago by stoecker

I hope I didn't overlook anything, but dropping the attribute from the xsd should not cause trouble after the database was cleaned...

comment:4 Changed 3 months ago by Klumbumbus

Milestone: 20.03

comment:5 Changed 3 months ago by Don-vip

I wasn't even aware of it.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.