Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1891 closed defect (duplicate)

Backtrace when trying to download a bbox

Reported by: avarab@… Owned by: framm
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: Cc:


I'm running [1182]. When I open JOSM, go to the download map dialog and try to download an area I get this:

Development version. Unknown revision.

at org.openstreetmap.josm.actions.DownloadAction.actionPerformed(
at javax.swing.AbstractButton.fireActionPerformed(
at javax.swing.AbstractButton$Handler.actionPerformed(
at javax.swing.DefaultButtonModel.fireActionPerformed(
at javax.swing.DefaultButtonModel.setPressed(
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(
at java.awt.AWTEventMulticaster.mouseReleased(
at java.awt.Component.processMouseEvent(
at javax.swing.JComponent.processMouseEvent(
at java.awt.Component.processEvent(
at java.awt.Container.processEvent(
at java.awt.Component.dispatchEventImpl(
at java.awt.Container.dispatchEventImpl(
at java.awt.Component.dispatchEvent(
at java.awt.LightweightDispatcher.retargetMouseEvent(
at java.awt.LightweightDispatcher.processMouseEvent(
at java.awt.LightweightDispatcher.dispatchEvent(
at java.awt.Container.dispatchEventImpl(
at java.awt.Window.dispatchEventImpl(
at java.awt.Component.dispatchEvent(
at java.awt.EventQueue.dispatchEvent(
at java.awt.EventDispatchThread.pumpOneEventForFilters(
at java.awt.EventDispatchThread.pumpEventsForFilter(
at java.awt.EventDispatchThread.pumpEventsForHierarchy(
at java.awt.EventDispatchThread.pumpEvents(
at java.awt.EventDispatchThread.pumpEvents(

All my plugins are up to date (download list, update & restart).

Attachments (0)

Change History (4)

comment:1 Changed 9 years ago by anonymous

Resolution: duplicate
Status: newclosed

Duplicate #1883.

comment:2 Changed 9 years ago by avarab@…

Resolution: duplicate
Status: closedreopened

This is not a duplicate of #1883. It has been solved (for me) but I still get this backtrace when trying to use the download dialog.

All my plugins are up-do-date.

The backtrace is also different.

comment:3 Changed 9 years ago by anonymous

Resolution: duplicate
Status: reopenedclosed

You use gpsbabelgui or usertools? They are not updated yet.

Yes the backtrace is different, but it's the same problem :-) There are 3 or 4 different backtraces which have same reason.

Please add versions of all plugins in a comment to #1883 when there are still problems.

comment:4 Changed 9 years ago by avarab@…

I wasn't using those two problems and all my plugins had been updated, but after doing ant clean && ant dist as suggested in #1901 the problem went away.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.