Modify

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#18860 closed enhancement (invalid)

Do not render highway=traffic_signals and crossing=traffic_signals together anymore

Reported by: Lukas458 Owned by: team
Priority: normal Milestone:
Component: Internal mappaint style Version: latest
Keywords: crossing, traffic_signals Cc: Lukas458

Description

I think it's contraproductive to render highway=traffic_signals + crossing=traffic_signals with a "big" AND a small traffic-signals-symbol, so it's misinterpreted as shortcut for putting a crossing (crossing=traffic_signals) and a highway-traffic-signal for the traffic on the lanes together on one node. I think this shouldn't happen, whereever possible highway=traffic_signals and highway=crossing + crossing=traffic_signals should apply on two separate nodes. Also because crossing=traffic_signals is an under-tag of highway=crossing, like the other crossing-values also are, and doesn't belong together with highway=traffic_signals.

Attachments (0)

Change History (5)

comment:1 Changed 3 months ago by skyper

Resolution: invalid
Status: newclosed

Atm, both is valid.

The two symbols are only rendered if both tags are present.
You need to add highway=crossing to the pedestrian crossing together with crossing=traffic_signals if you map it separate.

comment:2 Changed 3 months ago by skyper

Type: defectenhancement

comment:3 Changed 3 months ago by anonymous

Okay, I see, but the problem is, that crossing=traffic_signals belongs to highway=crossing. crossing=traffic_signals together with highway=traffi_signals is not a valid pedestrian crossing tagging in my eyes. It would be like you are tagging only crossing=uncontrolled without highway=crossing on a node, this would be incomplete, too.

comment:4 Changed 3 months ago by skyper

No, please, have a look at the wiki and please do start discussions about tagging style on appropriated media, e.g. the discussion pages on the wiki, the forum or mailing lists like tagging@osm. Thanks

comment:5 Changed 3 months ago by anonymous

delite all

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.