Modify

Opened 3 months ago

Closed 3 months ago

#18827 closed defect (duplicate)

JOSM Validator on opening_hours (nodes): Cannot read property "0" from undefined

Reported by: AnkEric Owned by: boman
Priority: normal Milestone:
Component: Plugin openinghourseditor Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Overpass query

Area: 50 km. around Bergen op Zoom, Netherlands
Select "node" (not: "way" !)
Result 5000 nodes

<query type="node">

<has-kv k="opening_hours"/>
<bbox-query {{bbox}}/>

</query>
<union>

<item/>
<recurse type="down"/>

</union>

  1. Export to JOSM
  1. JOSM Validation (on opening_hours)

What is the expected result?

JOSM Validator: Warnings

What happens instead?

JOSM Validator: multiple errors (blinking) + Warnings.
ScriptException: TypeError: Cannot read property "0" from undefined

Please provide any additional information below. Attach a screenshot if possible.

I could not find a specific opening_hours responsible for this error.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-02-26 10:50:27 +0100 (Wed, 26 Feb 2020)
Build-Date:2020-02-26 09:52:41
Revision:15937
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15937 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1909 (18363)
Memory Usage: 1260 MB / 1820 MB (678 MB allocated, but free)
Java version: 1.8.0_241-b07, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ Mapillary (1.5.20)
+ OpeningHoursEditor (35250)
+ PolygonCutOut (v0.7)
+ apache-commons (35092)
+ apache-http (35092)
+ contourmerge (v0.1.6)
+ ejml (35122)
+ jaxb (35092)
+ jna (35092)
+ jts (35122)
+ reverter (35313)
+ routes (35248)
+ turnrestrictions (35313)
+ utilsplugin2 (35334)

Tagging presets:
+ <josm.pref>\presets\NL_fiets_preset.xml
+ <josm.pref>\presets\Picnic_table.xml

Last errors/warnings:
- W: org.openstreetmap.josm.plugins.ohe.parser.TokenMgrError: Lexical error at line 1, column 35.  Encountered: "d" (100), after : ""
- W: Disable opening hours editor:: java.lang.Exception: Error in the TimeValue. Cause: org.openstreetmap.josm.plugins.ohe.parser.TokenMgrError: Lexical error at line 1, column 35.  Encountered: "d" (100), after : ""
- W: javax.script.ScriptException: TypeError: Cannot read property "0" from undefined in <eval> at line number 38. Cause: jdk.nashorn.internal.runtime.ECMAException: TypeError: Cannot read property "0" from undefined
- E: javax.script.ScriptException: TypeError: Cannot read property "0" from undefined in <eval> at line number 38. Cause: jdk.nashorn.internal.runtime.ECMAException: TypeError: Cannot read property "0" from undefined
- W: javax.script.ScriptException: TypeError: Cannot read property "0" from undefined in <eval> at line number 38. Cause: jdk.nashorn.internal.runtime.ECMAException: TypeError: Cannot read property "0" from undefined
- E: javax.script.ScriptException: TypeError: Cannot read property "0" from undefined in <eval> at line number 38. Cause: jdk.nashorn.internal.runtime.ECMAException: TypeError: Cannot read property "0" from undefined
- W: javax.script.ScriptException: TypeError: Cannot read property "0" from undefined in <eval> at line number 38. Cause: jdk.nashorn.internal.runtime.ECMAException: TypeError: Cannot read property "0" from undefined
- E: javax.script.ScriptException: TypeError: Cannot read property "0" from undefined in <eval> at line number 38. Cause: jdk.nashorn.internal.runtime.ECMAException: TypeError: Cannot read property "0" from undefined
- W: javax.script.ScriptException: TypeError: Cannot read property "0" from undefined in <eval> at line number 38. Cause: jdk.nashorn.internal.runtime.ECMAException: TypeError: Cannot read property "0" from undefined
- E: javax.script.ScriptException: TypeError: Cannot read property "0" from undefined in <eval> at line number 38. Cause: jdk.nashorn.internal.runtime.ECMAException: TypeError: Cannot read property "0" from undefined

Attachments (1)

2020-03-01_15-03-55.png (6.6 KB) - added by AnkEric 3 months ago.

Download all attachments as: .zip

Change History (2)

Changed 3 months ago by AnkEric

Attachment: 2020-03-01_15-03-55.png added

comment:1 Changed 3 months ago by skyper

Component: Core validatorPlugin openinghourseditor
Owner: changed from team to boman
Resolution: duplicate
Status: newclosed

Closed as duplicate of #16767.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain boman.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.