Modify

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#18818 closed defect (fixed)

"Download from OSM along selected ways" disallows value < 10 [meters]

Reported by: 1bm@… Owned by: team
Priority: normal Milestone: 20.03
Component: Core Version:
Keywords: Cc:

Description

What steps will reproduce the problem?

  1. Alt+Shift+D or select menu entry "Download along..." to open dialogue window "Download from OSM along selected ways"
  2. (leave pre-selected checkbox "OpenStreetMap data" untouched)
  3. focus on and type value < 10 in input field between "Download everything within:" and "meters"

What is the expected result?

allow value < 10 meters (as it used to be)

What happens instead?

disallows value < 10 metres, resets it to 10

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-02-26 10:50:27 +0100 (Wed, 26 Feb 2020)
Build-Date:2020-02-26 09:52:41
Revision:15937
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15937 en) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 811 MB / 1749 MB (341 MB allocated, but free)
Java version: 1.8.0_241-b07, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 2560x1440
Maximum Screen Size: 2560x1440
Dataset consistency test: No problems found

Plugins:
+ BuildingGeneralization (23)
+ CADTools (1008)
+ EasyPresets (1537621333)
+ ImageWayPoint (35248)
+ Mapillary (1.5.20)
+ PolygonCutOut (v0.7)
+ QuickLabel (18)
+ RoadSigns (35313)
+ apache-commons (35092)
+ apache-http (35092)
+ auto_tools (73)
+ buildings_tools (35248)
+ changeset-viewer (22)
+ imagery_offset_db (35248)
+ javafx-windows
+ jna (35092)
+ measurement (35248)
+ openvisible (35248)
+ reverter (35313)
+ turnrestrictions (35313)
+ utilsplugin2 (35334)

Tagging presets:
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/DE.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Stolpersteine&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/StolpersteineLight&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/iD&zip=1
+ D:\Portable Programme (non-install)\JOSM\Styles_Modified-style.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LitObjects&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1

Validator rules:
+ https://josm.openstreetmap.de/josmfile?page=Rules/GermanySpecific&zip=1

Last errors/warnings:
- W: java.net.UnknownHostException: b.tile.openstreetmap.org
- W: Already here java.net.UnknownHostException: b.tile.openstreetmap.org
- W: java.net.UnknownHostException: b.tile.openstreetmap.org
- W: Already here java.net.UnknownHostException: b.tile.openstreetmap.org
- W: java.net.UnknownHostException: b.tile.openstreetmap.org
- W: Already here java.net.UnknownHostException: b.tile.openstreetmap.org
- W: java.net.UnknownHostException: b.tile.openstreetmap.org
- W: Already here java.net.UnknownHostException: b.tile.openstreetmap.org
- W: java.net.UnknownHostException: b.tile.openstreetmap.org
- W: Already here java.net.UnknownHostException: b.tile.openstreetmap.org

Attachments (0)

Change History (12)

comment:1 Changed 3 months ago by GerdP

I think it works like this since r7536, see #8430

comment:2 in reply to:  1 Changed 3 months ago by anonymous

Replying to GerdP:

I think it works like this since r7536, see #8430

I believe you are mistaken. #8430 closed 5yrs ago. Until recently (last monthly version) < 10 (e.g. 5m) worked just fine for me.

comment:3 Changed 3 months ago by GerdP

I just tried with r14986. 10m is the smallest accepted value for the distance, 1 km² is the smallest accepted value for the area size.

comment:4 in reply to:  1 Changed 3 months ago by simon04

Replying to GerdP:

I think it works like this since r7536, see #8430

+1

If smaller values are useful (are they?), we can lower this limit easily.

comment:5 Changed 3 months ago by GerdP

If I got that right the limit is ignored. I tried with 10m and 1km² and the smallest download area was 1000x1000 m.
So, there might be an error in the interpretation of the values.

comment:6 Changed 3 months ago by anonymous

I have checked back w/ prev v15806 and (at least for this one) it turns out to be true: same behaviour as now. So I believed that it did what I expected inspite of what it really does/did. Interesting.

So yes, I think smaller values could be useful – I would like to download the least possible amount of data necessary, just what is useful to get the job done (e.g. houses/addresses along a street for checking stuff with mapillary)

comment:7 Changed 3 months ago by GerdP

Reg. comment:5: I expected many small areas along a diagonal way with 3000 m length with these settings, but the result was correct.
When you select a rather short way and use this action the value 10m seems in fact too high. I see no need to limit it to 10m, 1m is OK.

comment:8 Changed 3 months ago by GerdP

Resolution: fixed
Status: newclosed

In 15970/josm:

fix #18818: "Download from OSM along selected ways" disallows value < 10 [meters]
Lower the limit to 1m

comment:9 Changed 3 months ago by GerdP

Resolution: fixed
Status: closedreopened

comment:10 Changed 3 months ago by GerdP

Reg. the area: The dialog doesn't allow to set a value < 1 km² although the code seems to intend that 0.01 should be the minimum:

maxRect = new JSpinner(new SpinnerNumberModel(Config.getPref().getDouble(prefArea, 20.0), 0.01, 25.0, 1.0)) {

I assume the stepSize of 1.0 is responsible for that. Should I change the dialog to use normal input fields instead of JSpinner?

comment:11 Changed 3 months ago by GerdP

Resolution: fixed
Status: reopenedclosed

In 15971/josm:

fix #18818: "Download from OSM along selected ways" disallows area value < 1 km²
Set stepSize parameter to 0.01 instead of 1

comment:12 Changed 3 months ago by Don-vip

Milestone: 20.03

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.