Modify

Opened 5 weeks ago

Closed 5 weeks ago

Last modified 5 weeks ago

#18787 closed defect (duplicate)

JOSM wont staRT!!!!

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-02-24 22:06:28 +0100 (Mon, 24 Feb 2020)
Build-Date:2020-02-24 21:08:22
Revision:15927
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15927 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1909 (18363)
Memory Usage: 665 MB / 7196 MB (328 MB allocated, but free)
Java version: 1.8.0_241-b07, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080, \Display1 1920x1080
Maximum Screen Size: 1920x1080

Plugins:
+ EvidenceStore
+ FastDraw
+ LatLonTool
+ Mapillary
+ MicrosoftStreetside
+ OpenStreetCam
+ TmTools
+ apache-commons
+ apache-http
+ buildings_tools
+ count_changes
+ ejml
+ geochat
+ geotools
+ imagery_offset_db
+ javafx-windows
+ jaxb (35092)
+ jna
+ jts
+ mbtiles
+ opendata
+ openjfx
+ rex
+ splinex
+ tageditor
+ todo
+ turnlanes
+ turnlanes-tagging
+ turnrestrictions
+ utilsplugin2

Tagging presets:
+ %UserProfile%\Downloads\South Australia Preset.xml
+ %UserProfile%\Downloads\Western Australia Preset.xml
+ %UserProfile%\Desktop\MICROSOFT\Nemanja\DestinationSignsRelation.xml
+ %UserProfile%\Desktop\MICROSOFT\Nemanja\DestinationSignsRelationNOVO.xml
+ %UserProfile%\Desktop\MICROSOFT\Plugin\Destination signs preset\DestinationSigns_v2.zip
+ %UserProfile%\Desktop\MICROSOFT\Preset\DestinationSigns_AU.zip

Map paint styles:
- https://www.dropbox.com/s/qo3ai47fpv241jf/Styles_Fixme_and_Notes.zip?raw=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
+ https://pasharm.github.io/New_basic_style_for_JOSM/New_basic_style.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- %UserProfile%\Desktop\MICROSOFT\Styles_Noname-style.mapcss
+ https://github.com/osmlab/appledata/archive/josm_paint_inline_validation.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/LayerChecker&zip=1
- %UserProfile%\Downloads\Styles_Surface-MDCS_fix.mapcss
+ C:\Program Files (x86)\JOSM\Teams plugins\tmstyle.mapcss
- %UserProfile%\Downloads\BlackStreet_Australia.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
+ https://github.com/BrackoNe/rs_traffic_signs/archive/master.zip

Last errors/warnings:
- W: Plugin openjfx requires Java version 11. The current Java version is 8. You have to update Java in order to use this plugin.
- W: Plugin javafx-windows requires Java version 10. The current Java version is 8. You have to update Java in order to use this plugin.
- E: Handled by bug report queue: javax.json.stream.JsonParsingException: Invalid token=EOF at (line no=3, column no=49, offset=97). Expected tokens are: [CURLYOPEN, SQUAREOPEN, STRING, NUMBER, TRUE, FALSE, NULL, SQUARECLOSE]


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
javax.json.stream.JsonParsingException: Invalid token=EOF at (line no=3, column no=49, offset=97). Expected tokens are: [CURLYOPEN, SQUAREOPEN, STRING, NUMBER, TRUE, FALSE, NULL, SQUARECLOSE]
	at org.glassfish.json.JsonParserImpl.parsingException(JsonParserImpl.java:437)
	at org.glassfish.json.JsonParserImpl.getArray(JsonParserImpl.java:328)
	at org.glassfish.json.JsonParserImpl.getValue(JsonParserImpl.java:180)
	at org.glassfish.json.JsonParserImpl.getObject(JsonParserImpl.java:339)
	at org.glassfish.json.JsonParserImpl.getObject(JsonParserImpl.java:173)
	at org.openstreetmap.josm.tools.Territories.initializeExternalData(Territories.java:170)
	at org.openstreetmap.josm.tools.Territories.initialize(Territories.java:123)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:33)
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.runInitializationTasks(Lifecycle.java:99)
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:71)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:903)
	at org.openstreetmap.josm.gui.MainApplication$3.processArguments(MainApplication.java:276)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:703)

Attachments (0)

Change History (2)

comment:1 Changed 5 weeks ago by stoecker

Resolution: duplicate
Status: newclosed

Closed as duplicate of #18772.

comment:2 Changed 5 weeks ago by anonymous

Tnank yOU

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.