Modify

Opened 5 weeks ago

Closed 5 weeks ago

#18784 closed defect (duplicate)

Crash at every run after update

Reported by: h@… Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. use josm for years
  2. apt-get upgrade
  3. josm&

What is the expected result?

Use JOSM

What happens instead?

Crash after INFOS: GET https://api.openstreetmap.org/api/0.6/user/details -> HTTP/1.1 200 (434 ms; 1,15 kB)

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-02-24 22:06:28 +0100 (Mon, 24 Feb 2020)
Revision:15927
Build-Date:2020-02-24 21:08:22
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15927 fr) Linux Debian GNU/Linux 10 (buster)
Memory Usage: 202 MB / 1920 MB (90 MB allocated, but free)
Java version: 11.0.6+10-post-Debian-1deb10u1, Debian, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-11-jre:amd64-11.0.6+10-1~deb10u1
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-22
libcommons-compress-java: libcommons-compress-java:all-1.18-2
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:-
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]

Plugins:
+ ImproveWay
+ Mapillary
+ OpeningHoursEditor
+ SimplifyArea
+ apache-commons
+ apache-http
+ buildings_tools
+ editgpx
+ ejml
+ epci-fr (35092)
+ geotools
+ indoorhelper (35336)
+ jaxb (35092)
+ jna
+ jts
+ mapwithai
+ measurement
+ merge-overlap
+ opendata
+ openqa
+ print
+ todo
+ utilsplugin2
+ wikipedia

Map paint styles:
- https://github.com/hotosm/HDM-JOSM-style/archive/master.zip
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/MapWithAI&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1

Last errors/warnings:
- E: Handled by bug report queue: javax.json.stream.JsonParsingException: Invalid token=EOF at (line no=3, column no=49, offset=97). Expected tokens are: [CURLYOPEN, SQUAREOPEN, STRING, NUMBER, TRUE, FALSE, NULL, SQUARECLOSE]


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
javax.json.stream.JsonParsingException: Invalid token=EOF at (line no=3, column no=49, offset=97). Expected tokens are: [CURLYOPEN, SQUAREOPEN, STRING, NUMBER, TRUE, FALSE, NULL, SQUARECLOSE]
	at org.glassfish.json.JsonParserImpl.parsingException(JsonParserImpl.java:437)
	at org.glassfish.json.JsonParserImpl.getArray(JsonParserImpl.java:328)
	at org.glassfish.json.JsonParserImpl.getValue(JsonParserImpl.java:180)
	at org.glassfish.json.JsonParserImpl.getObject(JsonParserImpl.java:339)
	at org.glassfish.json.JsonParserImpl.getObject(JsonParserImpl.java:173)
	at org.openstreetmap.josm.tools.Territories.initializeExternalData(Territories.java:170)
	at org.openstreetmap.josm.tools.Territories.initialize(Territories.java:123)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:33)
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.runInitializationTasks(Lifecycle.java:99)
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:71)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:903)
	at org.openstreetmap.josm.gui.MainApplication$3.processArguments(MainApplication.java:276)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:703)

I hope this not a duplicate, please ask for any additional info needed.

Regards

Attachments (0)

Change History (1)

comment:1 Changed 5 weeks ago by anonymous

Resolution: duplicate
Status: newclosed

Closed as duplicate of #18772.
Sorry, the crash form lead staight to new ticket, please there are already lot of them.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.