Modify

Opened 3 months ago

Closed 3 months ago

#18762 closed defect (duplicate)

Editing a building tag error

Reported by: anonymous Owned by: team
Priority: major Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. trying to tag a drawn in structure as a building
  2. using the utility plugin for drawing buildings (b) then trying to edit the building tag to equal something other than building=yes
  3. Any use of the building tag. While adding a tag to a building drawn in using a, just typing b will into the key tag will produce an error

What is the expected result? That you can draw in a building and change the tags as needed to represent what type of building it is.

What happens instead? An error report opens and doesn't allow you to make changes to the building tag or add the building tag to any geometry that has been drawn when not using the plugin.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-02-23 19:11:30 +0100 (Sun, 23 Feb 2020)
Build-Date:2020-02-23 19:47:25
Revision:15915
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15915 en) Mac OS X 10.13.6
OS Build number: Mac OS X 10.13.6 (17G65)
Memory Usage: 1047 MB / 1820 MB (516 MB allocated, but free)
Java version: 1.8.0_241-b07, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 84062146 1920x1080, Display 69949852 2048x1152
Maximum Screen Size: 2048x1152
VM arguments: [-Djava.util.Arrays.useLegacyMergeSort=true, -Djnlp.tk=awt, -Djnlpx.jvm=<java.home>/bin/java, -Djnlpx.splashport=-1, -Djnlpx.home=<java.home>/bin, -Djnlpx.remove=false, -Djnlpx.offline=false, -Djnlpx.relaunch=true, -Djnlpx.session.data=/var/folders/7m/mnqjdzh913b7phr89dmcb_nc0000gn/T/session4027170516060434573, -Djnlpx.heapsize=-1,2147483648, -Djava.security.policy=file:<java.home>/lib/security/javaws.policy, -DtrustProxy=true, -Djnlpx.origFilenameArg=${HOME}/Library/Mobile Documents/com~apple~CloudDocs/Desktop/josm.jnlp, -Dsun.awt.warmup=true, -Djava.security.manager]
Dataset consistency test: No problems found

Plugins:
+ EasyPresets (1537621333)
+ ImproveOsm (191)
+ Mapillary (1.5.20)
+ OpenStreetCam (280)
+ apache-commons (35092)
+ apache-http (35092)
+ auto_tools (73)
+ buildings_tools (35248)
+ changeset-viewer (22)
+ graphview (35313)
+ intersection (0.0.7)
+ jna (35092)
+ markseen (14)
+ osm-obj-info (56)
+ reverter (35313)
+ rex (53)
+ turnrestrictions (35313)
+ undelete (35313)
+ utilsplugin2 (35334)

Tagging presets:
+ /Volumes/Clingstone/Presets_LaneAttributes-preset.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1

Map paint styles:
+ https://raw.githubusercontent.com/KaartGroup/Kaart-Styles/master/Kaart-Styles.mapcss
- ${HOME}/Downloads/Kaart-Styles.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ https://raw.githubusercontent.com/KaartGroup/Kaart-Styles/master/Overlapping%20Ways.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1

Validator rules:
+ https://raw.githubusercontent.com/KaartGroup/KaartValidator/master/kaart.validator.mapcss

Last errors/warnings:
- E: java.nio.file.NoSuchFileException: /Volumes/Clingstone/Presets_LaneAttributes-preset.xml
- E: /Volumes/Clingstone/Presets_LaneAttributes-preset.xml
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-2 (30) of javawsApplicationThreadGroup
java.lang.NullPointerException

Attachments (0)

Change History (1)

comment:1 Changed 3 months ago by taylor.smock

Resolution: duplicate
Status: newclosed

Closed as duplicate of #18764.
#18764 has a better trace.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.