Modify

Opened 3 months ago

Last modified 2 days ago

#18755 assigned enhancement

Add compatibility with Java 15

Reported by: Don-vip Owned by: Don-vip
Priority: normal Milestone: 20.08
Component: Core Version:
Keywords: java15 Cc: simon04

Description

Followup of #17827

First ​EA builds of Java 15 are available.

Attachments (0)

Change History (7)

comment:1 Changed 3 months ago by Don-vip

In 15914/josm:

fix #17827 - see #18755 - use Java 14/15 in Linux start script

comment:2 Changed 3 months ago by Don-vip

Cc: simon04 added

It's likely we will see Nashorn disappear in Java 15: javabug:8236933

comment:3 Changed 3 months ago by Don-vip

Replacement of opening_hours.js by OpeningHoursParser is tracked in #18140

comment:4 Changed 3 months ago by simon04

Replacement of OverpassTurboQueryWizard by unknown is tracked in #18164

comment:5 Changed 3 months ago by Don-vip

In 16156/josm:

see #17516 - see #17827 - see #18755 - Enable Jacoco coverage on Java 13/14/15

upgraded jacocoant to jacoco-0.8.6-20200313.013328-40 snapshot

comment:6 Changed 7 weeks ago by simon04

Removal of PreferencesUtils#readPrefsFromJS due to Nashorn removal tracked in #18830

comment:7 Changed 2 days ago by Don-vip

Google finally addressed my 2-years old ticket to add compatibility with Java 12+.

Error-Prone 2.4.0 is compatible with Java 8-14 + 15-ea.

See #19334 for patch.

Last edited 2 days ago by Don-vip (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as assigned The owner will remain Don-vip.
as The resolution will be set.
to The owner will be changed from Don-vip to the specified user.
The owner will change to Don-vip
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.