Modify

Opened 5 days ago

Closed 5 days ago

#18708 closed defect (fixed)

ArrayIndexOutOfBoundsException in ShowStatusReportAction

Reported by: simon04 Owned by: simon04
Priority: normal Milestone: 20.02
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Help → Report bug

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Revision:15845
Is-Local-Build:true
Build-Date:2020-02-12 00:07:07

Identification: JOSM/1.5 (15845 SVN de) Linux Arch Linux
Memory Usage: 512 MB / 3972 MB (245 MB allocated, but free)
Java version: 11.0.6+10, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 3840x2160
Maximum Screen Size: 3840x2160
VM arguments: [-agentlib:jdwp=transport=dt_socket,address=127.0.0.1:52275,suspend=y,server=n, -Djosm.dir.name=JOSM-dev, -javaagent:/opt/intellij-idea-ce-eap/plugins/Groovy/lib/agent/gragent.jar, -javaagent:/opt/intellij-idea-ce-eap/plugins/java/lib/rt/debugger-agent.jar, -agentpath:/tmp/libmemory_agent4.so=, -Dfile.encoding=UTF-8]
Program arguments: [--set=expert=true, --set=debug.edt-checker.enable=true, --set=dialog.dynamic.buttons=false]
Dataset consistency test: No problems found
[-agentlib:jdwp=transport=dt_socket,address=127.0.0.1:52275,suspend=y,server=n, -Djosm.dir.name=JOSM-dev, -javaagent:/opt/intellij-idea-ce-eap/plugins/Groovy/lib/agent/gragent.jar, -javaagent:/opt/intellij-idea-ce-eap/plugins/java/lib/rt/debugger-agent.jar, -agentpath:/tmp/libmemory_agent4.so=, -Dfile.encoding=UTF-8]
2020-02-12 21:48:44.191 SCHWERWIEGEND: Exception raised in EDT: java.util.concurrent.ExecutionException: java.lang.ArrayIndexOutOfBoundsException: Index 1 out of bounds for length 1. Ursache: java.lang.ArrayIndexOutOfBoundsException: Index 1 out of bounds for length 1
java.util.concurrent.ExecutionException: java.lang.ArrayIndexOutOfBoundsException: Index 1 out of bounds for length 1
	at java.base/java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.base/java.util.concurrent.FutureTask.get(FutureTask.java:191)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitAndReturn(GuiHelper.java:270)
	at org.openstreetmap.josm.gui.bugreport.BugReportDialog.showFor(BugReportDialog.java:232)
	at org.openstreetmap.josm.tools.bugreport.BugReportQueue.displayFor(BugReportQueue.java:134)
	at org.openstreetmap.josm.tools.bugreport.BugReportQueue.access$200(BugReportQueue.java:17)
	at org.openstreetmap.josm.tools.bugreport.BugReportQueue$BugReportDisplayRunnable.run(BugReportQueue.java:100)
	at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: java.lang.ArrayIndexOutOfBoundsException: Index 1 out of bounds for length 1
	at org.openstreetmap.josm.actions.ShowStatusReportAction.getReportHeader(ShowStatusReportAction.java:170)
	at org.openstreetmap.josm.gui.bugreport.DebugTextDisplay.<init>(DebugTextDisplay.java:52)
	at org.openstreetmap.josm.gui.bugreport.BugReportDialog.<init>(BugReportDialog.java:62)
	at org.openstreetmap.josm.gui.bugreport.BugReportDialog.lambda$showFor$3(BugReportDialog.java:242)
	at java.base/java.util.concurrent.FutureTask.run$$$capture(FutureTask.java:264)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java)
	at java.desktop/java.awt.event.InvocationEvent.dispatch$$$capture(InvocationEvent.java:313)
	at java.desktop/java.awt.event.InvocationEvent.dispatch(InvocationEvent.java)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:770)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:740)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

Attachments (0)

Change History (1)

comment:1 Changed 5 days ago by simon04

Resolution: fixed
Status: assignedclosed

In 15849/josm:

fix #18708 - ArrayIndexOutOfBoundsException in ShowStatusReportAction

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.