Modify

Opened 10 years ago

Closed 10 years ago

#1868 closed defect (fixed)

wmsplugin: Unable to max-out yahoo resolution

Reported by: mcdmx@… Owned by: framm
Priority: major Milestone:
Component: Plugin Version: latest
Keywords: Cc:

Description

The WMS-Plugin is unable to download high-resolution tiles from Yahoo, e.g. compare:

http://maps.yahoo.com/#mvt=s&lat=37.615002&lon=-122.38285&zoom=21

to the screenshot attached.

Zooming in and hitting "Change resolution" produces even worse results.

WMS-Plugin version: 12439

Attachments (1)

snapshot.jpg (55.2 KB) - added by mcdmx@… 10 years ago.

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by mcdmx@…

Attachment: snapshot.jpg added

comment:1 Changed 10 years ago by anonymous

Summary: wmsplugin (new): Unable to max-out resolutionwmsplugin: Unable to max-out yahoo resolution

comment:2 Changed 10 years ago by stoecker

This resolution seems not to be reachable using the Yahoo API or there is some trick. Using the normal API description I was unable to reach that accuracy.

comment:3 in reply to:  2 Changed 10 years ago by mcdmx@…

Potlatch is able to get the full Yahoo imagery resolution... Aren't they using the same API as the WMS plugin?

comment:4 Changed 10 years ago by stoecker

Hmm, they use Flash API not JavaScript. The page you refer above alsouses JavaScript, but of a totally different form. I really do not know.

At least I was unable to increase resolution with the JavaScript API. It is on zoom level 1 and this is the highest possible level (is reversed compared to OSM).

comment:5 Changed 10 years ago by xeen

The problem is that you can only specify zoom levels up to 1 (see [0]). There seems to be a radius switch, as explained here [1] that allows with a low value [2] to achieve very good zoom levels, see [3]. However, it's not possible to switch the latter to sat mode, at least not in an obvious way that isn't hacking the API and we certainly don't want to do that. My guess is that we'll have to teach webkit using flash and use the flash API.

comment:6 Changed 10 years ago by amettler@…

FYI, the highest resolution tiles on yahoo are actually public domain imagery from USGS, which can also be obtained from terraservice.net's WMS feed (this only has data in those places where Yahoo has the high-res images):

wmsplugin.url.x.name=Terraserver Urban
wmsplugin.url.x.url=http://terraservice.net/ogcmap.ashx?version=1.1.1&request=GetMap&Layers=urbanarea&Styles=&SRS=EPSG:4326&format=image/jpeg&

(topo maps are available too, see my user page http://wiki.openstreetmap.org/wiki/User:Speight)

comment:7 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

Added to the data sources of WMS plugin.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.